5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
17 Source0: %{name}-%{version}.tar.bz2
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
27 Summary: Monitor account initialization for the root image.
28 Group: Applications/System
31 Monitor is a collection of secondary scripts for configuring the node polling
32 system, syncing the PLC db with the monitoring database, notifying users,
33 interacting with PCU hardware, applying penalties to sites that violate
36 ######################################## CLIENT
39 Summary: Monitor hooks for a PLC node
40 Group: Applications/System
45 The client scripts handle account creation inside of a node. This will
46 include configuration setup for the monitoring agent running on the node. It
47 will also include any cron or init scripts needed to perform this kind of
49 ######################################## Server Deps
51 Summary: Monitor hooks for the PLC server.
52 Group: Applications/System
55 Requires: python-setuptools-devel
56 Requires: python-peak-util-extremes
59 Requires: compat-libstdc++-296
60 Requires: openssh-clients
61 Requires: perl-libwww-perl
62 Requires: perl-IO-Socket-SSL
63 Requires: MySQL-python
67 Requires: plewww-plekit
69 #Requires: zabbix-client
71 #Requires: zabbix-server
73 %description server-deps
74 The server side include all python modules and scripts needed to fully
76 ######################################## Server
78 Summary: Monitor hooks for the PLC server.
79 Group: Applications/System
83 Requires: monitor-server-deps
84 Requires: monitor-pcucontrol
85 Requires: PLCWWW >= 4.2
86 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
89 The server side include all python modules and scripts needed to fully
90 operation, track, and interact with any third-party monitoring software, such
93 ######################################## PCU Control
96 summary: pcu controls for monitor and plcapi
97 group: applications/system
99 requires: OpenIPMI-tools
101 %description pcucontrol
102 both monitor and the plcapi use a set of common commands to reboot machines
103 using their external or internal pcus. this package is a library of several
106 ####################################### RunlevelAgent
107 %package runlevelagent
108 summary: the RunlevelAgent that reports node runlevels
109 group: applications/system
112 %description runlevelagent
113 The RunlevelAgent starts as early as possible during boot-up and production
114 mode to actively report the observed runlevel to PLC and update the
115 'last_contact' field.
121 # NOTE: the build uses g++ cmdamt/
122 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
123 cd pcucontrol/models/intelamt
124 export TMPDIR=$PWD/tmp
129 rm -rf $RPM_BUILD_ROOT
130 #################### CLIENT
131 install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
132 install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
134 #################### SERVER
135 install -d $RPM_BUILD_ROOT/usr/share/%{name}
136 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
137 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
138 install -d $RPM_BUILD_ROOT/var/lib/%{name}
139 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
140 install -d $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
141 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
143 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
144 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
145 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
147 echo " * Installing core scripts"
148 rsync -a --exclude www --exclude archive-pdb --exclude .svn --exclude CVS \
149 ./ $RPM_BUILD_ROOT/usr/share/%{name}/
151 echo " * Installing web pages"
152 rsync -a www/ $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
153 rsync -a log/ $RPM_BUILD_ROOT/var/www/html/monitorlog/
155 echo " * Installing cron job for automated polling"
156 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
157 echo " * TODO: Setting up Monitor account in local MyPLC"
160 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
161 install -d -D -m 755 monitor $RPM_BUILD_ROOT/%{python_sitearch}/monitor
162 # TODO: need a much better way to do this.
163 rsync -a monitor/ $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
164 #for file in __init__.py database.py config.py ; do
165 # install -D -m 644 monitor/$file $RPM_BUILD_ROOT/%{python_sitearch}/monitor/$file
167 rsync -a pcucontrol/ $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
168 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
170 touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
171 chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
173 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
174 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
176 #################### RunlevelAgent
177 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
178 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
180 mkdir -p $RPM_BUILD_ROOT/var/log
181 touch $RPM_BUILD_ROOT/var/log/server-deps.log
185 rm -rf $RPM_BUILD_ROOT
188 /var/log/server-deps.log
191 %defattr(-,root,root)
192 #%config /usr/share/%{name}/monitorconfig.py
193 #%config /etc/monitor.conf
196 /var/www/cgi-bin/monitor
197 %{_sysconfdir}/cron.d/monitor-server.cron
198 %{python_sitearch}/threadpool.py
199 %{python_sitearch}/threadpool.pyc
200 %{python_sitearch}/threadpool.pyo
201 %{python_sitearch}/monitor
202 %{_sysconfdir}/plc.d/monitor
203 %{_sysconfdir}/plc.d/monitor.functions
204 %{_sysconfdir}/plc.d/zabbix
207 %defattr(-,root,root)
208 %{_initrddir}/monitor
209 %{_sysconfdir}/cron.d/monitor
212 %{python_sitearch}/pcucontrol
215 /usr/bin/RunlevelAgent.py
216 /usr/bin/RunlevelAgent.pyo
217 /usr/bin/RunlevelAgent.pyc
218 /%{_initrddir}/monitor-runlevelagent
221 #easy_install --build-directory /var/tmp -UZ ElementTree
222 ##easy_install --build-directory /var/tmp -UZ http://pypi.python.org/packages/2.5/E/Extremes/Extremes-1.1-py2.5.egg
225 ## TODO: something is bad wrong with this approach.
226 easy_install --build-directory /var/tmp -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
227 easy_install --build-directory /var/tmp -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
228 easy_install --build-directory /var/tmp -UZ Elixir
230 # crazy openssl libs for racadm binary
231 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
232 mkdir /usr/share/monitor/.ssh
233 chmod 700 /usr/share/monitor/.ssh
235 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
236 sed -i -e 's/^session required pam_loginuid.so/#session required pam_loginuid.so/g' /etc/pam.d/crond
238 # NOTE: add the default xml stuff if it's not already in the default xml config.
239 if ! grep '<category id="plc_monitor">' /etc/planetlab/default_config.xml ; then
240 sed -i 's|<category id="plc_net">| <category id="plc_monitor">\n <name>Monitor Service Configuration</name>\n <description>Monitor</description>\n <variablelist>\n <variable id="enabled" type="boolean">\n <name>Enabled</name>\n <value>true</value>\n <description>Enable on this machine.</description>\n </variable>\n <variable id="email">\n <value></value>\n </variable>\n <variable id="dbpassword">\n <value></value>\n </variable>\n <variable id="host" type="hostname">\n <name>Hostname</name>\n <value>pl-virtual-06.cs.princeton.edu</value>\n <description>The fully qualified hostname.</description>\n </variable>\n <variable id="ip" type="ip">\n <name>IP Address</name>\n <value/>\n <description>The IP address of the monitor server.</description>\n </variable>\n </variablelist>\n </category>\n <category id="plc_net">|' /etc/planetlab/default_config.xml
242 if ! grep '<category id="plc_zabbix">' /etc/planetlab/default_config.xml ; then
243 sed -i 's|<category id="plc_net">| <category id="plc_zabbix">\n <name>Zabbix Configuration</name>\n <description>Zabbix</description>\n <variablelist>\n <variable id="enabled" type="boolean">\n <name>Enabled</name>\n <value>false</value>\n <description>Enable on this machine.</description>\n </variable>\n <variable id="host" type="hostname">\n <name>Hostname</name>\n <value>localhost.localdomain</value>\n <description>The fully qualified hostname.</description>\n </variable>\n <variable id="ip" type="ip">\n <name>IP Address</name>\n <value/>\n <description>The IP address of the Zabbix server.</description>\n </variable>\n </variablelist>\n </category>\n <category id="plc_net">|' /etc/planetlab/default_config.xml
246 # NOTE: enable monitor by default, since we're installing it.
247 plc-config --save /etc/planetlab/default_config.xml \
248 --category plc_monitor --variable enabled --value true
251 # TODO: this will be nice when we have a web-based service running., such as
252 # an API server or so on.
253 # TODO: create real monitorconfig.py from monitorconfig-default.py
254 # TODO: create monitorconfig.php using phpconfig.py
255 # TODO: create symlink in /var/lib/monitor for chroot environments
256 # TODO: update the content of automate_pl03.sh
257 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
259 # NOTE: generate the python defines from zabbix include files.
260 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
262 # apply patches to zabbix
263 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
265 #chkconfig --add monitor-server
266 #chkconfig monitor-server on
269 chkconfig --add monitor
273 chkconfig --add monitor-runlevelagent
274 chkconfig monitor-runlevelagent on
275 if [ "$PL_BOOTCD" != "1" ] ; then
276 service monitor-runlevelagent restart
281 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
283 - improved templates and views
284 - cleaned controller code for web
285 - added IPMI requirement to pcucontrol package.
287 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
288 - added bootmanager log links
289 - addressed root cause of IntegrityErrors ; big deal
290 - adjusted templates to accomodate fix for IntegrityErrors
291 - added session.flush() to bootman.py to write out ActionsRecords
292 - fixed policy to either pause penalties or apply them ; not both.
294 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
295 -- Added Rpyc from 1.0 branch.
297 -- add setup-agent for password protected keys.
298 -- other minor improvements.
300 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
304 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
307 - added statistics dir
309 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
310 - remove plccache from controllers, all lookups from db.
311 - reformat emailTxt messags
312 - updated bootstates in bootman.py
314 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
315 - tag of latest changes.
316 - need to test end to end.
318 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
319 - big merge from the 2.0 branch
321 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
322 - minor improvements in rendering with sortable tables
324 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
326 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
327 - first draft with sortable tables + checkpoint
329 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
330 - use plekit tables from plewww.
331 - depend on plewww-plekit
333 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
335 - fix for package name dependency
338 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
339 - add improved docs to the latest build and tag.
341 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
342 - add documentation hooks for adding in-line docs like NM and PLCAPI
344 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
345 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
346 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
347 - 'safeboot', 'failboot', 'reinstall', etc.
349 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
350 - same as 2.0-12 tag.
352 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
353 - merge from 2.0, remove more zabbix code, simplify install, etc.
355 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
356 - major merge from 2.0 branch.
357 - ready to be updated with 4.3 and web changes.
359 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
360 - preparing to make a 2.0 branch for monitor.
362 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
363 - new changes are significantly different, that I'm upping the number for clarity.
365 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
366 - These are all changes in the latest Monitor code. I will branch this version
367 - next, before making additional large changes.
369 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
370 - Checkpointing current version for 4.2-rc21 - many many changes
372 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
373 - This is a major tag of every thing. probably needs a very different release
376 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
377 - Incremental improvements
379 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
380 - tagging everything for OneLab tech-transfer.
383 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
386 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
389 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
390 - This should be ready for 4.2rc2
393 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
396 %define module_current_branch 2.0