1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
3 %define name NodeManager
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
9 Summary: PlanetLab Node Manager
14 Group: System Environment/Daemons
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19 Packager: PlanetLab Central <support@planet-lab.org>
20 Distribution: PlanetLab %{plrelease}
23 # not possible because of forward_api_calls
27 #Obsoletes: sidewinder, sidewinder-common
29 # Uses function decorators
30 Requires: python >= 2.4
32 Requires: python-pycurl
36 Requires: vserver-%{slicefamily}
37 # our interface to the vserver patch
38 Requires: util-vserver >= 0.30.208-17
40 Requires: util-vserver-python > 0.3-16
42 Requires: pyplnet >= 4.3
45 The PlanetLab Node Manager manages all aspects of PlanetLab node and
46 slice management once the node has been initialized and configured by
47 the Boot Manager. It periodically contacts its management authority
48 for configuration updates. It provides an XML-RPC API for performing
49 local operations on slices.
55 # make manages the C and Python stuff
56 %{__make} %{?_smp_mflags}
59 # make manages the C and Python stuff
60 rm -rf $RPM_BUILD_ROOT
61 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
63 # install the sliver initscript (that triggers the slice initscript if any)
64 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
65 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
66 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
68 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
69 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
70 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
72 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
74 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
78 # tmp - handle file renamings; old names are from 2.0-8
80 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
81 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
82 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
83 /var/log/nm@/var/log/nodemanager
84 /var/log/nm.daemon@/var/log/nodemanager.daemon
85 /var/run/nm.pid@/var/run/nodemanager.pid
86 /tmp/sliver_mgr.api@/tmp/nodemanager.api
87 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
89 for renaming in $renamings; do
90 old=$(echo $renaming | cut -d@ -f1)
91 new=$(echo $renaming | cut -d@ -f2)
92 newdir=$(dirname $new)
93 if [ -e "$old" -a ! -e "$new" ] ; then
99 chkconfig --add conf_files
100 chkconfig conf_files on
103 chkconfig --add fuse-pl
105 if [ "$PL_BOOTCD" != "1" ] ; then
107 service fuse-pl restart
112 # 0 = erase, 1 = upgrade
113 if [ $1 -eq 0 ] ; then
114 chkconfig fuse-pl off
115 chkconfig --del fuse-pl
118 chkconfig conf_files off
119 chkconfig --del conf_files
123 rm -rf $RPM_BUILD_ROOT
126 %defattr(-,root,root,-)
127 %{_datadir}/NodeManager/
128 %{_bindir}/forward_api_calls
130 %{_sysconfdir}/logrotate.d/nodemanager
134 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
135 - Catch all exceptions for sfa plugin
137 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
138 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
140 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
141 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
143 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
144 - plugins/sliverauth.py improvements
146 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
147 - Disable sfagids plugin
149 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
150 - Re-tag nodemanager to include conflicted commits
152 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
153 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
154 - sfagids plugin deleted
155 - band-aid patch for lack of GetSliceFamily removed
157 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
159 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
160 - revert curlwrapper to former forking-curl version
161 - fixes in the omf plugin for ssh key location and node hrn
162 - set umask 0022 in tools.daemon
164 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
165 - configure omf-resctl for keys
167 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
170 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
171 - name changes and fix typos
173 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
174 - remove config and options parameters from start function
176 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
177 - working version of reservable nodes
178 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
179 - dismantled the -s|--startup option (no convincing need for that)
180 - simpler and more robust init.d/nm
181 - initscript content management through replace_file_with_string
182 - sliverauth uses replace_file_with_string
183 - curlwrapper has a debug mode
185 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
186 - pretty-printing/normalized python code - hopefully neutral
188 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
189 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
190 - that triggers /etc/init.d/vinit.slice if present and executable
191 - (2) install the slice-provided initscript (as per the initscript tag) as
192 - /etc/init.d/vinit.slice
193 - (3) as a result the initscript are now triggered by rc as part of the
194 - standard vserver .. start, properly attached to the vserver,
195 - and properly killed upon vserver .. stop
196 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
198 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
199 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
200 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
201 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
202 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
203 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
204 - cleanup: nodemanger now is a class; however plugins are still dumb modules
205 - cleanup: does not depend on obsolete Set
207 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
210 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
211 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
212 - Added some precautions to the slice id-saving code
213 - Added log message to code that records the slice id
215 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
216 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
217 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
218 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
220 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
221 - fix log_call in plugins/drl.py
223 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
224 - protect against nodes in migrated PLC's not having the hrn tag yet
226 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
227 - new omf-resctl and drl plugins
228 - specialaccount optimized to overwrite authorized keys only upon changes
229 - codemux plugin has support for a new 'ip' setting
230 - mainloop to display ordered modules&plugins at all times
232 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
233 - modules and plugins have a priority
234 - specialaccounts appears soon in the priority chain
235 - logger.log_call logs process output, and has a timeout
236 - vuser{add,del} run through bash -x
237 - nm initscript has support for 'service nm restartverbose'
238 - logs reviewed for consistency
239 - use hashlib module instead of sha when available
241 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
242 - first working version of 5.0:
243 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
244 - nodefamily is 3-fold with pldistro-fcdistro-arch
245 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
246 - (in addition to the 'vref' tag that's still exposed too)
247 - logging reviewed for more convenience
248 - support for 'service nm restartdebug'
249 - make sync knows how to publish uncommitted code on a test node
251 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
252 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
254 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
255 - support for f10 and f12 in the vref slice tag
257 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
259 - uses slicename 'sfacm' instead of 'genicw'
261 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
262 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
263 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
266 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
267 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
268 - self-contained. With this change, they will be able to refer to the attributes associated with a
271 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
272 - fix for syntax error
274 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
275 - -fixed problem with sioc import at the build side
276 - -bwlimit.set() now accepts the device and does not asume that it is eth0
278 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
279 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
281 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
282 - The seed for random previously was the meaning of life (i.e., 42) but
283 - that resulted in a not so random choice for the hmac. This
284 - implementation now uses a random.seed that is based on the current
287 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
288 - Minor fix such that sliverauth.py makes a more specific call to
289 - GetSliceTags that include that specific tagname it is looking for.
291 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
292 - Fix bug that prevented 'OVERRIDES' for working correctly.
294 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
295 - Increase disk limits to 10G per sliver
296 - Sanity check slice for home directory before starting (hack)
297 - Check codemux arguments
299 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
301 - * Move plcapi in plugin-api GetSlivers() calls.
302 - * Persistent Authcheck and resync session when auth failure
304 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
305 - Disabling sliverauth module. Not ready for deployment.
307 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
308 - Fixing overrides semantics.
310 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
311 - Generalized plugins
312 - Fixed initscript start up bug.
314 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
315 - * Fix delegation authentication problem
316 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
318 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
319 - * Rerun initscripts when slice goes from disabled to enabled.
321 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
322 - * Update session key when out of synch with PLC
323 - * PLCDefaults uses tagname
325 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
326 - log invokations of vsys
328 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
330 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
332 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
333 - Codemux supports multiple hosts mapping to single slice
334 - Fixed bug in delegation support where tickets delivered weren't
335 being passed to sm.deliver_ticket().
336 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
337 - Codemux now configured via slice attribute (host,port)
338 - Support for multiple vserver reference images (including different archs)
339 - Mom BW emails are sent to list defined by MyPLC's config
340 - Sirius BW loans honored correctly. Fixed.
341 - BW totals preserved for dynamic slices so as not to game the system.
342 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
343 - Configures vsys via vsys slice attribute {name: vsys, value: script}
344 - CPU reservations are now calculated via percentages instead of shares
345 - BW totals preserved for dynamic slices
346 - Closes bug where node cap sets off bw slice alarms for all slices.
348 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
351 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> -
354 %define module_current_branch 1.8