Setting tag NodeManager-2.0-6
[nodemanager.git] / NodeManager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
7
8 %define name NodeManager
9 %define version 2.0
10 %define taglevel 6
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Summary: PlanetLab Node Manager
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: System Environment/Daemons
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 # not possible because of forward_api_calls
29 #BuildArch: noarch
30
31 # Old Node Manager
32 Obsoletes: sidewinder, sidewinder-common
33
34 # vuseradd, vuserdel
35 Requires: vserver-%{slicefamily}
36 Requires: util-vserver >= 0.30.208-17
37
38 # vserver.py
39 Requires: util-vserver-python > 0.3-16
40
41 # Signed tickets
42 Requires: gnupg
43
44 # Contact API server
45 Requires: curl
46
47 # Uses function decorators
48 Requires: python >= 2.4
49
50 # sioc/plnet
51 Requires: pyplnet >= 4.3
52
53 %description
54 The PlanetLab Node Manager manages all aspects of PlanetLab node and
55 slice management once the node has been initialized and configured by
56 the Boot Manager. It periodically contacts its management authority
57 for configuration updates. It provides an XML-RPC API for performing
58 local operations on slices.
59
60 %prep
61 %setup -q
62
63 %build
64 # make manages the C and Python stuff
65 %{__make} %{?_smp_mflags}
66
67 %install
68 # make manages the C and Python stuff
69 rm -rf $RPM_BUILD_ROOT
70 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
71
72 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
73 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
74 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
75
76 install -D -m 644 logrotate/nm $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
77
78 %post
79 chkconfig --add conf_files
80 chkconfig conf_files on
81 chkconfig --add nm
82 chkconfig nm on
83 chkconfig --add fuse-pl
84 chkconfig fuse-pl on
85 if [ "$PL_BOOTCD" != "1" ] ; then
86         service nm restart
87         service fuse-pl restart
88 fi
89
90
91 %preun
92 # 0 = erase, 1 = upgrade
93 if [ $1 -eq 0 ] ; then
94     chkconfig fuse-pl off
95     chkconfig --del fuse-pl
96     chkconfig nm off
97     chkconfig --del nm
98     chkconfig conf_files off
99     chkconfig --del conf_files
100 fi
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %files
106 %defattr(-,root,root,-)
107 %{_datadir}/NodeManager/
108 %{_bindir}/forward_api_calls
109 %{_initrddir}/
110 %{_sysconfdir}/logrotate.d/nm
111
112 %changelog
113 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
114 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
115 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
116 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
117
118 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
119 - fix log_call in plugins/drl.py
120
121 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
122 - protect against nodes in migrated PLC's not having the hrn tag yet
123
124 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
125 - new omf-resctl and drl plugins
126 - specialaccount optimized to overwrite authorized keys only upon changes
127 - codemux plugin has support for a new 'ip' setting
128 - mainloop to display ordered modules&plugins at all times
129
130 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
131 - modules and plugins have a priority
132 - specialaccounts appears soon in the priority chain
133 - logger.log_call logs process output, and has a timeout
134 - vuser{add,del} run through bash -x
135 - nm initscript has support for 'service nm restartverbose'
136 - logs reviewed for consistency
137 - use hashlib module instead of sha when available
138
139 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
140 - first working version of 5.0:
141 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
142 - nodefamily is 3-fold with pldistro-fcdistro-arch
143 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
144 - (in addition to the 'vref' tag that's still exposed too)
145 - logging reviewed for more convenience
146 - support for 'service nm restartdebug'
147 - make sync knows how to publish uncommitted code on a test node
148
149 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
150 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
151
152 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
153 - support for f10 and f12 in the vref slice tag
154
155 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
156 - build on fedora12
157 - uses slicename 'sfacm' instead of 'genicw'
158
159 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
160 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
161 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
162 - days ago.
163
164 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
165 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
166 - self-contained. With this change, they will be able to refer to the attributes associated with a
167 - slice.
168
169 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
170 - fix for syntax error
171
172 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
173 - -fixed problem with sioc import at the build side
174 - -bwlimit.set() now accepts the device and does not asume that it is eth0
175
176 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
177 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
178
179 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
180 - The seed for random previously was the meaning of life (i.e., 42) but
181 - that resulted in a not so random choice for the hmac.  This
182 - implementation now uses a random.seed that is based on the current
183 - time.
184
185 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
186 - Minor fix such that sliverauth.py makes a more specific call to
187 - GetSliceTags that include that specific tagname it is looking for.
188
189 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
190 - Fix bug that prevented 'OVERRIDES' for working correctly.
191
192 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
193 - Increase disk limits to 10G per sliver
194 - Sanity check slice for home directory before starting (hack)
195 - Check codemux arguments
196
197 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
198 - * Fix Delegation
199 - * Move plcapi in plugin-api GetSlivers() calls.
200 - * Persistent Authcheck and resync session when auth failure
201
202 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
203 - Disabling sliverauth module.  Not ready for deployment.
204
205 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
206 - Fixing overrides semantics.
207
208 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
209 - Generalized plugins
210 - Fixed initscript start up bug.
211
212 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
213 - * Fix delegation authentication problem
214 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
215
216 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
217 - * Rerun initscripts when slice goes from disabled to enabled.
218
219 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
220 - * Update session key when out of synch with PLC
221 - * PLCDefaults uses tagname
222
223 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
224 - log invokations of vsys
225
226 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
227
228 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
229
230 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
231 - Codemux supports multiple hosts mapping to single slice
232 - Fixed bug in delegation support where tickets delivered weren't
233   being passed to sm.deliver_ticket().
234 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
235 - Codemux now configured via slice attribute (host,port)
236 - Support for multiple vserver reference images (including different archs)
237 - Mom BW emails are sent to list defined by MyPLC's config
238 - Sirius BW loans honored correctly.  Fixed.
239 - BW totals preserved for dynamic slices so as not to game the system.
240 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
241 - Configures vsys via vsys slice attribute {name: vsys, value: script}
242 - CPU reservations are now calculated via percentages instead of shares
243 - BW totals preserved for dynamic slices
244 - Closes bug where node cap sets off bw slice alarms for all slices.
245
246 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
247 - Switched to SVN.
248
249 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
250 - Initial build.
251
252 %define module_current_branch 1.8