0eba9b57b72a59c507431870f0c93cfc15632d9e
[plewww.git] / PLCWWW.spec
1 #
2 # $Id: PLCWWW.spec 1206 2008-03-03 15:49:07Z thierry $
3 #
4 %define module_taglevel_varname subversion
5 %define name PLCWWW
6 %define version 4.2
7 %define subversion 8
8
9 %define release %{subversion}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10
11 Summary: PlanetLab Central (PLC) Web Pages
12 Name: %{name}
13 Version: %{version}
14 Release: %{release}
15 License: PlanetLab
16 Group: Applications/Systems
17 Source0: %{name}-%{version}.tar.gz
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19 BuildArch: noarch
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: http://svn.one-lab.org/svn/new_plc_www/
25
26 %description
27 The plcwww packages provides the web pages that run on
28 top of the PLCAPI component to provide the Web User Interface to the
29 PLC installation.
30 This package was formerly embedded together with MyPLC, but there
31 clearly is a need for separate upgrade of this component.
32
33 # on centos5, when rebuilding the full monty I am getting this time
34 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
35 # and the perl-GD rpm is nowhere to be found
36 # this somehow must be because of plot-latlong again; let's try this
37 AutoReqProv: no
38 # upon failure I'd trash plot-latlong altogether
39
40 %prep
41 %setup -q
42
43 %build
44 echo "There is no build stage for this component"
45 echo "All files just need to be installed as is from the codebase"
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 #
51 # plcwww
52 #
53
54 echo "* PLCWWW: Installing web pages"
55 mkdir -p $RPM_BUILD_ROOT/var/www/html
56 # let's be conservative and exclude codebase files, though there should not be any
57 rsync -a --exclude \*.spec --exclude .svn --exclude CVS ./ $RPM_BUILD_ROOT/var/www/html/
58
59 echo "* PLCWWW: Installing drupal config for httpd"
60 install -D -m 644 drupal.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/drupal.conf
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(-,root,root,-)
67 /var/www/html
68 /etc/httpd/conf.d/drupal.conf
69
70 %changelog
71 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
72 - noarch
73
74 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
75 - should fix yum.conf on nodes after install
76
77 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
78 - uses different path for getbootmedium results - should be safer
79
80 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
81 - comon icon replaced with the one from the comon website
82
83 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
84 - displays rpms in the about page
85
86 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
87 - safer, reference-less, way to implement layout mechnism - see
88 - settings.php for details
89 - setting types properly displayed according to user's role
90 - setting deletion : fixed (was still using code from slice attribute)
91 - more comon buttons : in the nodes and peers index pages
92 - comon_button knows about peer_id
93
94 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
95 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
96
97 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
98 - Initial build.