6 %define nodefamily %{pldistro}-%{_arch}
8 %define name bootcd-%{nodefamily}
12 # pldistro already in the rpm name
13 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14 %define release %{taglevel}%{?date:.%{date}}
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %(echo %{url} | cut -d ' ' -f 2)
21 Summary: Boot CD material for %{nodefamily}
26 Group: System Environment/Base
27 Source0: %{name}-%{version}.tar.gz
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29 # other archs must be able to install this
32 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
37 %define debug_package %{nil}
40 The Boot CD securely boots PlanetLab nodes into an immutable
49 # Build the reference image
50 ./prep.sh %{pldistro} %{nodefamily}
55 rm -rf $RPM_BUILD_ROOT
59 # Install the reference image and build scripts
60 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
61 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
62 install -m 755 kvariant.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
64 build/isofs/bootcd.img \
70 tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
75 rm -rf $RPM_BUILD_ROOT
78 if [ -n "$SUDO_USER" ] ; then
79 # Allow user to delete the build directory
80 chown -h -R $SUDO_USER .
81 # Some temporary cdroot files like /var/empty/sshd and
82 # /usr/bin/sudo get created with non-readable permissions.
83 find . -not -perm +0600 -exec chmod u+rw {} \;
84 # Allow user to delete the built RPM(s)
85 chown -h -R $SUDO_USER %{_rpmdir}/*
89 %defattr(-,root,root,-)
93 [ -f /etc/planetlab/nodefamily ] || { mkdir -p /etc/planetlab ; echo %{nodefamily} > /etc/planetlab/nodefamily ; }
96 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-16
97 - fix build on fedora12
99 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-15
100 - record the ntp time to the hwclock. this is a bootcd operation, but it is
101 - repeated in the bootmanager to handle all CDs without this operation
103 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-14
104 - Daniel's update to generalize the kvariant support.
106 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-13
107 - robust to node config file specified with a relative path
109 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-12
110 - fix specfile - 4.2-11 would not build
112 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-11
113 - Added support for handling kernel variants
114 - http://svn.planet-lab.org/wiki/BootcdVariant
116 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-10
117 - mkfs.vfat output removed prior to invokation - fix needed on fedora 10
119 * Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-9
122 * Sat Dec 13 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-8
124 - Add a site_admin account to the BootCD.
125 - Add some explanations for common errors.
127 * Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-7
128 - Allow multiple -k options to the build.sh script.
129 - Probe devices in PCI bus order.
131 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-6
132 - add support for fedora9 images - compliant with upstart
133 - formerly monolythic dir 'conf_files/' split into 'etc/' and 'initscripts/'
135 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-5
136 - cosmetic - pl_boot to display timestamps
138 * Mon Aug 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-4
139 - adds -k as an argument to build.sh to pass additional kernel parameters to the
140 - bootcd and kexec kernel.
142 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-3
143 - rpm release tag does not need pldistro as it is already part of the rpm name
145 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-2
146 - change location of nodefamily in /etc/planetlab/
148 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
149 - new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
150 - now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7)
151 - nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
153 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
154 - kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
155 - build.sh cleaned up in the process
156 - actual location of selected node config file displayed
157 - import pypci rather than pypciscan
159 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
160 - build.sh support for -s <console_spec> (recommended vs using type)
161 - build.sh cleanup - usage clearer wrt types - removed old code
162 - fixed modprobe with args in pl_hwinit
164 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
165 - load floppy with modprobe flags
166 - support for creating a usb partition
167 - removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
169 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> -
170 - added biginitrd usb image
172 * Fri Sep 2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> -
175 %define module_current_branch 3.4