6c9eb769e6ffd46e77739dd116c073f87441b77c
[bootmanager.git] / bootmanager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name bootmanager
7 %define version 3.2
8 %define taglevel 19
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: The PlanetLab Boot Manager
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: BSD
22 Group: System Environment/Base
23 Source0: %{name}-%{version}.tar.gz
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25
26 Requires: tar, gnupg, sharutils, bzip2, pypcilib
27
28 AutoReqProv: no
29 %define debug_package %{nil}
30
31 %description
32 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
33 nodes.
34
35 %prep
36 %setup -q
37
38 %build
39 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 # Install source so that it can be rebuilt
45 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/
46
47 touch bootmanager.sh
48 install -D -m 755 bootmanager.sh $RPM_BUILD_ROOT/var/www/html/boot/bootmanager.sh
49
50 # This is only required for 2.x bootcds.
51 install -D -m 644 support-files/uudecode.gz $RPM_BUILD_ROOT/var/www/html/boot/uudecode.gz
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 # If run under sudo
57 if [ -n "$SUDO_USER" ] ; then
58     # Allow user to delete the build directory
59     chown -h -R $SUDO_USER .
60     # Some temporary cdroot files like /var/empty/sshd and
61     # /usr/bin/sudo get created with non-readable permissions.
62     find . -not -perm +0600 -exec chmod u+rw {} \;
63     # Allow user to delete the built RPM(s)
64     chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
65 fi
66
67 %post
68 cat <<EOF
69 Remember to GPG sign /var/www/html/boot/bootmanager.sh with the
70 PlanetLab private key.
71 EOF
72
73 %files
74 %defattr(-,root,root,-)
75 %{_datadir}/%{name}
76 %ghost /var/www/html/boot/bootmanager.sh
77 /var/www/html/boot/uudecode.gz
78
79 %changelog
80 * Wed Apr 15 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-3.2-19
81 - Only use
82 - /etc/modprobe.d/blacklist
83 - /etc/modprobe.d/blacklist-compat
84 - /etc/modprobe.d/blacklist-firewire
85 - as the blacklist files.
86 - When no ethernet interfaces can be found for the production kernel set
87 - the BOOT_STATE to failboot, rather than dbg.
88
89 * Mon Apr 13 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-3.2-18
90 - looks like some modprobe fixes
91 - added nuke_lvm functions
92 - use 'sort' instead of 'sorted' for backward compatibility.
93
94 * Thu Feb 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-17
95 - from trunk : upload logs on myplc
96 - from trunk : early sshd start
97 - tweaked fstab for remount after kexec
98 - modprobe write: uses new module from pyplnet
99
100 * Fri Feb 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-3.2-16
101 - removed 'sorted' so older versions of python could continue to run code
102 - fixed WriteNetworkConfig so that it returns the result of calls to the API
103 - added e2fsck prior to mounting any filesystem.
104
105 * Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-3.2-15
106 - Added in Daniel's support to only create a small /vserver and leave
107 - remaining disks alone so that their partitions can be used as raw
108 - disk extents by slices
109
110 * Mon Dec 15 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-3.2-14
111 - Use pyplnet.
112 - Order devices by PCI slot number.
113 - Module debugging code.
114
115 * Fri Sep 26 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-3.2-13
116 - include latest module tweaks in current production bootmanager.
117
118 * Tue Jul 08 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-3.2-12
119 - correctly convert port number to int before creating HTTPSConnection() object,
120 - plus other changes to file to accomodate this.
121
122 * Wed Jul 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-3.2-11
123 - More hacks.
124
125 * Tue Jul 01 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-3.2-10
126 - Make the hack work.
127
128 * Tue Jul 01 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-3.2-9
129 - Ugly hack stuff.
130
131 * Fri Jun 27 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - BootManager-3.2-8
132 - move the UpdateNodeConfiguration step after the NodeUpdate step in ChainBoot
133
134 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
135 - dont unload cpqphp
136
137 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
138 - changes in the state automaton logic 
139 - root+swap = 7G
140 - usb-key threshhold increased to 17 G
141 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
142
143 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
144 - renamed step InstallBootstrapRPM into InstallBootstrapFS
145 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
146 - import pypcimap rather than pypciscan
147 - initial downlaoding of plc_config made more robust
148 - root and /vservers file systems mounted ext3
149 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
150 - also seems to be using session-based authentication rather than former hmac-based one
151
152 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
153 - usage of wireless attributes fixed and tested
154 - breakpoints cleaned up (no change for production)
155 - less alarming message when floppy does not get unloaded
156
157 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
158 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
159 - removes legacy calls to PlanetLabConf.py 
160 - refrains from unloading floppy 
161 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
162
163 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
164 - Initial build.