6 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
7 %define extensionfamily %{distroname}-%{_arch}
9 %define name bootstrapfs-%{nodefamily}
13 # pldistro already in the rpm name
14 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
15 %define release %{taglevel}%{?date:.%{date}}
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %(echo %{url} | cut -d ' ' -f 2)
22 Summary: The PlanetLab Bootstrap Filesystems for %{nodefamily}
27 Group: System Environment/Base
28 Source0: %{name}-%{version}.tar.gz
29 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
30 # other archs must be able to install this
33 Requires: tar, gnupg, sharutils, bzip2
35 # 5.0 now has 3-fold nodefamily
36 %define obsolete_nodefamily %{pldistro}-%{_arch}
37 Obsoletes: bootstrapfs-%{obsolete_nodefamily}
40 %define debug_package %{nil}
44 The PlanetLab Bootstrap Filesystem(s) are downloaded by the
45 BootManager to instantiate a node with a new filesystem.
48 Summary: The (uncompressed) PlanetLab Bootstrap Filesystems for %{nodefamily}
49 Group: System Environment/Base
51 This package provides the same functions as %{name} but with uncompressed tarball for faster tests.
54 Summary: the MyPLC-side utilities for tweaking nodes yum configs
55 Group: System Environment/Base
56 %description -n nodeyum
57 Utility scripts for configuring node updates. This package is designed
65 ############################## node-side
67 ./build.sh %{pldistro}
70 ############################## server-side
71 pushd BootstrapFS/nodeconfig/yum
72 # scan fcdistros and catenate all repos in 'stock.repo' so db-config can be distro-independant
73 for fcdistro in $(ls); do
74 [ -d $fcdistro ] || continue
75 # get kexcludes for that distro
76 KEXCLUDE="exclude=$(../../../build/getkexcludes.sh -f $fcdistro)"
77 pushd $fcdistro/yum.myplc.d
78 echo "* Handling KEXCLUDE in yum repo for $fcdistro ($KEXCLUDE)"
79 for filein in $(find . -name '*.in') ; do
80 file=$(echo $filein | sed -e "s,\.in$,,")
81 sed -e "s,@KEXCLUDE@,$KEXCLUDE,g" $filein > $file
84 cat *.repo > stock.repo
90 rm -rf $RPM_BUILD_ROOT
92 ############################## node-side
96 install -D -m 644 bootstrapfs-%{nodefamily}.tar.bz2 \
97 $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar.bz2
98 install -D -m 644 bootstrapfs-%{nodefamily}.tar \
99 $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar
101 for pkgs in $(ls ../build/config.%{pldistro}/bootstrapfs-*.pkgs) ; do
102 NAME=$(basename $pkgs .pkgs | sed -e s,bootstrapfs-,,)
103 install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-%{extensionfamily}.tar.bz2 \
104 $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar.bz2
105 install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-%{extensionfamily}.tar \
106 $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar
110 ############################## server-side
111 # xxx unfinished business here
112 # xxx in a multi-flavour myplc, we should ship for all fcdistros
113 # and let the php scripts do the right thing
115 echo "* Installing MyPLC-side nodes yum config utilities"
116 # expose (fixed) myplc.repo.php as https://<plc>/yum/myplc.repo.php
117 install -D -m 644 ./nodeconfig/yum/myplc.repo.php $RPM_BUILD_ROOT/var/www/html/yum/myplc.repo.php
118 # expose the fcdistro-dependant yum.conf as https://<plc>/yum/yum.conf
119 install -D -m 644 ./nodeconfig/yum/%{distroname}/yum.conf $RPM_BUILD_ROOT/var/www/html/yum/yum.conf
120 # expose the (fcdistro-dependant) stock.repo as https://<plc>/yum/stock.repo
121 install -D -m 644 ./nodeconfig/yum/%{distroname}/yum.myplc.d/stock.repo $RPM_BUILD_ROOT/var/www/html/yum/stock.repo
123 # Install initscripts
124 echo "* Installing plc.d initscripts"
125 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
126 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
128 echo "* Installing db-config.d files"
129 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
130 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
131 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
135 rm -rf $RPM_BUILD_ROOT
139 %defattr(-,root,root,-)
140 /var/www/html/boot/bootstrapfs*.tar.bz2
143 %defattr(-,root,root,-)
144 /var/www/html/boot/bootstrapfs*.tar
147 %defattr(-,root,root,-)
149 /etc/planetlab/db-config.d
153 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-2
154 - new slicerepo package for exposing stuff to slivers
156 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-1
157 - first working version of 5.0:
158 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
159 - nodefailiy is 3-fold with pldistro-fcdistro-arch
160 - new module nodeyum; first draft has the php scripts and conf_files for tweaking nodes yum config
162 * Mon Jan 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-11
163 - for building on fedora12
165 * Thu Oct 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-10
166 - cosmetic change in message at build-time
168 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-9
169 - can use groups in the pkgs file with +++ for space
171 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-8
172 - bugfix for when a .post script is not needed
174 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-7
175 - search post-install scripts (.post) in path (distro, then planetlab)
176 - mostly useful for externally-defined pldistros
178 * Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-6
179 - fix build bug when dealing with extensions
181 * Thu Dec 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-5
182 - optional package bootstrapfs-<pldiftr>-<arch>-plain comes with uncompressed images for faster tests
184 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-4
185 - cosmetic changes in build: displays duration, and shows up in summary
187 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-3
188 - Do not overwrite yumgroups.xml upon updates of noderepo
190 * Thu Jul 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-2
191 - uses the right yum.conf when building images
193 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-1
194 - rpm release tag does not need pldistro as it is already part of the rpm name
196 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-0.1-2 BootstrapFS-1.0-0
197 - naming scheme changed, tarball name now contains ''nodefamily'' as <pldistro>-<arch>
198 - new package named 'noderepo' allows to ship the full set of node rpms to another (arch) myplc
200 * Fri Jan 18 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-0.1-1 bootstrapfs-0.1-2
201 - search more carefully for alternate pkgs files
202 - handling of sysconfig/crontab and creation of site_admin reviewed
203 - (this tag is set with module-tag.py)
205 * Fri Sep 2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> -
208 %define module_current_branch 1.0