00219e067812c2c57308b6091160adf0720dd3fe
[sfa.git] / geniwrapper.spec
1
2 %define url $URL: svn+ssh://svn.planet-lab.org/svn/geniwrapper/trunk/geniwrapper.spec $
3
4 %define name geniwrapper
5 %define version 0.8
6 %define taglevel 0
7
8 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
9 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
10
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 Source0: %{name}-%{version}.tar.bz2
15 License: GPL
16 Group: Applications/System
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %(echo %{url} | cut -d ' ' -f 2)
23
24 BuildRequires: make
25 Requires: python
26 Requires: pyOpenSSL >= 0.7
27 Requires: m2crypto
28
29 Summary: the GENI layer around MyPLC
30 Group: Applications/System
31
32 %package sfi 
33 Summary: the GENI layer around MyPLC - client side
34 Group: Applications/System
35
36 %description 
37 Geniwrapper implements the Geni interface which serves as a layer
38 between the existing PlanetLab interfaces and the Geni API.
39
40 %description sfi
41 This package provides the client side of the Geni API, in particular
42 sfi.py, together with less important utilities.
43
44 %prep
45 %setup -q
46
47 %build
48 make
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 make install DESTDIR="$RPM_BUILD_ROOT"
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files 
58 %defattr(-,root,root)
59 %config (noreplace) /etc/geni/geni_config
60 %config (noreplace) /etc/geni/aggregates.xml
61 %config (noreplace) /etc/geni/registries.xml
62 /usr/share/keyconvert/
63 /etc/init.d/geni
64 %{_bindir}/geni-config-tty
65 %{_bindir}/gimport.py
66 %{_bindir}/plc.py
67 %{python_sitelib}/*
68
69 %files sfi
70 %config (noreplace) /etc/geni/sfi_config
71 %{_bindir}/sfi.py
72 %{_bindir}/getNodes.py
73 %{_bindir}/getRecord.py
74 %{_bindir}/setRecord.py
75 %{_bindir}/genidump.py
76
77 %post
78 chkconfig --add geni
79
80 %changelog
81 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
82 - snapshot for reproducible builds
83
84 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
85 - snapshot for the convenience of alpha users
86
87 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
88 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
89
90 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
91 - ongoing work - snapshot for 4.3-rc9
92
93 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
94 - various fixes
95
96 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
97 - bugfixes - still a work in progress
98
99 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
100 - initial package
101
102
103 %define module_current_branch 0.2