11e7aa9a0dc0427bcacb35b284dfe67878c595a9
[iptables.git] / iptables.spec
1 #
2 # $Id: iproute.spec 7668 2008-01-08 11:49:43Z thierry $
3 #
4 %define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/iproute2/trunk/iproute.spec $
5
6 %define name iptables
7 %define version 1.3.8
8 %define taglevel 7
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 %define build_devel 1
18 %define linux_header 0
19
20 Summary: Tools for managing Linux kernel packet filtering capabilities.
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 Source: http://www.netfilter.org/%{name}-%{version}.tar.bz2
25 %define SOURCE1 iptables.init
26 %define SOURCE2 iptables-config
27 %define SOURCE3 planetlab-config
28 Group: System Environment/Base
29 #URL: http://www.netfilter.org/
30 BuildRoot: %{_tmppath}/%{name}-buildroot
31 License: GPL
32 BuildPrereq: /usr/bin/perl
33 Requires: kernel >= 2.4.20
34 Requires(post,postun): chkconfig
35 Prefix: %{_prefix}
36 BuildRequires: kernel-devel
37
38 %package ipv6
39 Summary: IPv6 support for iptables.
40 Group: System Environment/Base
41 Requires: %{name} = %{version}
42
43 %if %{build_devel}
44 %package devel
45 Summary: Development package for iptables.
46 Group: System Environment/Base
47 Requires: %{name} = %{version}
48 %endif
49
50 %description
51 The iptables utility controls the network packet filtering code in the
52 Linux kernel. If you need to set up firewalls and/or IP masquerading,
53 you should install this package.
54
55 %description ipv6
56 The iptables package contains IPv6 (the next version of the IP
57 protocol) support for iptables. Iptables controls the Linux kernel
58 network packet filtering code, allowing you to set up firewalls and IP
59 masquerading. 
60
61 Install iptables-ipv6 if you need to set up firewalling for your
62 network and you are using ipv6.
63
64 %if %{build_devel}
65 %description devel
66 The iptables utility controls the network packet filtering code in the
67 Linux kernel. If you need to set up firewalls and/or IP masquerading,
68 you should install this package.
69 %endif
70
71 %prep
72 rm -rf %{buildroot}
73
74 %setup -q
75
76 # Put it to a reasonable place
77 find . -type f -exec perl -pi -e "s,/usr,%{prefix},g" {} \;
78
79 %build
80 TOPDIR=`pwd`
81 OPT="$RPM_OPT_FLAGS -I$TOPDIR/include"
82
83 %define KERNEL %(rpm -q --qf '%%{VERSION}-%%{RELEASE}-%%{ARCH}\\n' kernel-devel | tail -n 1 )
84 count=$(rpm -q kernel-devel| wc -l)
85 if [ $count -gt 1 ] ; then
86         echo "WARNING: choosing kernel-devel-%{KERNEL}"
87         echo "  but there are other kernel-devel packages installed: $(rpm -q kernel-devel)"
88 fi
89         
90 %define KERNEL_DIR "/usr/src/kernels/%{KERNEL}"
91
92 make COPT_FLAGS="$OPT" KERNEL_DIR=%{KERNEL_DIR} LIBDIR=/%{_lib}
93 make COPT_FLAGS="$OPT" KERNEL_DIR=%{KERNEL_DIR} LIBDIR=/%{_lib} iptables-save iptables-restore
94 make COPT_FLAGS="$OPT" KERNEL_DIR=%{KERNEL_DIR} LIBDIR=/%{_lib} ip6tables-save ip6tables-restore
95
96 %install
97 make install DESTDIR=%{buildroot} KERNEL_DIR=%{KERNEL_DIR} BINDIR=/sbin LIBDIR=/%{_lib} MANDIR=%{_mandir}
98 %if %{build_devel}
99 make install-devel DESTDIR=%{buildroot} KERNEL_DIR=%{KERNEL_DIR} BINDIR=/sbin LIBDIR=%{_libdir} MANDIR=%{_mandir} INCDIR=%{_includedir}
100 %endif
101 cp ip{6,}tables-{save,restore} $RPM_BUILD_ROOT/sbin
102 cp iptables-*.8 $RPM_BUILD_ROOT%{_mandir}/man8
103 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
104 install -c -m755 %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/iptables
105 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
106 install -c -m755 ip6tables.init $RPM_BUILD_ROOT/etc/rc.d/init.d/ip6tables
107 mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
108 install -c -m755 %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/iptables-config
109 install -c -m755 %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/iptables
110 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
111 install -c -m755 ip6tables-config $RPM_BUILD_ROOT/etc/sysconfig/ip6tables-config
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT 
115
116 %post
117 /sbin/chkconfig --add iptables
118 /sbin/service iptables restart
119
120 %preun
121 if [ "$1" = 0 ]; then
122         /sbin/chkconfig --del iptables
123 fi
124
125 %post ipv6
126 /sbin/chkconfig --add ip6tables
127 /sbin/service ip6tables restart
128
129 %preun ipv6
130 if [ "$1" = 0 ]; then
131         /sbin/chkconfig --del ip6tables
132 fi
133
134 %files
135 %defattr(-,root,root,0755)
136 %doc COPYING INSTALL INCOMPATIBILITIES
137 %config %attr(0755,root,root) /etc/rc.d/init.d/iptables
138 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
139 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables
140 /sbin/iptables*
141 %{_mandir}/man8/iptables*
142 %dir /%{_lib}/iptables
143 /%{_lib}/iptables/libipt*
144 /sbin/ipset*
145 %{_mandir}/man8/ipset*
146 %dir /%{_lib}/ipset
147 /%{_lib}/ipset/libipset*
148
149 %files ipv6
150 %defattr(-,root,root,0755)
151 %config %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
152 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
153 /sbin/ip6tables*
154 %{_mandir}/man8/ip6tables*
155 /%{_lib}/iptables/libip6t*
156
157 %if %{build_devel}
158 %files devel
159 %defattr(-,root,root,0755)
160 %{_includedir}/libipq.h
161 %{_libdir}/libipq.a
162 #%{_libdir}/libiptc.a
163 %{_mandir}/man3/*
164 %endif
165
166 %changelog
167 * Mon Aug 04 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - iptables-1.3.8-7
168 - Codemux/PF change
169
170 * Mon Jul 28 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - iptables-1.3.8-6
171 - Syntax error in the spec file prevented this package from installing.  Fixed.
172
173 * Fri Jul 25 2008 Andy Bavier <acb@cs.princeton.edu> - iptables-1.3.8-5
174 - * --add-mark action in CLASSIFY target
175 - * Remove chkconfig from .spec file
176 - * Fix iptables-save/-restore bug for MARK with --copy-xid
177 - * Fix default PlanetLab iptables config
178
179 * Mon Jul 21 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - iptables-1.3.8-4
180 - Load tun/tap
181
182 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - iptables-1.3.8-3
183 - * Load required kernel modules before configuring tun/tap devices
184
185 * Wed Jul 09 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - iptables-1.3.8-2
186 - Added tuntap support. Let's start it in the iptables initscripts for now.
187
188 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - iptables-1.3.8-1
189 - Commit for latest fixes in trunk for the iptables config.  This one in
190 - particular loads ip_conntrack in order to have the new vnet support ping right
191 - away.
192
193
194 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
195 - rebuilt
196
197 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
198 - fixed iptables-restore -c fault if there are no counters (#116421)
199
200 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
201 - rebuilt
202
203 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
204 - Close File descriptors to prevent SELinux error message
205
206 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
207 - rebuild
208
209 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
210 - vew version 1.2.9
211 - new config options in ipXtables-config:
212   IPTABLES_MODULES_UNLOAD
213 - more documentation in ipXtables-config
214 - fix for netlink security issue in libipq (devel package)
215 - print fix for libipt_icmp (#109546)
216
217 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
218 - marked all messages in iptables init script for translation (#107462)
219 - enabled devel package (#105884, #106101)
220 - bumped build for fedora for libipt_recent.so (#106002)
221
222 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
223 - fixed lost udp port range in ip6tables-save (#104484)
224 - fixed non numeric multiport port output in ipXtables-savs
225
226 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
227 - do not link against -lnsl
228
229 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
230 - made variables in rmmod_r local
231
232 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
233 - fixed permission for init script
234
235 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
236 - fixed save when iptables file is missing and iptables-config permissions
237
238 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
239 - fixes for ip6tables: module unloading, setting policy only for existing 
240   tables
241
242 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
243 - IPTABLES_SAVE_COUNTER defaults to no, now
244 - install config file in /etc/sysconfig
245 - exchange unload of ip_tables and ip_conntrack
246 - fixed start function
247
248 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
249 - new config option IPTABLES_SAVE_ON_RESTART
250 - init script: new status, save and restart
251 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
252
253 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
254 - new config option IPTABLES_STATUS_NUMERIC
255 - cleared IPTABLES_MODULES in iptables-config
256
257 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
258 - new init scripts
259
260 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
261 - remove check for very old kernel versions in init scripts
262 - sync up both init scripts and remove some further ugly things
263 - add some docu into rpm
264
265 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
266 - rebuild
267
268 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
269 - update to 1.2.8
270
271 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
272 - rebuilt
273
274 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
275 - update to 1.2.7a
276 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
277
278 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
279 - Fix multilib
280
281 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
282 - fixed iptables and ip6tables initscript output, based on #70511
283 - check return status of all iptables calls, not just the last one
284   in a 'for' loop.
285
286 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
287 - 1.2.6a (bugfix release, #69747)
288
289 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
290 - automated rebuild
291
292 * Thu May 23 2002 Tim Powers <timp@redhat.com>
293 - automated rebuild
294
295 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
296 - Add some fixes from CVS, fixing bug #60465
297
298 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
299 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
300   #59402
301 - Update URL (#59354)
302 - Use /sbin/chkconfig rather than chkconfig in %postun script
303
304 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
305 - 1.2.5
306
307 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
308 - automated rebuild
309
310 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
311 - Fix %preun script
312
313 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
314 - Update to 1.2.4 (various fixes, including security fixes; among others:
315   #42990, #50500, #53325, #54280)
316 - Fix init script (#31133)
317
318 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
319 - 1.2.3 (5 security fixes, some other fixes)
320 - Fix updating (#53032)
321
322 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
323 - Fix #50990
324 - Add some fixes from current CVS; should fix #52620
325
326 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
327 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
328   issues
329
330 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
331 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
332   <mschwendt@yahoo.com>
333
334 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
335 - 1.2.2
336
337 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
338 - 1.2.1a, fixes #28412, #31136, #31460, #31133
339
340 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
341 - Yet another initscript fix (#30173)
342 - Fix the fixes; they fixed some issues but broke more important
343   stuff :/ (#30176)
344
345 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
346 - Fix up initscript (#27962)
347 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
348
349 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
350 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
351
352 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
353 - fix bugzilla #25986 (initscript not marked as config file)
354 - fix bugzilla #25962 (iptables-restore)
355 - mv chkconfig --del from postun to preun
356
357 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
358 - Fix check for ipchains
359
360 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
361 - Some fixes to init scripts
362
363 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
364 - Add some fixes from CVS, fixes among other things Bug #24732
365
366 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
367 - Add missing man pages, fix up init script (Bug #17676)
368
369 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
370 - add init script
371
372 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
373 - 1.2
374 - fix up ipv6 split
375 - add init script
376 - Move the plugins from /usr/lib/iptables to /lib/iptables.
377   This needs to work before /usr is mounted...
378 - Use -O1 on alpha (compiler bug)
379
380 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
381 - 1.1.2
382 - Add IPv6 support (in separate package)
383
384 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
385 - build everywhere
386
387 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
388 - 1.1.1
389
390 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
391 - automatic rebuild
392
393 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
394 - move iptables to /sbin.
395 - excludearch alpha for now, not building there because of compiler bug(?)
396
397 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
398 - don't obsolete ipchains either
399 - update to 1.1.0
400
401 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
402 - remove explicit kernel requirement
403
404 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
405 - initial package