Initscripts to support VNET and PlanetFlow
[iptables.git] / iptables.spec
1 #
2 # $Id: iproute.spec 7668 2008-01-08 11:49:43Z thierry $
3 #
4 %define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/iproute2/trunk/iproute.spec $
5
6 %define name iptables
7 %define version 1.3.8
8 %define taglevel 0
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 %define build_devel 1
18 %define linux_header 0
19
20 Summary: Tools for managing Linux kernel packet filtering capabilities.
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 Source: http://www.netfilter.org/%{name}-%{version}.tar.bz2
25 %define SOURCE1 iptables.init
26 %define SOURCE2 iptables-config
27 %define SOURCE3 planetlab-config
28 Group: System Environment/Base
29 #URL: http://www.netfilter.org/
30 BuildRoot: %{_tmppath}/%{name}-buildroot
31 License: GPL
32 BuildPrereq: /usr/bin/perl
33 Requires: kernel >= 2.4.20
34 Requires(post,postun): chkconfig
35 Prefix: %{_prefix}
36 BuildRequires: kernel-devel
37
38 %package ipv6
39 Summary: IPv6 support for iptables.
40 Group: System Environment/Base
41 Requires: %{name} = %{version}
42
43 %if %{build_devel}
44 %package devel
45 Summary: Development package for iptables.
46 Group: System Environment/Base
47 Requires: %{name} = %{version}
48 %endif
49
50 %description
51 The iptables utility controls the network packet filtering code in the
52 Linux kernel. If you need to set up firewalls and/or IP masquerading,
53 you should install this package.
54
55 %description ipv6
56 The iptables package contains IPv6 (the next version of the IP
57 protocol) support for iptables. Iptables controls the Linux kernel
58 network packet filtering code, allowing you to set up firewalls and IP
59 masquerading. 
60
61 Install iptables-ipv6 if you need to set up firewalling for your
62 network and you are using ipv6.
63
64 %if %{build_devel}
65 %description devel
66 The iptables utility controls the network packet filtering code in the
67 Linux kernel. If you need to set up firewalls and/or IP masquerading,
68 you should install this package.
69 %endif
70
71 %prep
72 rm -rf %{buildroot}
73
74 %setup -q
75
76 # Put it to a reasonable place
77 find . -type f -exec perl -pi -e "s,/usr,%{prefix},g" {} \;
78
79 %build
80 TOPDIR=`pwd`
81 OPT="$RPM_OPT_FLAGS -I$TOPDIR/include"
82
83 %define KERNEL %(rpm -q --qf '%%{VERSION}-%%{RELEASE}-%%{ARCH}\\n' kernel-devel | tail -n 1 )
84 count=$(rpm -q kernel-devel| wc -l)
85 if [ $count -gt 1 ] ; then
86         echo "WARNING: choosing kernel-devel-%{KERNEL}"
87         echo "  but there are other kernel-devel packages installed: $(rpm -q kernel-devel)"
88 fi
89         
90 %define KERNEL_DIR "/usr/src/kernels/%{KERNEL}"
91
92 make COPT_FLAGS="$OPT" KERNEL_DIR=%{KERNEL_DIR} LIBDIR=/%{_lib}
93 make COPT_FLAGS="$OPT" KERNEL_DIR=%{KERNEL_DIR} LIBDIR=/%{_lib} iptables-save iptables-restore
94 make COPT_FLAGS="$OPT" KERNEL_DIR=%{KERNEL_DIR} LIBDIR=/%{_lib} ip6tables-save ip6tables-restore
95
96 %install
97 make install DESTDIR=%{buildroot} KERNEL_DIR=%{KERNEL_DIR} BINDIR=/sbin LIBDIR=/%{_lib} MANDIR=%{_mandir}
98 %if %{build_devel}
99 make install-devel DESTDIR=%{buildroot} KERNEL_DIR=%{KERNEL_DIR} BINDIR=/sbin LIBDIR=%{_libdir} MANDIR=%{_mandir} INCDIR=%{_includedir}
100 %endif
101 cp ip{6,}tables-{save,restore} $RPM_BUILD_ROOT/sbin
102 cp iptables-*.8 $RPM_BUILD_ROOT%{_mandir}/man8
103 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
104 install -c -m755 %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/iptables
105 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
106 install -c -m755 ip6tables.init $RPM_BUILD_ROOT/etc/rc.d/init.d/ip6tables
107 mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
108 install -c -m755 %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/iptables-config
109 install -c -m755 %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/iptables
110 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
111 install -c -m755 ip6tables-config $RPM_BUILD_ROOT/etc/sysconfig/ip6tables-config
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT 
115
116 %post
117 /sbin/chkconfig --add iptables
118
119 %preun
120 if [ "$1" = 0 ]; then
121         /sbin/chkconfig --del iptables
122 fi
123
124 %post ipv6
125 /sbin/chkconfig --add ip6tables
126
127 %preun ipv6
128 if [ "$1" = 0 ]; then
129         /sbin/chkconfig --del ip6tables
130 fi
131
132 %files
133 %defattr(-,root,root,0755)
134 %doc COPYING INSTALL INCOMPATIBILITIES
135 %config %attr(0755,root,root) /etc/rc.d/init.d/iptables
136 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
137 /sbin/iptables*
138 %{_mandir}/man8/iptables*
139 %dir /%{_lib}/iptables
140 /%{_lib}/iptables/libipt*
141 /sbin/ipset*
142 %{_mandir}/man8/ipset*
143 %dir /%{_lib}/ipset
144 /%{_lib}/ipset/libipset*
145
146 %files ipv6
147 %defattr(-,root,root,0755)
148 %config %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
149 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
150 /sbin/ip6tables*
151 %{_mandir}/man8/ip6tables*
152 /%{_lib}/iptables/libip6t*
153
154 %if %{build_devel}
155 %files devel
156 %defattr(-,root,root,0755)
157 %{_includedir}/libipq.h
158 %{_libdir}/libipq.a
159 #%{_libdir}/libiptc.a
160 %{_mandir}/man3/*
161 %endif
162
163 %changelog
164 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
165 - rebuilt
166
167 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
168 - fixed iptables-restore -c fault if there are no counters (#116421)
169
170 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
171 - rebuilt
172
173 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
174 - Close File descriptors to prevent SELinux error message
175
176 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
177 - rebuild
178
179 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
180 - vew version 1.2.9
181 - new config options in ipXtables-config:
182   IPTABLES_MODULES_UNLOAD
183 - more documentation in ipXtables-config
184 - fix for netlink security issue in libipq (devel package)
185 - print fix for libipt_icmp (#109546)
186
187 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
188 - marked all messages in iptables init script for translation (#107462)
189 - enabled devel package (#105884, #106101)
190 - bumped build for fedora for libipt_recent.so (#106002)
191
192 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
193 - fixed lost udp port range in ip6tables-save (#104484)
194 - fixed non numeric multiport port output in ipXtables-savs
195
196 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
197 - do not link against -lnsl
198
199 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
200 - made variables in rmmod_r local
201
202 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
203 - fixed permission for init script
204
205 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
206 - fixed save when iptables file is missing and iptables-config permissions
207
208 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
209 - fixes for ip6tables: module unloading, setting policy only for existing 
210   tables
211
212 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
213 - IPTABLES_SAVE_COUNTER defaults to no, now
214 - install config file in /etc/sysconfig
215 - exchange unload of ip_tables and ip_conntrack
216 - fixed start function
217
218 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
219 - new config option IPTABLES_SAVE_ON_RESTART
220 - init script: new status, save and restart
221 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
222
223 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
224 - new config option IPTABLES_STATUS_NUMERIC
225 - cleared IPTABLES_MODULES in iptables-config
226
227 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
228 - new init scripts
229
230 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
231 - remove check for very old kernel versions in init scripts
232 - sync up both init scripts and remove some further ugly things
233 - add some docu into rpm
234
235 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
236 - rebuild
237
238 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
239 - update to 1.2.8
240
241 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
242 - rebuilt
243
244 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
245 - update to 1.2.7a
246 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
247
248 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
249 - Fix multilib
250
251 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
252 - fixed iptables and ip6tables initscript output, based on #70511
253 - check return status of all iptables calls, not just the last one
254   in a 'for' loop.
255
256 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
257 - 1.2.6a (bugfix release, #69747)
258
259 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
260 - automated rebuild
261
262 * Thu May 23 2002 Tim Powers <timp@redhat.com>
263 - automated rebuild
264
265 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
266 - Add some fixes from CVS, fixing bug #60465
267
268 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
269 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
270   #59402
271 - Update URL (#59354)
272 - Use /sbin/chkconfig rather than chkconfig in %postun script
273
274 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
275 - 1.2.5
276
277 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
278 - automated rebuild
279
280 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
281 - Fix %preun script
282
283 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
284 - Update to 1.2.4 (various fixes, including security fixes; among others:
285   #42990, #50500, #53325, #54280)
286 - Fix init script (#31133)
287
288 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
289 - 1.2.3 (5 security fixes, some other fixes)
290 - Fix updating (#53032)
291
292 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
293 - Fix #50990
294 - Add some fixes from current CVS; should fix #52620
295
296 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
297 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
298   issues
299
300 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
301 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
302   <mschwendt@yahoo.com>
303
304 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
305 - 1.2.2
306
307 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
308 - 1.2.1a, fixes #28412, #31136, #31460, #31133
309
310 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
311 - Yet another initscript fix (#30173)
312 - Fix the fixes; they fixed some issues but broke more important
313   stuff :/ (#30176)
314
315 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
316 - Fix up initscript (#27962)
317 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
318
319 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
320 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
321
322 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
323 - fix bugzilla #25986 (initscript not marked as config file)
324 - fix bugzilla #25962 (iptables-restore)
325 - mv chkconfig --del from postun to preun
326
327 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
328 - Fix check for ipchains
329
330 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
331 - Some fixes to init scripts
332
333 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
334 - Add some fixes from CVS, fixes among other things Bug #24732
335
336 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
337 - Add missing man pages, fix up init script (Bug #17676)
338
339 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
340 - add init script
341
342 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
343 - 1.2
344 - fix up ipv6 split
345 - add init script
346 - Move the plugins from /usr/lib/iptables to /lib/iptables.
347   This needs to work before /usr is mounted...
348 - Use -O1 on alpha (compiler bug)
349
350 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
351 - 1.1.2
352 - Add IPv6 support (in separate package)
353
354 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
355 - build everywhere
356
357 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
358 - 1.1.1
359
360 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
361 - automatic rebuild
362
363 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
364 - move iptables to /sbin.
365 - excludearch alpha for now, not building there because of compiler bug(?)
366
367 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
368 - don't obsolete ipchains either
369 - update to 1.1.0
370
371 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
372 - remove explicit kernel requirement
373
374 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
375 - initial package