Tagging module iptables - iptables-1.3.8-2
[iptables.git] / iptables.spec
1 #
2 # $Id: iproute.spec 7668 2008-01-08 11:49:43Z thierry $
3 #
4 %define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/iproute2/trunk/iproute.spec $
5
6 %define name iptables
7 %define version 1.3.8
8 %define taglevel 2
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 %define build_devel 1
18 %define linux_header 0
19
20 Summary: Tools for managing Linux kernel packet filtering capabilities.
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 Source: http://www.netfilter.org/%{name}-%{version}.tar.bz2
25 %define SOURCE1 iptables.init
26 %define SOURCE2 iptables-config
27 %define SOURCE3 planetlab-config
28 Group: System Environment/Base
29 #URL: http://www.netfilter.org/
30 BuildRoot: %{_tmppath}/%{name}-buildroot
31 License: GPL
32 BuildPrereq: /usr/bin/perl
33 Requires: kernel >= 2.4.20
34 Requires(post,postun): chkconfig
35 Prefix: %{_prefix}
36 BuildRequires: kernel-devel
37
38 %package ipv6
39 Summary: IPv6 support for iptables.
40 Group: System Environment/Base
41 Requires: %{name} = %{version}
42
43 %if %{build_devel}
44 %package devel
45 Summary: Development package for iptables.
46 Group: System Environment/Base
47 Requires: %{name} = %{version}
48 %endif
49
50 %description
51 The iptables utility controls the network packet filtering code in the
52 Linux kernel. If you need to set up firewalls and/or IP masquerading,
53 you should install this package.
54
55 %description ipv6
56 The iptables package contains IPv6 (the next version of the IP
57 protocol) support for iptables. Iptables controls the Linux kernel
58 network packet filtering code, allowing you to set up firewalls and IP
59 masquerading. 
60
61 Install iptables-ipv6 if you need to set up firewalling for your
62 network and you are using ipv6.
63
64 %if %{build_devel}
65 %description devel
66 The iptables utility controls the network packet filtering code in the
67 Linux kernel. If you need to set up firewalls and/or IP masquerading,
68 you should install this package.
69 %endif
70
71 %prep
72 rm -rf %{buildroot}
73
74 %setup -q
75
76 # Put it to a reasonable place
77 find . -type f -exec perl -pi -e "s,/usr,%{prefix},g" {} \;
78
79 %build
80 TOPDIR=`pwd`
81 OPT="$RPM_OPT_FLAGS -I$TOPDIR/include"
82
83 %define KERNEL %(rpm -q --qf '%%{VERSION}-%%{RELEASE}-%%{ARCH}\\n' kernel-devel | tail -n 1 )
84 count=$(rpm -q kernel-devel| wc -l)
85 if [ $count -gt 1 ] ; then
86         echo "WARNING: choosing kernel-devel-%{KERNEL}"
87         echo "  but there are other kernel-devel packages installed: $(rpm -q kernel-devel)"
88 fi
89         
90 %define KERNEL_DIR "/usr/src/kernels/%{KERNEL}"
91
92 make COPT_FLAGS="$OPT" KERNEL_DIR=%{KERNEL_DIR} LIBDIR=/%{_lib}
93 make COPT_FLAGS="$OPT" KERNEL_DIR=%{KERNEL_DIR} LIBDIR=/%{_lib} iptables-save iptables-restore
94 make COPT_FLAGS="$OPT" KERNEL_DIR=%{KERNEL_DIR} LIBDIR=/%{_lib} ip6tables-save ip6tables-restore
95
96 %install
97 make install DESTDIR=%{buildroot} KERNEL_DIR=%{KERNEL_DIR} BINDIR=/sbin LIBDIR=/%{_lib} MANDIR=%{_mandir}
98 %if %{build_devel}
99 make install-devel DESTDIR=%{buildroot} KERNEL_DIR=%{KERNEL_DIR} BINDIR=/sbin LIBDIR=%{_libdir} MANDIR=%{_mandir} INCDIR=%{_includedir}
100 %endif
101 cp ip{6,}tables-{save,restore} $RPM_BUILD_ROOT/sbin
102 cp iptables-*.8 $RPM_BUILD_ROOT%{_mandir}/man8
103 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
104 install -c -m755 %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/iptables
105 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
106 install -c -m755 ip6tables.init $RPM_BUILD_ROOT/etc/rc.d/init.d/ip6tables
107 mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
108 install -c -m755 %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/iptables-config
109 install -c -m755 %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/iptables
110 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
111 install -c -m755 ip6tables-config $RPM_BUILD_ROOT/etc/sysconfig/ip6tables-config
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT 
115
116 %post
117 /sbin/chkconfig --add iptables
118
119 %preun
120 if [ "$1" = 0 ]; then
121         /sbin/chkconfig --del iptables
122 fi
123
124 %post ipv6
125 /sbin/chkconfig --add ip6tables
126
127 %preun ipv6
128 if [ "$1" = 0 ]; then
129         /sbin/chkconfig --del ip6tables
130 fi
131
132 %files
133 %defattr(-,root,root,0755)
134 %doc COPYING INSTALL INCOMPATIBILITIES
135 %config %attr(0755,root,root) /etc/rc.d/init.d/iptables
136 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
137 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables
138 /sbin/iptables*
139 %{_mandir}/man8/iptables*
140 %dir /%{_lib}/iptables
141 /%{_lib}/iptables/libipt*
142 /sbin/ipset*
143 %{_mandir}/man8/ipset*
144 %dir /%{_lib}/ipset
145 /%{_lib}/ipset/libipset*
146
147 %files ipv6
148 %defattr(-,root,root,0755)
149 %config %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
150 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
151 /sbin/ip6tables*
152 %{_mandir}/man8/ip6tables*
153 /%{_lib}/iptables/libip6t*
154
155 %if %{build_devel}
156 %files devel
157 %defattr(-,root,root,0755)
158 %{_includedir}/libipq.h
159 %{_libdir}/libipq.a
160 #%{_libdir}/libiptc.a
161 %{_mandir}/man3/*
162 %endif
163
164 %changelog
165 * Wed Jul 09 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - iptables-1.3.8-2
166 - Added tuntap support. Let's start it in the iptables initscripts for now.
167
168 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - iptables-1.3.8-1
169 - Commit for latest fixes in trunk for the iptables config.  This one in
170 - particular loads ip_conntrack in order to have the new vnet support ping right
171 - away.
172
173
174 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
175 - rebuilt
176
177 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
178 - fixed iptables-restore -c fault if there are no counters (#116421)
179
180 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
181 - rebuilt
182
183 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
184 - Close File descriptors to prevent SELinux error message
185
186 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
187 - rebuild
188
189 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
190 - vew version 1.2.9
191 - new config options in ipXtables-config:
192   IPTABLES_MODULES_UNLOAD
193 - more documentation in ipXtables-config
194 - fix for netlink security issue in libipq (devel package)
195 - print fix for libipt_icmp (#109546)
196
197 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
198 - marked all messages in iptables init script for translation (#107462)
199 - enabled devel package (#105884, #106101)
200 - bumped build for fedora for libipt_recent.so (#106002)
201
202 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
203 - fixed lost udp port range in ip6tables-save (#104484)
204 - fixed non numeric multiport port output in ipXtables-savs
205
206 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
207 - do not link against -lnsl
208
209 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
210 - made variables in rmmod_r local
211
212 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
213 - fixed permission for init script
214
215 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
216 - fixed save when iptables file is missing and iptables-config permissions
217
218 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
219 - fixes for ip6tables: module unloading, setting policy only for existing 
220   tables
221
222 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
223 - IPTABLES_SAVE_COUNTER defaults to no, now
224 - install config file in /etc/sysconfig
225 - exchange unload of ip_tables and ip_conntrack
226 - fixed start function
227
228 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
229 - new config option IPTABLES_SAVE_ON_RESTART
230 - init script: new status, save and restart
231 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
232
233 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
234 - new config option IPTABLES_STATUS_NUMERIC
235 - cleared IPTABLES_MODULES in iptables-config
236
237 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
238 - new init scripts
239
240 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
241 - remove check for very old kernel versions in init scripts
242 - sync up both init scripts and remove some further ugly things
243 - add some docu into rpm
244
245 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
246 - rebuild
247
248 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
249 - update to 1.2.8
250
251 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
252 - rebuilt
253
254 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
255 - update to 1.2.7a
256 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
257
258 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
259 - Fix multilib
260
261 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
262 - fixed iptables and ip6tables initscript output, based on #70511
263 - check return status of all iptables calls, not just the last one
264   in a 'for' loop.
265
266 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
267 - 1.2.6a (bugfix release, #69747)
268
269 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
270 - automated rebuild
271
272 * Thu May 23 2002 Tim Powers <timp@redhat.com>
273 - automated rebuild
274
275 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
276 - Add some fixes from CVS, fixing bug #60465
277
278 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
279 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
280   #59402
281 - Update URL (#59354)
282 - Use /sbin/chkconfig rather than chkconfig in %postun script
283
284 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
285 - 1.2.5
286
287 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
288 - automated rebuild
289
290 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
291 - Fix %preun script
292
293 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
294 - Update to 1.2.4 (various fixes, including security fixes; among others:
295   #42990, #50500, #53325, #54280)
296 - Fix init script (#31133)
297
298 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
299 - 1.2.3 (5 security fixes, some other fixes)
300 - Fix updating (#53032)
301
302 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
303 - Fix #50990
304 - Add some fixes from current CVS; should fix #52620
305
306 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
307 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
308   issues
309
310 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
311 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
312   <mschwendt@yahoo.com>
313
314 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
315 - 1.2.2
316
317 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
318 - 1.2.1a, fixes #28412, #31136, #31460, #31133
319
320 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
321 - Yet another initscript fix (#30173)
322 - Fix the fixes; they fixed some issues but broke more important
323   stuff :/ (#30176)
324
325 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
326 - Fix up initscript (#27962)
327 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
328
329 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
330 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
331
332 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
333 - fix bugzilla #25986 (initscript not marked as config file)
334 - fix bugzilla #25962 (iptables-restore)
335 - mv chkconfig --del from postun to preun
336
337 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
338 - Fix check for ipchains
339
340 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
341 - Some fixes to init scripts
342
343 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
344 - Add some fixes from CVS, fixes among other things Bug #24732
345
346 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
347 - Add missing man pages, fix up init script (Bug #17676)
348
349 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
350 - add init script
351
352 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
353 - 1.2
354 - fix up ipv6 split
355 - add init script
356 - Move the plugins from /usr/lib/iptables to /lib/iptables.
357   This needs to work before /usr is mounted...
358 - Use -O1 on alpha (compiler bug)
359
360 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
361 - 1.1.2
362 - Add IPv6 support (in separate package)
363
364 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
365 - build everywhere
366
367 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
368 - 1.1.1
369
370 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
371 - automatic rebuild
372
373 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
374 - move iptables to /sbin.
375 - excludearch alpha for now, not building there because of compiler bug(?)
376
377 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
378 - don't obsolete ipchains either
379 - update to 1.1.0
380
381 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
382 - remove explicit kernel requirement
383
384 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
385 - initial package