Add default classification, cleanup
[iptables.git] / iptables.spec
1 #
2 # $Id: iproute.spec 7668 2008-01-08 11:49:43Z thierry $
3 #
4 %define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/iproute2/trunk/iproute.spec $
5
6 %define name iptables
7 %define version 1.3.8
8 %define taglevel 4
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 %define build_devel 1
18 %define linux_header 0
19
20 Summary: Tools for managing Linux kernel packet filtering capabilities.
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 Source: http://www.netfilter.org/%{name}-%{version}.tar.bz2
25 %define SOURCE1 iptables.init
26 %define SOURCE2 iptables-config
27 %define SOURCE3 planetlab-config
28 Group: System Environment/Base
29 #URL: http://www.netfilter.org/
30 BuildRoot: %{_tmppath}/%{name}-buildroot
31 License: GPL
32 BuildPrereq: /usr/bin/perl
33 Requires: kernel >= 2.4.20
34 Requires(post,postun): chkconfig
35 Prefix: %{_prefix}
36 BuildRequires: kernel-devel
37
38 %package ipv6
39 Summary: IPv6 support for iptables.
40 Group: System Environment/Base
41 Requires: %{name} = %{version}
42
43 %if %{build_devel}
44 %package devel
45 Summary: Development package for iptables.
46 Group: System Environment/Base
47 Requires: %{name} = %{version}
48 %endif
49
50 %description
51 The iptables utility controls the network packet filtering code in the
52 Linux kernel. If you need to set up firewalls and/or IP masquerading,
53 you should install this package.
54
55 %description ipv6
56 The iptables package contains IPv6 (the next version of the IP
57 protocol) support for iptables. Iptables controls the Linux kernel
58 network packet filtering code, allowing you to set up firewalls and IP
59 masquerading. 
60
61 Install iptables-ipv6 if you need to set up firewalling for your
62 network and you are using ipv6.
63
64 %if %{build_devel}
65 %description devel
66 The iptables utility controls the network packet filtering code in the
67 Linux kernel. If you need to set up firewalls and/or IP masquerading,
68 you should install this package.
69 %endif
70
71 %prep
72 rm -rf %{buildroot}
73
74 %setup -q
75
76 # Put it to a reasonable place
77 find . -type f -exec perl -pi -e "s,/usr,%{prefix},g" {} \;
78
79 %build
80 TOPDIR=`pwd`
81 OPT="$RPM_OPT_FLAGS -I$TOPDIR/include"
82
83 %define KERNEL %(rpm -q --qf '%%{VERSION}-%%{RELEASE}-%%{ARCH}\\n' kernel-devel | tail -n 1 )
84 count=$(rpm -q kernel-devel| wc -l)
85 if [ $count -gt 1 ] ; then
86         echo "WARNING: choosing kernel-devel-%{KERNEL}"
87         echo "  but there are other kernel-devel packages installed: $(rpm -q kernel-devel)"
88 fi
89         
90 %define KERNEL_DIR "/usr/src/kernels/%{KERNEL}"
91
92 make COPT_FLAGS="$OPT" KERNEL_DIR=%{KERNEL_DIR} LIBDIR=/%{_lib}
93 make COPT_FLAGS="$OPT" KERNEL_DIR=%{KERNEL_DIR} LIBDIR=/%{_lib} iptables-save iptables-restore
94 make COPT_FLAGS="$OPT" KERNEL_DIR=%{KERNEL_DIR} LIBDIR=/%{_lib} ip6tables-save ip6tables-restore
95
96 %install
97 make install DESTDIR=%{buildroot} KERNEL_DIR=%{KERNEL_DIR} BINDIR=/sbin LIBDIR=/%{_lib} MANDIR=%{_mandir}
98 %if %{build_devel}
99 make install-devel DESTDIR=%{buildroot} KERNEL_DIR=%{KERNEL_DIR} BINDIR=/sbin LIBDIR=%{_libdir} MANDIR=%{_mandir} INCDIR=%{_includedir}
100 %endif
101 cp ip{6,}tables-{save,restore} $RPM_BUILD_ROOT/sbin
102 cp iptables-*.8 $RPM_BUILD_ROOT%{_mandir}/man8
103 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
104 install -c -m755 %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/iptables
105 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
106 install -c -m755 ip6tables.init $RPM_BUILD_ROOT/etc/rc.d/init.d/ip6tables
107 mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
108 install -c -m755 %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/iptables-config
109 install -c -m755 %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/iptables
110 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
111 install -c -m755 ip6tables-config $RPM_BUILD_ROOT/etc/sysconfig/ip6tables-config
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT 
115
116 %post
117 /sbin/chkconfig --add iptables
118 /sbin/chkconfig --level 345 iptables on
119 /sbin/service restart iptables
120
121 %preun
122 if [ "$1" = 0 ]; then
123         /sbin/chkconfig --del iptables
124 fi
125
126 %post ipv6
127 /sbin/chkconfig --add ip6tables
128 /sbin/chkconfig --level 345 ip6tables on
129 /sbin/service restart ip6tables
130
131 %preun ipv6
132 if [ "$1" = 0 ]; then
133         /sbin/chkconfig --del ip6tables
134 fi
135
136 %files
137 %defattr(-,root,root,0755)
138 %doc COPYING INSTALL INCOMPATIBILITIES
139 %config %attr(0755,root,root) /etc/rc.d/init.d/iptables
140 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
141 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables
142 /sbin/iptables*
143 %{_mandir}/man8/iptables*
144 %dir /%{_lib}/iptables
145 /%{_lib}/iptables/libipt*
146 /sbin/ipset*
147 %{_mandir}/man8/ipset*
148 %dir /%{_lib}/ipset
149 /%{_lib}/ipset/libipset*
150
151 %files ipv6
152 %defattr(-,root,root,0755)
153 %config %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
154 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
155 /sbin/ip6tables*
156 %{_mandir}/man8/ip6tables*
157 /%{_lib}/iptables/libip6t*
158
159 %if %{build_devel}
160 %files devel
161 %defattr(-,root,root,0755)
162 %{_includedir}/libipq.h
163 %{_libdir}/libipq.a
164 #%{_libdir}/libiptc.a
165 %{_mandir}/man3/*
166 %endif
167
168 %changelog
169 * Mon Jul 21 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - iptables-1.3.8-4
170 - Load tun/tap
171
172 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - iptables-1.3.8-3
173 - * Load required kernel modules before configuring tun/tap devices
174
175 * Wed Jul 09 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - iptables-1.3.8-2
176 - Added tuntap support. Let's start it in the iptables initscripts for now.
177
178 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - iptables-1.3.8-1
179 - Commit for latest fixes in trunk for the iptables config.  This one in
180 - particular loads ip_conntrack in order to have the new vnet support ping right
181 - away.
182
183
184 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
185 - rebuilt
186
187 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
188 - fixed iptables-restore -c fault if there are no counters (#116421)
189
190 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
191 - rebuilt
192
193 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
194 - Close File descriptors to prevent SELinux error message
195
196 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
197 - rebuild
198
199 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
200 - vew version 1.2.9
201 - new config options in ipXtables-config:
202   IPTABLES_MODULES_UNLOAD
203 - more documentation in ipXtables-config
204 - fix for netlink security issue in libipq (devel package)
205 - print fix for libipt_icmp (#109546)
206
207 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
208 - marked all messages in iptables init script for translation (#107462)
209 - enabled devel package (#105884, #106101)
210 - bumped build for fedora for libipt_recent.so (#106002)
211
212 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
213 - fixed lost udp port range in ip6tables-save (#104484)
214 - fixed non numeric multiport port output in ipXtables-savs
215
216 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
217 - do not link against -lnsl
218
219 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
220 - made variables in rmmod_r local
221
222 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
223 - fixed permission for init script
224
225 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
226 - fixed save when iptables file is missing and iptables-config permissions
227
228 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
229 - fixes for ip6tables: module unloading, setting policy only for existing 
230   tables
231
232 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
233 - IPTABLES_SAVE_COUNTER defaults to no, now
234 - install config file in /etc/sysconfig
235 - exchange unload of ip_tables and ip_conntrack
236 - fixed start function
237
238 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
239 - new config option IPTABLES_SAVE_ON_RESTART
240 - init script: new status, save and restart
241 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
242
243 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
244 - new config option IPTABLES_STATUS_NUMERIC
245 - cleared IPTABLES_MODULES in iptables-config
246
247 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
248 - new init scripts
249
250 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
251 - remove check for very old kernel versions in init scripts
252 - sync up both init scripts and remove some further ugly things
253 - add some docu into rpm
254
255 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
256 - rebuild
257
258 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
259 - update to 1.2.8
260
261 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
262 - rebuilt
263
264 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
265 - update to 1.2.7a
266 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
267
268 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
269 - Fix multilib
270
271 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
272 - fixed iptables and ip6tables initscript output, based on #70511
273 - check return status of all iptables calls, not just the last one
274   in a 'for' loop.
275
276 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
277 - 1.2.6a (bugfix release, #69747)
278
279 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
280 - automated rebuild
281
282 * Thu May 23 2002 Tim Powers <timp@redhat.com>
283 - automated rebuild
284
285 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
286 - Add some fixes from CVS, fixing bug #60465
287
288 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
289 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
290   #59402
291 - Update URL (#59354)
292 - Use /sbin/chkconfig rather than chkconfig in %postun script
293
294 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
295 - 1.2.5
296
297 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
298 - automated rebuild
299
300 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
301 - Fix %preun script
302
303 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
304 - Update to 1.2.4 (various fixes, including security fixes; among others:
305   #42990, #50500, #53325, #54280)
306 - Fix init script (#31133)
307
308 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
309 - 1.2.3 (5 security fixes, some other fixes)
310 - Fix updating (#53032)
311
312 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
313 - Fix #50990
314 - Add some fixes from current CVS; should fix #52620
315
316 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
317 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
318   issues
319
320 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
321 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
322   <mschwendt@yahoo.com>
323
324 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
325 - 1.2.2
326
327 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
328 - 1.2.1a, fixes #28412, #31136, #31460, #31133
329
330 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
331 - Yet another initscript fix (#30173)
332 - Fix the fixes; they fixed some issues but broke more important
333   stuff :/ (#30176)
334
335 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
336 - Fix up initscript (#27962)
337 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
338
339 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
340 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
341
342 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
343 - fix bugzilla #25986 (initscript not marked as config file)
344 - fix bugzilla #25962 (iptables-restore)
345 - mv chkconfig --del from postun to preun
346
347 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
348 - Fix check for ipchains
349
350 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
351 - Some fixes to init scripts
352
353 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
354 - Add some fixes from CVS, fixes among other things Bug #24732
355
356 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
357 - Add missing man pages, fix up init script (Bug #17676)
358
359 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
360 - add init script
361
362 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
363 - 1.2
364 - fix up ipv6 split
365 - add init script
366 - Move the plugins from /usr/lib/iptables to /lib/iptables.
367   This needs to work before /usr is mounted...
368 - Use -O1 on alpha (compiler bug)
369
370 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
371 - 1.1.2
372 - Add IPv6 support (in separate package)
373
374 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
375 - build everywhere
376
377 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
378 - 1.1.1
379
380 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
381 - automatic rebuild
382
383 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
384 - move iptables to /sbin.
385 - excludearch alpha for now, not building there because of compiler bug(?)
386
387 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
388 - don't obsolete ipchains either
389 - update to 1.1.0
390
391 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
392 - remove explicit kernel requirement
393
394 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
395 - initial package