6 Summary: The Linux kernel (the core of the Linux operating system)
8 # What parts do we want to build? We must build at least one kernel.
9 # These are the kernels that are built IF the architecture allows it.
16 # default is to not build this - to override, use something like
17 # kernel-SPECVARS := iwlwifi=1
18 # rpm does not seem to have a syntax for defining overridable defaults
19 # any better solution would be more than welcome.
20 %define build_iwlwifi %{?iwlwifi:1}%{!?iwlwifi:0}
22 # Versions of various parts
24 # for module-tag.py - sublevel is used for the version (middle) part of tag names
25 %define name linux-2.6
26 %define module_version_varname sublevel
30 # Polite request for people who spin their own kernel rpms:
31 # please modify the "release" field in a way that identifies
32 # that the kernel isn't the stock distribution kernel, for example by
33 # adding some text to the end of the version number.
37 %define kversion 2.6.%{sublevel}
38 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
40 %define vsversion 2.3.0.34
42 # Will go away when VServer supports NetNS in mainline. Currently, it must be
43 # updated every time the PL kernel is updated.
44 %define vini_pl_patch 561
46 %define release vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
48 %{!?pldistro:%global pldistro planetlab}
51 %define make_target bzImage
52 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
54 # Override generic defaults with per-arch defaults
56 %define image_install_path boot
59 # Three sets of minimum package version requirements in the form of Conflicts:
60 # to versions below the minimum
64 # First the general kernel 2.6 required versions as per
65 # Documentation/Changes
67 %define kernel_dot_org_conflicts ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
70 # Then a series of requirements that are distribution specific, either
71 # because we add patches for something, or the older versions have
72 # problems with the newer kernel or lack certain things that make
73 # integration in the distro harder than needed.
75 %define package_conflicts cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
78 # Several packages had bugs in them that became obvious when the NPTL
79 # threading code got integrated.
81 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x, cups < 1.1.17-13
84 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
88 # %define xen_conflicts glibc < 2.3.5-1
91 # Packages that need to be installed before the kernel is, because the %post
94 %define kernel_prereq fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
97 Packager: PlanetLab Central <support@planet-lab.org>
98 Distribution: PlanetLab %{plrelease}
99 URL: %(echo %{url} | cut -d ' ' -f 2)
102 Group: System Environment/Kernel
104 Version: %{rpmversion}
107 Provides: kernel = %{version}
108 Provides: kernel-drm = 4.3.0
109 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
110 Provides: kernel-smp = %{rpmversion}-%{release}
111 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
112 Prereq: %{kernel_prereq}
113 Conflicts: %{kernel_dot_org_conflicts}
114 Conflicts: %{package_conflicts}
115 Conflicts: %{nptl_conflicts}
116 # We can't let RPM do the dependencies automatic because it'll then pick up
117 # a correct but undesirable perl dependency from the module headers which
118 # isn't required for the kernel proper to function
122 # List the packages used during the kernel build
124 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
125 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
126 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
127 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
130 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
132 Source10: %{pldistro}-%{kversion}-i586.config
133 Source11: %{pldistro}-%{kversion}-i686.config
134 Source12: %{pldistro}-%{kversion}-x86_64.config
136 Source20: %{pldistro}-%{kversion}-i686-uml.config
139 Source30: %{pldistro}-%{kversion}-i686-xenU.config
144 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
147 Patch010: linux-2.6-010-e1000e.patch
148 Patch020: linux-2.6-020-build-id.patch
149 Patch030: linux-2.6-030-netns.patch
150 Patch040: linux-2.6-040-i_mutex-check.patch
152 # These are patches picked up from Fedora/RHEL
153 Patch100: linux-2.6-100-build-nonintconfig.patch
156 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
157 Patch210: linux-2.6-210-vserver-cpu-sched.patch
158 Patch220: delta-ptrace-fix01.diff
161 Patch250: linux-2.6-250-ipsets.patch
164 Patch500: linux-2.6-500-vserver-filesharing.patch
165 Patch510: linux-2.6-510-ipod.patch
166 Patch521: linux-2.6-521-packet-tagging.patch
167 Patch522: linux-2.6-522-iptables-connection-tagging.patch
168 Patch523: linux-2.6-523-raw-sockets.patch
169 Patch524: linux-2.6-524-peercred.patch
170 Patch525: linux-2.6-525-sknid-elevator.patch
171 Patch526: linux-2.6-526-tun-tap.patch
172 Patch530: linux-2.6-530-built-by-support.patch
173 Patch540: linux-2.6-540-oom-kill.patch
174 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
175 Patch560: linux-2.6-560-mmconf.patch
176 Patch570: linux-2.6-570-tagxid.patch
177 Patch580: linux-2.6-580-show-proc-virt.patch
178 Patch590: linux-2.6-590-chopstix-intern.patch
179 Patch620: linux-2.6-620-kdb.patch
180 Patch630: linux-2.6-630-sched-fix.patch
181 Patch640: linux-2.6-640-netlink-audit-hack.patch
182 Patch650: linux-2.6-650-hangcheck-reboot.patch
184 # See also the file named 'sources' here for the related checksums
185 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
186 # see http://bughost.org/bugzilla/show_bug.cgi?id=1584
188 %define mac80211_version 10.0.4
189 Patch600: http://intellinuxwireless.org/mac80211/downloads/mac80211-%{mac80211_version}.tgz
190 %define iwlwifi_version 1.2.25
191 Patch601: http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-%{iwlwifi_version}.tgz
194 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
197 The kernel package contains the Linux kernel (vmlinuz), the core of any
198 Linux operating system. The kernel handles the basic functions
199 of the operating system: memory allocation, process allocation, device
200 input and output, etc.
203 Summary: Development package for building kernel modules to match the kernel.
204 Group: System Environment/Kernel
206 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
207 Provides: kernel-smp-devel = %{rpmversion}-%{release}
208 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
209 Prereq: /usr/bin/find
212 This package provides kernel headers and makefiles sufficient to build modules
213 against the kernel package.
217 Summary: Various documentation bits found in the kernel source.
221 This package contains documentation files from the kernel
222 source. Various bits of information about the Linux kernel and the
223 device drivers shipped with it are documented in these files.
225 You'll want to install this package if you need a reference to the
226 options that can be passed to Linux kernel modules at load time.
229 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
231 Group: System Environment/Kernel
232 Provides: kernel = %{version}
233 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
234 Prereq: %{kernel_prereq}
235 Conflicts: %{kernel_dot_org_conflicts}
236 Conflicts: %{package_conflicts}
237 Conflicts: %{nptl_conflicts}
240 # Conflicts: %{xen_conflicts}
242 # We can't let RPM do the dependencies automatic because it'll then pick up
243 # a correct but undesirable perl dependency from the module headers which
244 # isn't required for the kernel proper to function
248 This package includes a version of the Linux kernel which
249 runs in Xen unprivileged guest VMs. This should be installed
250 both inside the unprivileged guest (for the modules) and in
254 Summary: Development package for building kernel modules to match the kernel.
255 Group: System Environment/Kernel
257 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
258 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
259 Provides: kernel-devel = %{rpmversion}-%{release}xenU
260 Prereq: /usr/sbin/hardlink, /usr/bin/find
262 %description xenU-devel
263 This package provides kernel headers and makefiles sufficient to build modules
264 against the kernel package.
267 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
269 Group: System Environment/Kernel
272 This package includes a user mode version of the Linux kernel.
275 Summary: Development package for building kernel modules to match the UML kernel.
276 Group: System Environment/Kernel
277 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
278 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
279 Provides: kernel-devel = %{rpmversion}-%{release}smp
281 Prereq: /usr/sbin/hardlink, /usr/bin/find
283 %description uml-devel
284 This package provides kernel headers and makefiles sufficient to build modules
285 against the User Mode Linux kernel package.
288 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
290 Group: System Environment/Kernel
292 %description uml-modules
293 This package includes a user mode version of the Linux kernel modules.
296 Summary: A placeholder RPM that provides kernel and kernel-drm
298 Group: System Environment/Kernel
299 Provides: kernel = %{version}
300 Provides: kernel-drm = 4.3.0
301 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
304 VServers do not require and cannot use kernels, but some RPMs have
305 implicit or explicit dependencies on the "kernel" package
306 (e.g. tcpdump). This package installs no files but provides the
307 necessary dependencies to make rpm and yum happy.
311 # First we unpack the kernel tarball.
312 # If this isn't the first make prep, we use links to the existing clean tarball
313 # which speeds things up quite a bit.
314 if [ ! -d kernel-%{kversion}/vanilla ]; then
315 # Ok, first time we do a make prep.
316 rm -f pax_global_header
317 %setup -q -n %{name}-%{kversion} -c
318 mv linux-%{kversion} vanilla
320 # We already have a vanilla dir.
321 cd kernel-%{kversion}
324 KERNEL_PREVIOUS=vanilla
325 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
326 %define ApplyPatch() \
327 rm -fr linux-%{kversion}-%1 \
328 cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1 \
330 test "%2" != "%%2" && patchflag="%2" \
331 PATCH="%{expand:%{PATCH%1}}" \
332 if test ! -e "$PATCH"; then \
333 echo "Patch %1 does not exist!" \
337 *.bz2) bzcat "$PATCH";; \
338 *.gz) zcat "$PATCH";; \
340 esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
341 KERNEL_PREVIOUS=linux-%{kversion}-%1
343 # This is where the patches get applied
351 # NetNS patch for VINI
388 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
389 # break with later patches.
392 %ApplyPatch %vini_pl_patch
396 # Run the mac80211 stuff in the kernel tree holding the last patch
398 pushd mac80211-%{mac80211_version}
399 mac80211_makeflags="KSRC=../$KERNEL_PREVIOUS"
400 make $mac80211_makeflags modified
401 make $mac80211_makeflags source
402 make $mac80211_makeflags patch_kernel
405 # Untar iwlwifi in the same place - needs to be compiled later
407 # the install target is broken: first it does not pass the right -b flag to depmod
408 # second we do not need to invoke depmod at this stage anyway
409 # let's add our own patch/stuff in this Makefile for manual install later on
410 pushd iwlwifi-%{iwlwifi_version}
411 cat >> Makefile <<EOF
413 @echo \$(addprefix \$(DIR),\$(addsuffix .ko,\$(list-m)))
418 rm -fr linux-%{kversion}
419 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
423 # make sure the kernel has the sublevel we know it has. This looks weird
424 # but for -pre and -rc versions we need it since we only want to use
425 # the higher version when the final kernel is released.
426 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
427 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
429 # get rid of unwanted files resulting from patch fuzz
430 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
443 rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
444 cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
445 cd linux-%{_target_cpu}-%{kversion}$Flavour
447 # Pick the right config file for the kernel we're building
448 if [ -n "$Flavour" ] ; then
449 Config=%{pldistro}-%{kversion}-%{_target_cpu}-$Flavour.config
450 DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
451 DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
453 Config=%{pldistro}-%{kversion}-%{_target_cpu}.config
454 DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
458 KernelVer=%{version}-%{release}$Flavour
459 echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
461 # make sure EXTRAVERSION says what we want it to say
462 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
464 # and now to start the build process
467 cp %{_sourcedir}/$Config .config
469 #Arch=`head -1 .config | cut -b 3-`
470 echo USING ARCH=$Arch
472 make -s ARCH=$Arch nonint_oldconfig > /dev/null
473 make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
474 make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
477 # build the iwlwifi driver
478 make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
479 KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour
482 # Start installing the results
484 %if "%{_enable_debug_packages}" == "1"
485 mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
487 mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
488 install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
489 install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
490 if [ -f arch/$Arch/boot/bzImage ]; then
491 cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
493 if [ -f arch/$Arch/boot/zImage.stub ]; then
494 cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
496 if [ "$Flavour" = "uml" ] ; then
497 install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
500 mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
501 make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
505 # make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
506 # KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour \
507 # KMISC=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless install
508 pushd %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version}
509 iwlwifi_dest=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless
510 # get the list and location of modules to install - no need to pass KSRC nor anything, let's keep it simple
511 iwlwifi_modules=$(make --no-print-directory module-list)
512 install -d $iwlwifi_dest
513 install -m 644 -c $iwlwifi_modules $iwlwifi_dest
517 # And save the headers/makefiles etc for building modules against
519 # This all looks scary, but the end result is supposed to be:
520 # * all arch relevant include/ files
521 # * all Makefile/Kconfig files
522 # * all script/ files
524 rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
525 rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
526 mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
527 (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
528 # dirs for additional modules per module-init-tools, kbuild/modules.txt
529 mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
530 mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
531 # first copy everything
532 cp --parents `find -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
533 cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
534 if [ "$Flavour" = "uml" ] ; then
535 cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
537 # then drop all but the needed Makefiles/Kconfig files
538 rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
539 rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
540 rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
541 cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
542 cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
543 cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
544 if [ -d arch/%{_arch}/scripts ]; then
545 cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
547 if [ -f arch/%{_arch}/*lds ]; then
548 cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
550 rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
551 rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
552 mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
554 cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
555 cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
556 if [ "$Arch" = "x86_64" ]; then
557 cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
560 if [ "$Flavour" = "xenU" ]; then
561 cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
562 cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
566 if [ "$Flavour" = "uml" ] ; then
567 cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
570 # While arch/powerpc/include/asm is still a symlink to the old
571 # include/asm-ppc{64,} directory, include that in kernel-devel too.
572 if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
573 cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
574 mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
575 pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
576 ln -sf ../../../include/asm-ppc* asm
580 # Make sure the Makefile and version.h have a matching timestamp so that
581 # external modules can be built
582 touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
583 touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
587 # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
589 %if "%{_enable_debug_packages}" == "1"
590 mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
591 cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
594 if [ -f vmlinuz ]; then
595 cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
599 find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
601 # mark modules executable so that strip-to-file can strip them
602 cat modnames | xargs chmod u+x
604 # remove files that will be auto generated by depmod at rpm -i time
605 rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
607 # Move the devel headers out of the root file system
608 mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
609 mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
610 ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
611 [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
618 # prepare directories
619 rm -rf $RPM_BUILD_ROOT
620 mkdir -p $RPM_BUILD_ROOT/boot
622 %if "%{_target_cpu}" == "x86_64"
623 %define kernel_arch %{_target_cpu}
625 %if "%{_target_cpu}" == "i586"
626 %define kernel_arch i386
628 %if "%{_target_cpu}" == "i686"
629 %define kernel_arch i386
633 BuildKernel %make_target %kernel_arch
638 BuildKernel linux um uml
642 BuildKernel vmlinuz %kernel_arch xenU
654 %if %{buildxen} && "%{_target_cpu}" == "i686"
655 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
656 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
657 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
658 # This directive teaches ldconfig to search in nosegneg subdirectories
659 # and cache the DSOs there with extra bit 0 set in their hwcap match
660 # fields. In Xen guest kernels, the vDSO tells the dynamic linker to
661 # search in nosegneg subdirectories and to match this extra hwcap bit
662 # in the ld.so.cache file.
665 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
669 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
671 # sometimes non-world-readable files sneak into the kernel source tree
673 # copy the source over
674 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
682 rm -rf $RPM_BUILD_ROOT
688 # load the loop module for upgrades...in case the old modules get removed we have
689 # loopback in the kernel so that mkinitrd will work.
691 /sbin/modprobe loop 2> /dev/null > /dev/null || :
695 if [ -f /etc/sysconfig/kernel ]; then
696 /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
699 # trick mkinitrd in case the current environment does not have device mapper
700 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
701 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
702 if [ ! -f $rootdev ]; then
704 mkdir -p $(dirname $rootdev)
709 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
710 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
711 # Older modutils do not support --package option
712 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
715 if [ -n "$fake_root_lvm" ]; then
719 # make some useful links
720 pushd /boot > /dev/null ; {
721 ln -sf config-%{KVERREL} config
722 ln -sf config-%{KVERREL} configsmp
723 ln -sf initrd-%{KVERREL}.img initrd-boot
724 ln -sf initrd-%{KVERREL}.img initrd-bootsmp
725 ln -sf vmlinuz-%{KVERREL} kernel-boot
726 ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
731 mkdir -p /etc/planetlab
732 touch /etc/planetlab/update-reboot
735 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
736 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
737 pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
738 /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
743 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
744 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
747 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
748 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
749 pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
750 /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
755 depmod -ae %{KVERREL}uml
758 /sbin/modprobe loop 2> /dev/null > /dev/null || :
759 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
762 /sbin/modprobe loop 2> /dev/null > /dev/null || :
763 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
766 rm -f /lib/modules/%{KVERREL}uml/modules.*
775 %defattr(-,root,root)
776 /%{image_install_path}/vmlinuz-%{KVERREL}
777 /boot/System.map-%{KVERREL}
778 /boot/config-%{KVERREL}
779 %dir /lib/modules/%{KVERREL}
780 /lib/modules/%{KVERREL}/kernel
781 /lib/modules/%{KVERREL}/build
782 /lib/modules/%{KVERREL}/source
783 /lib/modules/%{KVERREL}/extra
784 /lib/modules/%{KVERREL}/updates
787 %defattr(-,root,root)
788 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
791 %if %{builduml} && "%{_target_cpu}" == "i686"
793 %defattr(-,root,root)
797 %defattr(-,root,root)
798 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
799 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
802 %defattr(-,root,root)
803 /boot/System.map-%{KVERREL}uml
804 /boot/config-%{KVERREL}uml
805 %dir /lib/modules/%{KVERREL}uml
806 /lib/modules/%{KVERREL}uml/kernel
807 /lib/modules/%{KVERREL}uml/build
808 /lib/modules/%{KVERREL}uml/source
809 /lib/modules/%{KVERREL}uml/extra
810 /lib/modules/%{KVERREL}uml/updates
813 %if %{buildxen} && "%{_target_cpu}" == "i686"
815 %defattr(-,root,root)
816 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
817 /boot/System.map-%{KVERREL}xenU
818 /boot/config-%{KVERREL}xenU
819 %dir /lib/modules/%{KVERREL}xenU
820 /lib/modules/%{KVERREL}xenU/kernel
821 /lib/modules/%{KVERREL}xenU/build
822 /lib/modules/%{KVERREL}xenU/source
823 /lib/modules/%{KVERREL}xenU/extra
824 /lib/modules/%{KVERREL}xenU/updates
825 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
828 %defattr(-,root,root)
829 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
830 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
834 %defattr(-,root,root)
837 # only some architecture builds need kernel-doc
841 %defattr(-,root,root)
842 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
843 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
844 %dir %{_datadir}/doc/kernel-doc-%{kversion}
848 * Wed Jul 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-14
849 - added fix to process visibility so when ncontext/vcontext run netstat in
850 - xid=1, it can see all ports & processes.
852 * Mon Jul 21 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-13
853 - fix for tcpdump/tcp payloads
855 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-12
857 - * Attempt to fix TCP-payload-related problems with tcpdump
859 * Wed Jul 09 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-11
860 - * Split up VNET+ module into its component patches
861 - * Added tun/tap support
863 * Tue Jul 08 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-10
864 - Filling a statically allocated buffer cannot fail, right?
866 * Wed Jun 25 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-9
867 - Enable the hangcheck timer driver, and build it in to the kernel.
868 - Dump relevant data on the scheduler bug instead of BUGing.
870 * Sat Jun 07 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-8
871 - * Partial fix for the UDP-packet-pollution problem
872 - * Support for PF_PACKET sockets
873 - * Support for SOCK_PACKET sockets
874 - * Disabled Chopstix with mutexes
875 - * Tested VNET+ under heavy loads
879 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-7
880 - Bringing this fix in for tcpdump and ping
883 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-6
884 - Updated configuration to include COW again.
886 - Patches from Sapan to fix ping losses.
888 - Still need help with tcpdump traffic.
891 * Tue May 06 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-5
892 - Patch needs to be applied.
894 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-4
897 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-22-3
898 - Fix bug with looping in schedule()
900 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-2
901 - Includes changes from Sapan/Andy regarding the scheduler and vnet bugs.
902 - Should be safe to try a second deployment.
905 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
907 - Disable split pagetable lock.
909 * Wed Jul 5 2006 Dave Jones <davej@redhat.com>
910 - Get rid of stack backtrace on panic, which in most
911 cases actually caused a loss of info instead of a gain.
913 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
916 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
918 - Fix up the alsa list_add bug.
920 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
921 - Fix up various stupidities incurred by the last big rebase.
922 - Reenable SMP x86-64 builds.
924 - Enable PCI fake hotplug driver.
925 - Enable gameport/joystick on i586 builds. (#196581)
927 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
928 - Enable profiling for 586 kernels.
930 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
931 - Rebuild with slab debug off.
933 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
936 * Mon Jun 5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
939 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
942 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
943 - Improved list_head debugging.
945 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
948 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
951 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
954 * Tue May 9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
956 - make 16C950 UARTs work (again). (#126403)
957 - Fix exec-shield default, which should fix a few programs that
960 * Thu May 4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
963 * Tue May 2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
966 * Mon May 1 2006 Dave Jones <davej@redhat.com>
969 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
970 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
972 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
975 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
976 - Enable PCI MSI support.
978 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
981 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
984 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
987 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
990 * Fri Apr 7 2006 Dave Jones <davej@redhat.com>
993 * Tue Apr 4 2006 Dave Jones <davej@redhat.com>
994 - Reenable non-standard serial ports. (#187466)
995 - Reenable snd-es18xx for x86-32 (#187733)
997 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
998 - ship the .kernelrelease file in -devel too.
999 - Disable EDAC debug.
1001 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
1004 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
1005 - Include patches posted for review for inclusion in 2.6.16.1
1006 - Updated new audit msg types.
1007 - Reenable HDLC driver (#186257)
1008 - Make acpi-cpufreq 'sticky'
1009 - Fix broken x86-64 32bit vDSO (#186924)
1011 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
1012 - Improve spinlock scalability on big machines.
1014 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
1015 - Sync with FC5's 2.6.16 kernel.
1016 - Update Tux & Exec-shield to latest.