6 Summary: The Linux kernel (the core of the Linux operating system)
8 # What parts do we want to build? We must build at least one kernel.
9 # These are the kernels that are built IF the architecture allows it.
16 # default is to not build this - to override, use something like
17 # kernel-SPECVARS := iwlwifi=1
18 # rpm does not seem to have a syntax for defining overridable defaults
19 # any better solution would be more than welcome.
20 %define build_iwlwifi %{?iwlwifi:1}%{!?iwlwifi:0}
22 # Versions of various parts
24 # for module-tag.py - sublevel is used for the version (middle) part of tag names
25 %define name linux-2.6
26 %define module_version_varname sublevel
30 # Polite request for people who spin their own kernel rpms:
31 # please modify the "release" field in a way that identifies
32 # that the kernel isn't the stock distribution kernel, for example by
33 # adding some text to the end of the version number.
37 %define kversion 2.6.%{sublevel}
38 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
40 %define vsversion 2.3.0.34
42 # Will go away when VServer supports NetNS in mainline. Currently, it must be
43 # updated every time the PL kernel is updated.
44 %define vini_pl_patch 561
46 %define release vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
48 %{!?pldistro:%global pldistro planetlab}
51 %define make_target bzImage
52 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
54 # Override generic defaults with per-arch defaults
56 %define image_install_path boot
59 # Three sets of minimum package version requirements in the form of Conflicts:
60 # to versions below the minimum
64 # First the general kernel 2.6 required versions as per
65 # Documentation/Changes
67 %define kernel_dot_org_conflicts ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
70 # Then a series of requirements that are distribution specific, either
71 # because we add patches for something, or the older versions have
72 # problems with the newer kernel or lack certain things that make
73 # integration in the distro harder than needed.
75 %define package_conflicts cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
78 # Several packages had bugs in them that became obvious when the NPTL
79 # threading code got integrated.
81 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x, cups < 1.1.17-13
84 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
88 # %define xen_conflicts glibc < 2.3.5-1
91 # Packages that need to be installed before the kernel is, because the %post
94 %define kernel_prereq fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
97 Packager: PlanetLab Central <support@planet-lab.org>
98 Distribution: PlanetLab %{plrelease}
99 URL: %(echo %{url} | cut -d ' ' -f 2)
102 Group: System Environment/Kernel
104 Version: %{rpmversion}
107 Provides: kernel = %{version}
108 Provides: kernel-drm = 4.3.0
109 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
110 Provides: kernel-smp = %{rpmversion}-%{release}
111 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
112 Prereq: %{kernel_prereq}
113 Conflicts: %{kernel_dot_org_conflicts}
114 Conflicts: %{package_conflicts}
115 Conflicts: %{nptl_conflicts}
116 # We can't let RPM do the dependencies automatic because it'll then pick up
117 # a correct but undesirable perl dependency from the module headers which
118 # isn't required for the kernel proper to function
122 # List the packages used during the kernel build
124 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
125 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
126 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
127 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
130 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
132 Source11: %{pldistro}-%{kversion}-i686.config
133 Source12: %{pldistro}-%{kversion}-x86_64.config
135 Source20: %{pldistro}-%{kversion}-i686-uml.config
138 Source30: %{pldistro}-%{kversion}-i686-xenU.config
143 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
146 Patch010: linux-2.6-010-e1000e.patch
147 Patch020: linux-2.6-020-build-id.patch
148 Patch030: linux-2.6-030-netns.patch
149 Patch040: linux-2.6-040-i_mutex-check.patch
151 # These are patches picked up from Fedora/RHEL
152 Patch100: linux-2.6-100-build-nonintconfig.patch
155 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
156 Patch210: linux-2.6-210-vserver-cpu-sched.patch
157 Patch220: delta-ptrace-fix01.diff
160 Patch250: linux-2.6-250-ipsets.patch
163 Patch500: linux-2.6-500-vserver-filesharing.patch
164 Patch510: linux-2.6-510-ipod.patch
165 Patch521: linux-2.6-521-packet-tagging.patch
166 Patch522: linux-2.6-522-iptables-connection-tagging.patch
167 Patch523: linux-2.6-523-raw-sockets.patch
168 Patch524: linux-2.6-524-peercred.patch
169 Patch525: linux-2.6-525-sknid-elevator.patch
170 Patch526: linux-2.6-526-tun-tap.patch
171 Patch527: linux-2.6-527-iptables-classify-add-mark.patch
172 Patch530: linux-2.6-530-built-by-support.patch
173 Patch540: linux-2.6-540-oom-kill.patch
174 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
175 Patch560: linux-2.6-560-mmconf.patch
176 Patch570: linux-2.6-570-tagxid.patch
177 Patch580: linux-2.6-580-show-proc-virt.patch
178 Patch590: linux-2.6-590-chopstix-intern.patch
179 Patch620: linux-2.6-620-kdb.patch
180 Patch630: linux-2.6-630-sched-fix.patch
181 Patch640: linux-2.6-640-netlink-audit-hack.patch
182 Patch650: linux-2.6-650-hangcheck-reboot.patch
183 Patch660: linux-2.6-660-nmi-watchdog-default.patch
184 %if "%{distroname}" == "f9" || "%{distroname}" == "f10"
185 Patch670: linux-2.6-670-gcc43.patch
187 Patch680: linux-2.6-680-htb-hysteresis-tso.patch
188 Patch690: linux-2.6-690-web100.patch
190 # See also the file named 'sources' here for the related checksums
191 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
192 # see http://bughost.org/bugzilla/show_bug.cgi?id=1584
194 %define mac80211_version 10.0.4
195 Patch600: http://intellinuxwireless.org/mac80211/downloads/mac80211-%{mac80211_version}.tgz
196 %define iwlwifi_version 1.2.25
197 Patch601: http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-%{iwlwifi_version}.tgz
200 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
203 The kernel package contains the Linux kernel (vmlinuz), the core of any
204 Linux operating system. The kernel handles the basic functions
205 of the operating system: memory allocation, process allocation, device
206 input and output, etc.
209 Summary: Development package for building kernel modules to match the kernel.
210 Group: System Environment/Kernel
212 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
213 Provides: kernel-smp-devel = %{rpmversion}-%{release}
214 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
215 Prereq: /usr/bin/find
218 This package provides kernel headers and makefiles sufficient to build modules
219 against the kernel package.
223 Summary: Various documentation bits found in the kernel source.
227 This package contains documentation files from the kernel
228 source. Various bits of information about the Linux kernel and the
229 device drivers shipped with it are documented in these files.
231 You'll want to install this package if you need a reference to the
232 options that can be passed to Linux kernel modules at load time.
235 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
237 Group: System Environment/Kernel
238 Provides: kernel = %{version}
239 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
240 Prereq: %{kernel_prereq}
241 Conflicts: %{kernel_dot_org_conflicts}
242 Conflicts: %{package_conflicts}
243 Conflicts: %{nptl_conflicts}
246 # Conflicts: %{xen_conflicts}
248 # We can't let RPM do the dependencies automatic because it'll then pick up
249 # a correct but undesirable perl dependency from the module headers which
250 # isn't required for the kernel proper to function
254 This package includes a version of the Linux kernel which
255 runs in Xen unprivileged guest VMs. This should be installed
256 both inside the unprivileged guest (for the modules) and in
260 Summary: Development package for building kernel modules to match the kernel.
261 Group: System Environment/Kernel
263 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
264 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
265 Provides: kernel-devel = %{rpmversion}-%{release}xenU
266 Prereq: /usr/sbin/hardlink, /usr/bin/find
268 %description xenU-devel
269 This package provides kernel headers and makefiles sufficient to build modules
270 against the kernel package.
273 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
275 Group: System Environment/Kernel
278 This package includes a user mode version of the Linux kernel.
281 Summary: Development package for building kernel modules to match the UML kernel.
282 Group: System Environment/Kernel
283 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
284 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
285 Provides: kernel-devel = %{rpmversion}-%{release}smp
287 Prereq: /usr/sbin/hardlink, /usr/bin/find
289 %description uml-devel
290 This package provides kernel headers and makefiles sufficient to build modules
291 against the User Mode Linux kernel package.
294 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
296 Group: System Environment/Kernel
298 %description uml-modules
299 This package includes a user mode version of the Linux kernel modules.
302 Summary: A placeholder RPM that provides kernel and kernel-drm
304 Group: System Environment/Kernel
305 Provides: kernel = %{version}
306 Provides: kernel-drm = 4.3.0
307 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
310 VServers do not require and cannot use kernels, but some RPMs have
311 implicit or explicit dependencies on the "kernel" package
312 (e.g. tcpdump). This package installs no files but provides the
313 necessary dependencies to make rpm and yum happy.
317 # First we unpack the kernel tarball.
318 # If this isn't the first make prep, we use links to the existing clean tarball
319 # which speeds things up quite a bit.
320 if [ ! -d kernel-%{kversion}/vanilla ]; then
321 # Ok, first time we do a make prep.
322 rm -f pax_global_header
323 %setup -q -n %{name}-%{kversion} -c
324 mv linux-%{kversion} vanilla
326 # We already have a vanilla dir.
327 cd kernel-%{kversion}
330 KERNEL_PREVIOUS=vanilla
331 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
332 %define ApplyPatch() \
333 rm -fr linux-%{kversion}-%1 \
334 cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1 \
336 test "%2" != "%%2" && patchflag="%2" \
337 PATCH="%{expand:%{PATCH%1}}" \
338 if test ! -e "$PATCH"; then \
339 echo "Patch %1 does not exist!" \
343 *.bz2) bzcat "$PATCH";; \
344 *.gz) zcat "$PATCH";; \
346 esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
347 KERNEL_PREVIOUS=linux-%{kversion}-%1
349 # This is where the patches get applied
357 # NetNS patch for VINI
395 %if "%{distroname}" == "f9" || "%{distroname}" == "f10"
402 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
403 # break with later patches.
406 %ApplyPatch %vini_pl_patch
410 # Run the mac80211 stuff in the kernel tree holding the last patch
412 pushd mac80211-%{mac80211_version}
413 mac80211_makeflags="KSRC=../$KERNEL_PREVIOUS"
414 make $mac80211_makeflags modified
415 make $mac80211_makeflags source
416 make $mac80211_makeflags patch_kernel
419 # Untar iwlwifi in the same place - needs to be compiled later
421 # the install target is broken: first it does not pass the right -b flag to depmod
422 # second we do not need to invoke depmod at this stage anyway
423 # let's add our own patch/stuff in this Makefile for manual install later on
424 pushd iwlwifi-%{iwlwifi_version}
425 cat >> Makefile <<EOF
427 @echo \$(addprefix \$(DIR),\$(addsuffix .ko,\$(list-m)))
432 rm -fr linux-%{kversion}
433 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
437 # make sure the kernel has the sublevel we know it has. This looks weird
438 # but for -pre and -rc versions we need it since we only want to use
439 # the higher version when the final kernel is released.
440 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
441 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
443 # get rid of unwanted files resulting from patch fuzz
444 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
457 rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
458 cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
459 cd linux-%{_target_cpu}-%{kversion}$Flavour
461 # Pick the right config file for the kernel we're building
462 if [ -n "$Flavour" ] ; then
463 Config=%{pldistro}-%{kversion}-%{_target_cpu}-$Flavour.config
464 DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
465 DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
467 Config=%{pldistro}-%{kversion}-%{_target_cpu}.config
468 DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
472 KernelVer=%{version}-%{release}$Flavour
473 echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
475 # make sure EXTRAVERSION says what we want it to say
476 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
478 # and now to start the build process
481 cp %{_sourcedir}/$Config .config
483 #Arch=`head -1 .config | cut -b 3-`
484 echo USING ARCH=$Arch
486 make -s ARCH=$Arch nonint_oldconfig > /dev/null
487 make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
488 make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
491 # build the iwlwifi driver
492 make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
493 KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour
496 # Start installing the results
498 %if "%{_enable_debug_packages}" == "1"
499 mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
501 mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
502 install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
503 install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
504 if [ -f arch/$Arch/boot/bzImage ]; then
505 cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
507 if [ -f arch/$Arch/boot/zImage.stub ]; then
508 cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
510 if [ "$Flavour" = "uml" ] ; then
511 install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
514 mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
515 make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
519 # make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
520 # KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour \
521 # KMISC=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless install
522 pushd %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version}
523 iwlwifi_dest=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless
524 # get the list and location of modules to install - no need to pass KSRC nor anything, let's keep it simple
525 iwlwifi_modules=$(make --no-print-directory module-list)
526 install -d $iwlwifi_dest
527 install -m 644 -c $iwlwifi_modules $iwlwifi_dest
531 # And save the headers/makefiles etc for building modules against
533 # This all looks scary, but the end result is supposed to be:
534 # * all arch relevant include/ files
535 # * all Makefile/Kconfig files
536 # * all script/ files
538 rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
539 rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
540 mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
541 (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
542 # dirs for additional modules per module-init-tools, kbuild/modules.txt
543 mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
544 mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
545 # first copy everything
546 cp --parents `find -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
547 cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
548 if [ "$Flavour" = "uml" ] ; then
549 cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
551 # then drop all but the needed Makefiles/Kconfig files
552 rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
553 rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
554 rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
555 cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
556 cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
557 cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
558 if [ -d arch/%{_arch}/scripts ]; then
559 cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
561 if [ -f arch/%{_arch}/*lds ]; then
562 cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
564 rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
565 rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
566 mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
568 cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
569 cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
570 if [ "$Arch" = "x86_64" ]; then
571 cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
574 if [ "$Flavour" = "xenU" ]; then
575 cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
576 cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
580 if [ "$Flavour" = "uml" ] ; then
581 cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
584 # While arch/powerpc/include/asm is still a symlink to the old
585 # include/asm-ppc{64,} directory, include that in kernel-devel too.
586 if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
587 cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
588 mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
589 pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
590 ln -sf ../../../include/asm-ppc* asm
594 # Make sure the Makefile and version.h have a matching timestamp so that
595 # external modules can be built
596 touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
597 touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
601 # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
603 %if "%{_enable_debug_packages}" == "1"
604 mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
605 cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
608 if [ -f vmlinuz ]; then
609 cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
613 find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
615 # mark modules executable so that strip-to-file can strip them
616 cat modnames | xargs chmod u+x
618 # remove files that will be auto generated by depmod at rpm -i time
619 rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
621 # Move the devel headers out of the root file system
622 mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
623 mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
624 ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
625 [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
632 # prepare directories
633 rm -rf $RPM_BUILD_ROOT
634 mkdir -p $RPM_BUILD_ROOT/boot
636 %if "%{_target_cpu}" == "x86_64"
637 %define kernel_arch %{_target_cpu}
639 %if "%{_target_cpu}" == "i586"
640 %define kernel_arch i386
642 %if "%{_target_cpu}" == "i686"
643 %define kernel_arch i386
647 BuildKernel %make_target %kernel_arch
652 BuildKernel linux um uml
656 BuildKernel vmlinuz %kernel_arch xenU
668 %if %{buildxen} && "%{_target_cpu}" == "i686"
669 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
670 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
671 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
672 # This directive teaches ldconfig to search in nosegneg subdirectories
673 # and cache the DSOs there with extra bit 0 set in their hwcap match
674 # fields. In Xen guest kernels, the vDSO tells the dynamic linker to
675 # search in nosegneg subdirectories and to match this extra hwcap bit
676 # in the ld.so.cache file.
679 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
683 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
685 # sometimes non-world-readable files sneak into the kernel source tree
687 # copy the source over
688 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
696 rm -rf $RPM_BUILD_ROOT
702 # load the loop module for upgrades...in case the old modules get removed we have
703 # loopback in the kernel so that mkinitrd will work.
705 /sbin/modprobe loop 2> /dev/null > /dev/null || :
709 if [ -f /etc/sysconfig/kernel ]; then
710 /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
713 # trick mkinitrd in case the current environment does not have device mapper
714 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
715 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
716 if [ ! -f $rootdev ]; then
718 mkdir -p $(dirname $rootdev)
723 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
724 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
725 # Older modutils do not support --package option
726 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
729 if [ -n "$fake_root_lvm" ]; then
733 # make some useful links
734 pushd /boot > /dev/null ; {
735 ln -sf config-%{KVERREL} config
736 ln -sf config-%{KVERREL} configsmp
737 ln -sf initrd-%{KVERREL}.img initrd-boot
738 ln -sf initrd-%{KVERREL}.img initrd-bootsmp
739 ln -sf vmlinuz-%{KVERREL} kernel-boot
740 ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
745 mkdir -p /etc/planetlab
746 touch /etc/planetlab/update-reboot
749 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
750 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
751 pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
752 /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
757 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
758 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
761 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
762 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
763 pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
764 /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
769 depmod -ae %{KVERREL}uml
772 /sbin/modprobe loop 2> /dev/null > /dev/null || :
773 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
776 /sbin/modprobe loop 2> /dev/null > /dev/null || :
777 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
780 rm -f /lib/modules/%{KVERREL}uml/modules.*
789 %defattr(-,root,root)
790 /%{image_install_path}/vmlinuz-%{KVERREL}
791 /boot/System.map-%{KVERREL}
792 /boot/config-%{KVERREL}
793 %dir /lib/modules/%{KVERREL}
794 /lib/modules/%{KVERREL}/kernel
795 /lib/modules/%{KVERREL}/build
796 /lib/modules/%{KVERREL}/source
797 /lib/modules/%{KVERREL}/extra
798 /lib/modules/%{KVERREL}/updates
801 %defattr(-,root,root)
802 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
805 %if %{builduml} && "%{_target_cpu}" == "i686"
807 %defattr(-,root,root)
811 %defattr(-,root,root)
812 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
813 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
816 %defattr(-,root,root)
817 /boot/System.map-%{KVERREL}uml
818 /boot/config-%{KVERREL}uml
819 %dir /lib/modules/%{KVERREL}uml
820 /lib/modules/%{KVERREL}uml/kernel
821 /lib/modules/%{KVERREL}uml/build
822 /lib/modules/%{KVERREL}uml/source
823 /lib/modules/%{KVERREL}uml/extra
824 /lib/modules/%{KVERREL}uml/updates
827 %if %{buildxen} && "%{_target_cpu}" == "i686"
829 %defattr(-,root,root)
830 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
831 /boot/System.map-%{KVERREL}xenU
832 /boot/config-%{KVERREL}xenU
833 %dir /lib/modules/%{KVERREL}xenU
834 /lib/modules/%{KVERREL}xenU/kernel
835 /lib/modules/%{KVERREL}xenU/build
836 /lib/modules/%{KVERREL}xenU/source
837 /lib/modules/%{KVERREL}xenU/extra
838 /lib/modules/%{KVERREL}xenU/updates
839 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
842 %defattr(-,root,root)
843 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
844 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
848 %defattr(-,root,root)
851 # only some architecture builds need kernel-doc
855 %defattr(-,root,root)
856 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
857 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
858 %dir %{_datadir}/doc/kernel-doc-%{kversion}
862 * Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-22-32
863 - support building on fedora 10
865 * Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-31
866 - add patches for m-lab and drl
868 * Tue Nov 11 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-30
869 - Use Intel's e1000e driver.
871 * Thu Oct 02 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-22-29
872 - added drivers for OPTION's globetrotter (gt 3g+ emea) umts cards
873 - + cleanup outdated configs
875 * Wed Sep 17 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-28
876 - Recovering a hunk that I accidentally ommited out of the last commit. Should not entail retesting, because the commits
879 * Sun Sep 14 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-27
880 - Fixing the accounting issue that causes certain connections to be misaccounted, and that causes NM/peercreds to
881 - intermittently break.
883 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-22-26
884 - patch for building on f9/gcc-4.3, no functional change on other distros
886 * Sun Aug 17 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-25
889 * Tue Aug 12 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-24
890 - Enable nmi watchdog by default.
892 * Mon Aug 04 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-23
893 - Fixed a bug in my previous commit.
895 * Mon Aug 04 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-22
896 - * 1 fix for using udp/listening sockets via raw
897 - * 1 fix to help codemux divide traffic in PlanetFlow
899 * Fri Aug 01 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-21
900 - Codemux calls setsockopt/SO_PEERCRED to set peer credentials on a socket, so that the connections it proxies to its clients are tagged for PlanetFlow. This hunk got lost somewhere along the way.
902 * Thu Jul 31 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-20
903 - Removed a debugging statement. Shows up a lot in the debug logs.
905 * Wed Jul 30 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-19
906 - Unbroke peercred setting.
908 * Mon Jul 28 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-18
909 - Now you can write your own TCP using packet sockets. As a side effect, tcptraceroute runs to completion including the
912 * Mon Jul 28 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-17
913 - Optimize packet socket support to eliminate a packet copy.
915 * Sun Jul 27 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-16
916 - Missed this header file, which broke the compile.
917 - I'll be doing another tag to include an optimization I left out of this version. This version is for Build only.
919 * Sun Jul 27 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-15
920 - Fixes to tcpdump-related problems reported recently.
922 * Wed Jul 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-14
923 - added fix to process visibility so when ncontext/vcontext run netstat in
924 - xid=1, it can see all ports & processes.
926 * Mon Jul 21 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-13
927 - fix for tcpdump/tcp payloads
929 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-12
931 - * Attempt to fix TCP-payload-related problems with tcpdump
933 * Wed Jul 09 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-11
934 - * Split up VNET+ module into its component patches
935 - * Added tun/tap support
937 * Tue Jul 08 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-10
938 - Filling a statically allocated buffer cannot fail, right?
940 * Wed Jun 25 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-9
941 - Enable the hangcheck timer driver, and build it in to the kernel.
942 - Dump relevant data on the scheduler bug instead of BUGing.
944 * Sat Jun 07 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-8
945 - * Partial fix for the UDP-packet-pollution problem
946 - * Support for PF_PACKET sockets
947 - * Support for SOCK_PACKET sockets
948 - * Disabled Chopstix with mutexes
949 - * Tested VNET+ under heavy loads
953 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-7
954 - Bringing this fix in for tcpdump and ping
957 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-6
958 - Updated configuration to include COW again.
960 - Patches from Sapan to fix ping losses.
962 - Still need help with tcpdump traffic.
965 * Tue May 06 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-5
966 - Patch needs to be applied.
968 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-4
971 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-22-3
972 - Fix bug with looping in schedule()
974 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-2
975 - Includes changes from Sapan/Andy regarding the scheduler and vnet bugs.
976 - Should be safe to try a second deployment.
979 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
981 - Disable split pagetable lock.
983 * Wed Jul 5 2006 Dave Jones <davej@redhat.com>
984 - Get rid of stack backtrace on panic, which in most
985 cases actually caused a loss of info instead of a gain.
987 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
990 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
992 - Fix up the alsa list_add bug.
994 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
995 - Fix up various stupidities incurred by the last big rebase.
996 - Reenable SMP x86-64 builds.
998 - Enable PCI fake hotplug driver.
999 - Enable gameport/joystick on i586 builds. (#196581)
1001 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
1002 - Enable profiling for 586 kernels.
1004 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
1005 - Rebuild with slab debug off.
1007 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
1010 * Mon Jun 5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
1013 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
1016 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
1017 - Improved list_head debugging.
1019 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
1022 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
1025 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
1028 * Tue May 9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
1030 - make 16C950 UARTs work (again). (#126403)
1031 - Fix exec-shield default, which should fix a few programs that
1034 * Thu May 4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
1037 * Tue May 2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
1040 * Mon May 1 2006 Dave Jones <davej@redhat.com>
1043 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
1044 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
1046 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
1049 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
1050 - Enable PCI MSI support.
1052 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
1055 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
1058 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
1061 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
1064 * Fri Apr 7 2006 Dave Jones <davej@redhat.com>
1067 * Tue Apr 4 2006 Dave Jones <davej@redhat.com>
1068 - Reenable non-standard serial ports. (#187466)
1069 - Reenable snd-es18xx for x86-32 (#187733)
1071 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
1072 - ship the .kernelrelease file in -devel too.
1073 - Disable EDAC debug.
1075 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
1078 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
1079 - Include patches posted for review for inclusion in 2.6.16.1
1080 - Updated new audit msg types.
1081 - Reenable HDLC driver (#186257)
1082 - Make acpi-cpufreq 'sticky'
1083 - Fix broken x86-64 32bit vDSO (#186924)
1085 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
1086 - Improve spinlock scalability on big machines.
1088 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
1089 - Sync with FC5's 2.6.16 kernel.
1090 - Update Tux & Exec-shield to latest.