4 %define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/WWW/trunk/PLCWWW.spec $
6 %define name nodeconfig
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 Summary: PlanetLab Central (PLC) nodes configuration files generator
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
27 # We use set everywhere
29 Requires: PLCAPI >= 5.0
30 # need the apache user at install-time
35 The nodeconfig package provides various php scripts that are used to
36 generate configuration files for nodes. It is taken out of the PLCWWW
37 module because it has crucial impact on nodes, while PLCWWW can and
38 does have several implementations at this moment. For historical
39 reasons these scripts get installed in /var/www/html/PlanetLabConf.
47 KEXCLUDE="exclude=$(../../build/getkexcludes.sh)"
49 # expand list of kexcludes
50 for filein in $(find . -name '*.in') ; do
51 file=$(echo $filein | sed -e "s,\.in$,,")
52 sed -e "s,@KEXCLUDE@,$KEXCLUDE,g" $filein > $file
55 # scan fcdistros and catenate all repos in 'stock.repo' so db-config can be distro-independant
57 for fcdistro in $(ls); do
58 [ -d $fcdistro ] || continue
59 pushd $fcdistro/yum.myplc.d
61 cat *.repo > stock.repo
68 rm -rf $RPM_BUILD_ROOT
72 echo "* nodeconfig: Installing PlanetLabConf pages"
74 for dir in boot PlanetLabConf PLCAPI ; do
75 mkdir -p $RPM_BUILD_ROOT/var/www/html/$dir
76 rsync -a --exclude .svn ./$dir/ $RPM_BUILD_ROOT/var/www/html/$dir/
79 # the yum area -- se db-config
80 # expose (fixed) myplc.repo.php as https://<plc>/yum/myplc.repo.php
81 install -D -m 644 ./yum/myplc.repo.php $RPM_BUILD_ROOT/var/www/html/yum/myplc.repo.php
82 # expose the fcdistro-dependant yum.conf as https://<plc>/yum/yum.conf
83 install -D -m 644 ./yum/%{distroname}/yum.conf $RPM_BUILD_ROOT/var/www/html/yum/yum.conf
84 # expose the (fcdistro-dependant) stock.repo as https://<plc>/yum/stock.repo
85 install -D -m 644 ./yum/%{distroname}/yum.myplc.d/stock.repo $RPM_BUILD_ROOT/var/www/html/yum/stock.repo
90 rm -rf $RPM_BUILD_ROOT
93 # the boot manager upload area
95 chown apache:apache /var/log/bm
99 %defattr(-,root,root,-)
101 /var/www/html/PlanetLabConf
106 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-5.0-1
107 - reflects new names from the data model
109 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-4
110 - keys.php know about monitor
111 - new sudoers.php script
113 * Thu Apr 03 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-2 nodeconfig-4.2-3
114 - Added support for centralized PlanetFlow.
116 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-1 nodeconfig-4.2-2
117 - integrated /var/www/html/{boot,PLCAPI} from PLCWWW
118 - former content has moved down into PlanetLabConf
121 %define module_current_branch 4.2