1 # we define this in a separate specfile because we cannot produce all the 3 packages
2 # nodemanager-lib nodemanager-vs nodemanager-lxc in a single build
4 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
6 %define name nodemanager-lxc
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 Summary: PlanetLab Node Manager Plugin for lxc nodes
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
28 Requires: libvirt-python
29 # cgroups.py needs this
30 Requires: python-inotify
31 # the common package for nodemanager
32 Requires: nodemanager-lib
33 # the lxc-specific tools for using slice images
34 Requires: lxc-sliceimage
36 # Requires: sliceimage-lxc-f16-x86_64 >= 5.1-3
39 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
45 # make manages the C and Python stuff
46 %{__make} %{?_smp_mflags} lxc
49 # make manages the C and Python stuff
50 rm -rf $RPM_BUILD_ROOT
51 %{__make} %{?_smp_mflags} install-lxc DESTDIR="$RPM_BUILD_ROOT"
54 rm -rf $RPM_BUILD_ROOT
57 %defattr(-,root,root,-)
58 %{_datadir}/NodeManager/
61 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
62 - fixes in hostmap, and in interfaces
64 - privatebridge now comes with nodemanager-lib
66 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
67 - omf plugin does not block any longer when running trigger script
68 - log goes into sliver's /var/log instead
70 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
71 - new install-scripts target in Makefile
72 - conf_files and fuse-pl initscripts chmod'ed +x
73 - omf_resctl config template tweaked to use _slicename_%_hostname_
75 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
76 - make sure to create /etc/planetlab/virt so others can read that
77 - expose get_node_virt() and command_in_slice()
78 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
79 - user's .profile now has right owner
80 - other tweaks in lxc slivers
82 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
83 - lxc slice creation: slice user was created with unknown gid - fixed
84 - lxc slice creation: .profile for root and user - fixed
86 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
87 - fix umounting of ssh directory when deleting omf-friendly slivers
88 - support for writing cgroups in subsystems other than cpuset
89 - add xid to template match
90 - finer-grained split between -lib -vs and -lxc
91 - first roughly complete omf_resctl for omfv6
92 - minor fix for when getslivers does not have minexemptrate
94 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
95 - Fix path, machine arch in slivers
97 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
99 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
100 - no-op bump to 5.2 to be in line with the rest of the system
102 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
103 - improvements to privatebridge
105 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
106 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
108 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
109 - fix wrong gre tunnel deleted when topology changes
111 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
112 - Update /etc/hosts in slivers from sliver_hostmap tag.
114 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
115 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
116 - initial check-in of privatebridge plugin.
118 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
119 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
121 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
122 - fix slices not deleted properly when they use vsys
124 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
125 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
127 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
128 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
130 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
131 - Bridge virtual interfaces to VLANs
133 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
134 - Add support for L2 bridged interfaces with public IPs inside a slice
136 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
137 - Support for freezing BestEffort slices for Vicci
139 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
140 - Change to use new vsh (wrapper for lxcsu)
142 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
144 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
146 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
147 - tag 2.1-7 was broken for OMF-friendly slices
148 - expose_ssh_dir was erroneously defined on the Worker class
150 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
151 - bwlimitlxc now ships with plnode-utils
153 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
154 - set LD_PRELOAD for linux-containers nodes
156 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
157 - first complete version for vs and lxc - functional but not thoroughly tested though
159 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
160 - split packaging in 3 (lib, lxc, vs)
161 - this tag will only work with lxc though