4e0a59d594f86418de9b72a11971773967a5aa66
[yum.git] / original / yum.spec
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3 Summary: RPM installer/updater
4 Name: yum
5 Version: 3.2.22
6 Release: 26%{?dist}
7 License: GPLv2+
8 Group: System Environment/Base
9 Source0: http://linux.duke.edu/projects/yum/download/3.2/%{name}-%{version}.tar.gz
10 Source1: yum.conf.fedora
11 Source2: yum-updatesd.conf.fedora
12
13 #  See: http://people.redhat.com/jantill/gits/yum branch el-5.3-master
14 # and the el5.3* branches for the individual patches.
15
16 # Fedora patches we might as well carry
17 Patch0: installonlyn-enable.patch
18 Patch1: yum-mirror-priority.patch
19 Patch2: yum-manpage-files.patch
20 Patch3: yum-ia64-multilib.patch
21 # NOTE: We don't carry this as it'd change the policy mid cycle
22 # Patch3: yum-multilib-policy-best.patch
23
24 # Work around python-2.4.z's gettext ... maybe not needed post 5.3
25 Patch102: yum-hack-python-gettext-workaround.patch
26 # SSL, although it's still done in RHN-plugin
27 # Also fixes 462915: client and server x509 support for Yum
28 Patch103: yum-3.2.22-client+server-x509.patch
29
30 # Python-2.* is just too sucky to enable this
31 Patch104: yum-3.2.22-i18n-off.patch
32
33 # Post 3.2.22 release upstream changes
34 Patch110: yum-3.2.22-post-BIG.patch
35 Patch111: yum-3.2.22-txmbr-sort.patch
36 Patch112: yum-3.2.22-kernel-updates-minimize.patch
37 Patch113: yum-3.2.22-pylin-indent-fix.patch
38 Patch114: yum-3.2.22-i18n-gettext-typo-fix.patch
39 Patch115: yum-3.2.22-sort-providers.patch
40 Patch116: yum-3.2.22-local-pkgs.patch
41 Patch117: yum-3.2.22-rawhide-fixes.patch
42 Patch118: yum-3.2.22-regression.patch
43 Patch119: yum-3.2.22-reinstall-local.patch
44 Patch120: yum-3.2.23-rawhide-fixes.patch
45
46 # 5.5 patches...
47 Patch201: BZ-517286-instant-downloads.patch
48 Patch202: BZ-521008-regression-update-not-exist.patch
49 Patch203: BZ-526064-check-update-obs.patch
50 Patch204: BZ-528738-bugtracker.patch
51 Patch205: BZ-528746-reinstall-compat-rpm.patch
52 Patch206: BZ-529233-faster-compare_providers.patch
53 Patch207: BZ-529719-base_package_name-compare_providers.patch
54 Patch208: BZ-548582-excludes-source-repos-crash.patch
55 Patch209: BZ-523135-newest-obs-only.patch
56
57 URL: http://linux.duke.edu/yum/
58 BuildArchitectures: noarch
59 BuildRequires: python
60 BuildRequires: gettext
61 BuildRequires: intltool
62 Conflicts: pirut < 1.1.4
63 Conflicts: yum-versionlock < 1.1.16-13.el5
64 Requires: python >= 2.4, rpm-python, rpm >= 0:4.4.2
65 Requires: python-iniparse
66 Requires: python-sqlite
67 Requires: urlgrabber >= 3.1.0
68 Requires: python-elementtree
69 # Make sure metadata code is updated too
70 Requires: yum-metadata-parser >= 1.1.0
71 Requires: yum-fastestmirror
72 Conflicts: yum-rhn-plugin < 0.5.3-30.el5
73 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
74 Obsoletes: yum-skip-broken
75 Conflicts: yum-skip-broken
76 Obsoletes: yum-basearchonly
77 Conflicts: yum-basearchonly
78 # yum-complete-transaction from 1.1.10-9.el5 has problems:
79 Conflicts: yum-utils < 1.1.16-11
80 # We don't require this in RHEL, although it'll use it if you have it
81 # suggests would be ok, if it worked and if pygpgme wasn't in EPEL :).
82 # Requires: pygpgme
83 Obsoletes: yum-allow-downgrade < 1.1.20-0
84 Obsoletes: yum-plugin-allow-downgrade < 1.1.22-0
85 Obsoletes: yum-repolist
86
87 %description
88 Yum is a utility that can check for and automatically download and
89 install updated RPM packages. Dependencies are obtained and downloaded 
90 automatically prompting the user as necessary.
91
92 %package updatesd
93 Summary: Update notification daemon
94 Group: Applications/System
95 Requires: yum = %{version}-%{release}
96 Requires: dbus-python
97 Requires: pygobject2
98 Requires(preun): /sbin/chkconfig
99 Requires(post): /sbin/chkconfig
100 Requires(preun): /sbin/service
101 Requires(post): /sbin/service
102
103 %description updatesd
104 yum-updatesd provides a daemon which checks for available updates and 
105 can notify you when they are available via email, syslog or dbus. 
106
107 %prep
108 %setup -q
109
110 %define _default_patch_fuzz 2
111
112 %patch0 -p1
113 %patch1 -p1
114 %patch2 -p1
115 %patch3 -p1
116
117 %patch102 -p1
118 %patch103 -p1
119
120 %patch104 -p1
121
122 %patch110 -p1
123 %patch111 -p1
124 %patch112 -p1
125 %patch113 -p1
126 %patch114 -p1
127 %patch115 -p1
128 %patch116 -p1
129 %patch117 -p1
130 %patch118 -p1
131 %patch119 -p1
132 %patch120 -p1
133
134 %patch201 -p1
135 %patch202 -p1
136 %patch203 -p1
137 %patch204 -p1
138 %patch205 -p1
139 %patch206 -p1
140 %patch207 -p1
141 %patch208 -p1
142 %patch209 -p1
143
144 %build
145 make
146
147 %install
148 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
149 make DESTDIR=$RPM_BUILD_ROOT install
150 install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/yum.conf
151
152 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/yum/pluginconf.d $RPM_BUILD_ROOT/usr/lib/yum-plugins
153
154 # for now, move repodir/yum.conf back
155 mv $RPM_BUILD_ROOT/%{_sysconfdir}/yum/repos.d $RPM_BUILD_ROOT/%{_sysconfdir}/yum.repos.d
156 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum.conf
157
158 # yum-updatesd has moved to the separate source version
159 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum-updatesd.conf 
160 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/yum-updatesd
161 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/dbus-1/system.d/yum-updatesd.conf
162 rm -f $RPM_BUILD_ROOT/%{_sbindir}/yum-updatesd
163 rm -f $RPM_BUILD_ROOT/%{_mandir}/man*/yum-updatesd*
164
165 rm -f $RPM_BUILD_ROOT/%{_datadir}/yum-cli/yumupd.py*
166
167 %find_lang %name
168
169 %clean
170 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
171
172 %files -f %{name}.lang
173 %defattr(-, root, root, -)
174 %doc README AUTHORS COPYING TODO INSTALL ChangeLog PLUGINS
175 %config(noreplace) %{_sysconfdir}/yum.conf
176 %dir %{_sysconfdir}/yum
177 %dir %{_sysconfdir}/yum.repos.d
178 %config(noreplace) %{_sysconfdir}/logrotate.d/yum
179 %dir %{_datadir}/yum-cli
180 %{_datadir}/yum-cli/*
181 %{_bindir}/yum
182 %{python_sitelib}/yum
183 %{python_sitelib}/rpmUtils
184 %dir /var/cache/yum
185 %dir /var/lib/yum
186 %{_mandir}/man*/yum.*
187 %{_mandir}/man*/yum-shell*
188 # plugin stuff
189 %dir %{_sysconfdir}/yum/pluginconf.d 
190 %dir /usr/lib/yum-plugins
191
192 %changelog
193 * Sun Apr 04 2010 Karanbir Singh <kbsingh@centos.org> - 3.2.22-26.el5.centos
194 - Make installonly be 5
195 - Require fastest mirror plugin
196 - Obsolete yum-repolist
197
198 * Tue Feb 23 2010 James Antill <jantill@redhat.com> - 3.2.22-26
199 - Only look at the newest packages for obsoletes, again.
200 - Resolves: rhbz#523135
201
202 * Tue Feb 16 2010 James Antill <jantill@redhat.com> - 3.2.22-25
203 - Fix weird excludes bug for source repos.
204 - Resolves: rhbz#548582
205
206 * Wed Jan 27 2010 James Antill <jantill@redhat.com> - 3.2.22-24
207 - Fix reinstall error handling, due to yumdb usage, bad backport of
208 - patch for 528746.
209 - Resolves: rhbz#559164
210
211 * Thu Dec 17 2009 James Antill <jantill@redhat.com> - 3.2.22-23
212 - Fix bugtracker URL
213 - Resolves: rhbz#528738
214 - Fix reinstall for rpm and general output fixup.
215 - Resolves: rhbz#528746
216 - Remove slow edge case from compare_providers
217 - Resolves: rhbz#529233
218 - Add base package name check to compare_providers()
219 - Resolves: rhbz#529719
220
221 * Wed Oct  7 2009 James Antill <jantill@redhat.com> - 3.2.22-21
222 - Fix instant downloads crash.
223 - Resolves: rhbz#517286
224 - Fix exit regression when updating packages which don't exist.
225 - Resolves: rhbz#521008
226 - Show obsoletes in check-update, if obsoletes flag is on.
227 - Resolves: rhbz#526064
228
229 * Tue Jul  7 2009 James Antill <jantill@redhat.com> - 3.2.22-20
230 - Resolve weird python unicode() vs. str() perf. problem
231 - Resolves: rhbz#509932
232 - Fixup documentation spelling errors.
233 - Resolves: 510012
234
235 * Fri Jun 26 2009 James Antill <jantill@redhat.com> - 3.2.22-18
236 - Allow API users to set repo directory attributes again.
237 - Resolves: rhbz#508055
238 - Re-Fix pkgSack init loop on empty pkgSacks to make anaconda happy.
239 - Resolves: rhbz#507885
240 - Resolves: rhbz#489256
241
242 * Wed Jun 24 2009 James Antill <jantill@redhat.com> - 3.2.22-16
243 - Fix pkgSack init loop on empty pkgSacks.
244 - Resolves: rhbz#507885
245 - Fix turning off color.
246 - Resolves: rhbz#507883
247 - Fix language testing to use LC_MESSAGES instead of LC_CTYPE.
248 - Resolves: rhbz#507357
249 - Fix to_str not being in misc
250 - Resolves: rhbz#508051
251 - Resolves: rhbz#489256
252
253 * Fri Jun 19 2009 James Antill <jantill@redhat.com> - 3.2.22-15
254 - Fix reinstall with local files.
255 - Resolves: rhbz#489256
256 - Resolves: rhbz#462915
257
258 * Thu May 14 2009 James Antill <jantill@redhat.com> - 3.2.22-14
259 - Fix a couple of regressions.
260 - Conflict with older rhn-plugin
261 - Resolves: rhbz#489256
262 - Resolves: rhbz#462915
263 - Resolves: 500697
264
265 * Tue Apr 28 2009 James Antill <jantill@redhat.com> - 3.2.22-10
266 - Rebase for lots of bug fixes, and some features/speedups.
267 - Resolves: rhbz#489256
268 - Resolves: rhbz#462915
269 - Only look at new obsoletes
270
271 * Tue Nov 25 2008 James Antill <jantill@redhat.com> - 3.2.19-18
272 - Fix utf8 in redhat-logos license
273 - Resolves: rhbz#472375
274
275 * Mon Nov 10 2008 James Antill <jantill@redhat.com> - 3.2.19-16
276 - Fix ia64 multilib for RHEL-5
277 - Resolves: rhbz#469271
278
279 * Tue Oct 28 2008 James Antill <jantill@redhat.com> - 3.2.19-14
280 - Fix yum shell when doing remove commands first.
281 - Resolves: rhbz#468754
282
283 * Thu Oct 23 2008 James Antill <jantill@redhat.com> - 3.2.19-13
284 - Add the timestamp_check option, so we can have repoids to random stuff
285 - Resolves: rhbz#466176
286 - Fix yum shell man page for repo command.
287 - Resolves: rhbz#467415
288 - Resolves: rhbz#454882
289
290 * Thu Oct 16 2008 James Antill <jantill@redhat.com> - 3.2.19-11
291 - Don't show rpm progress when in super quiet mode
292 - Resolves: rhbz#466911
293 - Resolves: rhbz#454882
294
295 * Mon Sep 29 2008 James Antill <jantill@redhat.com> - 3.2.19-10
296 - Fix/hide exceptions on rpm callbacks, to make rpm happier.
297 - Resolves: rhbz#463447
298 - Resolves: rhbz#454882
299
300 * Fri Sep 19 2008 James Antill <jantill@redhat.com> - 3.2.19-9
301 - Fix typo in checkSignals, we rpm has got a signal.
302 - Resolves: rhbz#462784
303 - Resolves: rhbz#454882
304
305 * Tue Sep 16 2008 James Antill <jantill@redhat.com> - 3.2.19-8
306 - Allow yum remove to work without downloading pkgSack MD.
307 - Only install a single package from a provider.
308 - Fix total download cb to use the logger.
309 - Add incomplete transactions warning.
310 - Speed fix for large patterns (notably large package name excludes).
311 - Speed fix for includepkgs.
312 - UI tweak for loaded plugins line.
313 - Dynamic columns support and list/groupinfo-v changes to use it.
314 - Add conflicts as well as obsoletes, so you can't reinstall skip-broken.
315 - Resolves: rhbz#462086
316 - Resolves: rhbz#454882
317
318 * Fri Aug 29 2008 James Antill <jantill@redhat.com> - 3.2.19-6
319 - Fix list searches for name.arch
320 - Resolves: rhbz#454882
321
322 * Thu Aug 28 2008 James Antill <jantill@redhat.com> - 3.2.19-5
323 - Fix minor API gitch in 3.2.19
324 - Obsolete yum-skip-broken, so it auto goes away on update
325 - Resolves: rhbz#454882
326
327 * Wed Aug 27 2008 James Antill <jantill@redhat.com> - 3.2.19-4
328 - Fix minor API gitch in 3.2.19
329 - Resolves: rhbz#454882
330
331 * Tue Aug 26 2008 James Antill <jantill@redhat.com> - 3.2.19-2
332 - Import next upstream 3.2.19.
333 - What will be in Fedora 9 soon.
334 - Resolves: rhbz#454882
335
336 * Wed Aug  6 2008 James Antill <jantill@redhat.com> - 3.2.17-0_beta_18_2
337 - Import next upstream 3.2.18 beta.
338 - What will be in Fedora 9 soon.
339 - Lots of bug fixes, changes for gpgcheck/repo_gpgcheck/update-minimal/etc.
340 - Resolves: rhbz#454882
341
342 * Mon Jul 21 2008 James Antill <jantill@redhat.com> - 3.2.17-0_beta_18_1
343 - Import upstream 3.2.18 beta.
344 - What will be in Fedora 9 soon.
345 - Resolves: rhbz#454882
346
347 * Mon Mar 24 2008 James Antill <jantill@redhat.com> - 3.2.8-10
348 - Allow URLs to work as arguments to -c (config. file)
349 - Resolves: rhbz#447271
350
351 * Mon Mar 24 2008 James Antill <jantill@redhat.com> - 3.2.8-9
352 - Minor man page fix
353 - Resolves: rhbz#438168
354 - Multilib arch problem fix
355 - Resolves: rhbz#437429
356
357 * Tue Mar 11 2008 James Antill <jantill@redhat.com> - 3.2.8-8
358 - Re-add the ssl-ca-cert patch
359 - Resolves: rhbz#436804
360 - Add unused patterns argument
361 - Resolves: rhbz#319491
362
363 * Thu Feb 21 2008 James Antill <jantill@redhat.com> - 3.2.8-7
364 - Hacky workaround for python split gettext bug.
365 - Resolves: rhbz#431073
366
367 * Sun Feb  3 2008 James Antill <jantill@redhat.com> - 3.2.8-6
368 - Tweak config. file for 3.2.8
369 - Resolves: rhbz#237773
370 - Set HTTP user-agent to specify this is yum, and which verison
371 - Resolves: rhbz#319461
372 - Create logdir if it doesn't exist.
373 - Resolves: rhbz#253960
374 - Add committer/comittime
375 - Relates: rhbz#319491
376
377
378 * Tue Jan 22 2008 James Antill <jantill@redhat.com> - 3.2.8-5
379 - Import some of the returnPackages() changes, to fix len() == -1 bug with
380 - some repos. And missing import sqlutils.
381 - Resolves: rhbz#429751
382
383 * Fri Jan 18 2008 James Antill <jantill@redhat.com> - 3.2.8-4
384 - Workaround the worst behaviour of yum install kernel.
385 - Import Fedora 8 yum base.
386 - Add lots of small bug fix patches from 3.2.9
387 - Resolves: rhbz#384691
388
389 * Wed Jan 10 2007 Jeremy Katz <katzj@redhat.com> - 3.0.1-5
390 - fix for 'yum localinstall' with multiarch (#220682)
391
392 * Wed Dec  6 2006 Jeremy Katz <katzj@redhat.com> - 3.0.1-4
393 - revert to older version of rpmsack to not repeatedly open the rpmdb to 
394   avoid problems (Related: #217285, #213963)
395
396 * Tue Nov 14 2006 Peter Jones <pjones@redhat.com> - 3.0.1-3
397 - don't consider arch when getting newest packages in a list (#212626)
398
399 * Fri Nov 10 2006 Jeremy Katz <katzj@redhat.com> - 3.0.1-2
400 - yum-updatesd fixes (#213622, #212494, #212507)
401 - sslcacert option (jbowes, #210977)
402
403 * Fri Nov  3 2006 Jeremy Katz <katzj@redhat.com> - 3.0.1-1
404 - update to 3.0.1
405
406 * Fri Oct 13 2006 Paul Nasrat <pnasrat@redhat.com> - 3.0-6
407 - fix package comparison for available packages
408
409 * Thu Oct 12 2006 Jeremy Katz <katzj@redhat.com> - 3.0-5
410 - fix traceback when syslog not available (#208773)
411 - fix package comparison not properly handling different arches (#210316)
412
413 * Tue Oct 10 2006 Jeremy Katz <katzj@redhat.com> - 3.0-4
414 - fix traceback on package download error (#210135, #210181, #210115)
415
416 * Thu Oct  5 2006 Jeremy Katz <katzj@redhat.com> - 3.0-3
417 - fix traceback referencing var (#209471)
418 - add dgregor's basepath patch
419
420 * Thu Oct  5 2006 Jeremy Katz <katzj@redhat.com> - 3.0-2
421 - fix traceback in yum-updatesd
422
423 * Wed Oct  4 2006 Jeremy Katz <katzj@redhat.com> - 3.0-1
424 - 3.0 
425
426 * Fri Sep 29 2006 Jeremy Katz <katzj@redhat.com> - 2.9.8-1
427 - update to 2.9.8 with the past two fixes as well as fixes for 
428   exclude/include lines in config files
429
430 * Thu Sep 28 2006 Jeremy Katz <katzj@redhat.com> - 2.9.7-4
431 - fix trying to reget existing files (#208460)
432
433 * Wed Sep 27 2006 Jeremy Katz <katzj@redhat.com> - 2.9.7-3
434 - and better fix for upstream (jbowes)
435
436 * Wed Sep 27 2006 Jeremy Katz <katzj@redhat.com> - 2.9.7-2
437 - backout patch that breaks anaconda
438
439 * Wed Sep 27 2006 Jeremy Katz <katzj@redhat.com> - 2.9.7-1
440 - update to 2.9.7
441
442 * Thu Sep 21 2006 James Bowes <jbowes@redhat.com> - 2.9.6-2
443 - Remove unused imports in installonlyn
444
445 * Wed Sep  6 2006 Jeremy Katz <katzj@redhat.com> - 2.9.6-1
446 - update to 2.9.6
447
448 * Tue Sep  5 2006 Jeremy Katz <katzj@redhat.com> - 2.9.5-5
449 - update to current CVS snap (20060906) in advance of the final 2.9.6 tarball
450 - bring back the installonlyn fixes 
451
452 * Thu Aug 31 2006 Jeremy Katz <katzj@redhat.com> - 2.9.5-4
453 - revert installonlyn changes; they require changes that will only be in 2.9.6
454
455 * Wed Aug 30 2006 Jeremy Katz <katzj@redhat.com> - 2.9.5-3
456 - fix deprecation warnings in installonlyn (Jack Neely)
457
458 * Thu Aug 24 2006 Jeremy Katz <katzj@redhat.com> - 2.9.5-2
459 - add patch to fix case of an empty rpmdb (eg, at install time #204005)
460
461 * Wed Aug 23 2006 Jeremy Katz <katzj@redhat.com> - 2.9.5-1
462 - update to 2.9.5
463
464 * Fri Aug 18 2006 Chris Lumens <clumens@redhat.com> 2.9.4-4
465 - Add patch to fix pattern matching (#202974).
466
467 * Fri Aug 18 2006 Karsten Hopp <karsten@redhat.com> - 2.9.4-3
468 - revert last change
469
470 * Thu Aug 17 2006 Karsten Hopp <karsten@redhat.com> - 2.9.4-2
471 - Requires: libxml2-python for updatesd subpackage
472
473 * Wed Aug  9 2006 Jeremy Katz <katzj@redhat.com> - 2.9.4-1
474 - update to 2.9.4 (including logging fixes, gpg checking fix, 
475   and fixes for #200901, #200346, #189483)
476
477 * Mon Jul 24 2006 Florian La Roche <laroche@redhat.com> - 2.9.3-2
478 - add patch to not require /dev/log (not present in chroots) #199558
479
480 * Wed Jul 12 2006 Jeremy Katz <katzj@redhat.com> - 2.9.3-1
481 - update to 2.9.3
482 - add fix for taking the yum lock more than once and a variable typo from CVS
483
484 * Wed Jul  5 2006 Jeremy Katz <katzj@redhat.com> - 2.9.2-3
485 - few other little api fixes (#197603, #197607)
486
487 * Mon Jul  3 2006 Jeremy Katz <katzj@redhat.com> - 2.9.2-2
488 - fix tyop (#197398)
489
490 * Wed Jun 28 2006 Jeremy Katz <katzj@redhat.com> - 2.9.2-1
491 - update to 2.9.2
492
493 * Tue Jun 27 2006 Jeremy Katz <katzj@redhat.com> - 2.9.1-2
494 - move yum-updatesd into a subpackage
495 - no longer ship the yum update cronjob, yum-updatesd can do this instead
496
497 * Tue Jun 20 2006 Jeremy Katz <katzj@redhat.com> - 2.9.1-1
498 - update to 2.9.1
499
500 * Mon Jun 19 2006 Paul Nasrat <pnasrat@redhat.com> - 2.9.0-8
501 - Fix resolvedeps
502
503 * Thu Jun 15 2006 Bill Nottingham <notting@redhat.com> 2.9.0-7
504 - require pygobject2 (for yum-updatesd)
505
506 * Thu Jun 15 2006 Chris Lumens <clumens@redhat.com> 2.9.0-6
507 - Fix compareEVR traceback.
508
509 * Wed Jun 14 2006 Paul Nasrat <pnasrat@redhat.com> - 2.9.0-5
510 - Various fixups (key grab and importing, composite exception handling)
511
512 * Tue Jun 13 2006 Jeremy Katz <katzj@redhat.com> - 2.9.0-4
513 - install yum-updatesd bits
514
515 * Tue Jun 13 2006 Jeremy Katz <katzj@redhat.com> - 2.9.0-3
516 - add patch to fix filelist crash installing/querying the filesystem package
517 - add patch to fix excludes
518
519 * Mon Jun 12 2006 Jeremy Katz <katzj@redhat.com> - 2.9.0-2
520 - add patch for mirror errors
521
522 * Mon Jun 12 2006 Jeremy Katz <katzj@redhat.com> - 2.9.0-1
523 - update to 2.9.0, require C-based metadata parser to speed things up
524
525 * Mon Jun  5 2006 Jeremy Katz <katzj@redhat.com> - 2.6.1-4
526 - handle PAE kernels in installonlyn (#194064)
527
528 * Thu May 25 2006 Paul Nasrat <pnasrat@redhat.com> - 2.6.1-3
529 - Rebuild with patch
530
531 * Wed May 24 2006 Paul Nasrat <pnasrat@redhat.com> - 2.6.1-2
532 - backport mirror failure callback 
533
534 * Wed Apr 26 2006 Jeremy Katz <katzj@redhat.com> - 2.6.1-1
535 - update to 2.6.1 with fixes for #181406, #185309, #161190, #185946
536
537 * Tue Apr 18 2006 Jeremy Katz <katzj@redhat.com> - 2.6.0-3
538 - more proxy fixing for non CLI use case (#185309)
539
540 * Mon Apr 10 2006 Jeremy Katz <katzj@redhat.com> - 2.6.0-2
541 - add fix for xen0/xenU kernels in installonlyn (#187894)
542 - add fix for proxies with the mirror list (#161190)
543
544 * Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 2.6.0-1
545 - update to 2.6.0 final containing fix for #176257
546
547 * Fri Mar 03 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.3-5
548 - Add support for patterns in YumBase.install()
549
550 * Thu Mar 02 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.3-4
551 - Cover pkg then group selection in conditional group support (#181858)
552
553 * Thu Mar 02 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.3-3
554 - Conditional group support (#181858)
555
556 * Fri Feb 24 2006 Jeremy Katz <katzj@redhat.com> - 2.5.3-2
557 - fix installyonlyn bug with tokeep > 2 (#176704)
558
559 * Wed Feb 22 2006 Jeremy Katz <katzj@redhat.com> - 2.5.3-1
560 - Update to 2.5.3 with fixes for lots of stuff (and all of our patches applied)
561   (#177528, #177737, #179512, others)
562
563 * Fri Feb 10 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.1-5
564 - Merge patches from head for group plugin support and conditionals
565
566 * Fri Feb 03 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.1-4
567 - Fix group unselect traceback (cf #177737)
568
569 * Tue Jan 31 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.1-3
570 - Merge upstream patches (sortabletransactiondata, grouplists)
571
572 * Sun Jan 15 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.1-2
573 - Fix group removal traceback (#177737)
574
575 * Sun Jan  8 2006 Jeremy Katz <katzj@redhat.com> - 2.5.1-1
576 - seth loves me and made a 2.5.1 release.  so no cvs snap for you! 
577
578 * Sun Jan  8 2006 Jeremy Katz <katzj@redhat.com> - 2.5.1-0.20060108
579 - update to CVS snap
580
581 * Wed Dec 21 2005 Paul Nasrat <pnasrat@redhat.com> - 2.5.0-5
582 - Make txmbr hashable (#175975)
583
584 * Fri Dec 16 2005 Paul Nasrat <pnasrat@redhat.com> - 2.5.0-4
585 - Fix for KeyError when no location['base']
586
587 * Wed Dec 14 2005 Jeremy Katz <katzj@redhat.com> - 2.5.0-3
588 - better mirrorlist fix
589
590 * Wed Dec 14 2005 Jeremy Katz <katzj@redhat.com> - 2.5.0-2
591 - revert installyonlyn change that wasn't supposed to get committed
592 - better fix for #175647 that doesn't cause tracebacks when deps 
593   need updating too
594 - fix mirrorlist corruption (#175436)
595
596 * Tue Dec 13 2005 Jeremy Katz <katzj@redhat.com> - 2.5.0-1
597 - update to 2.5.0
598 - add patch for traceback in #175647
599
600 * Sat Dec 10 2005 Jeremy Katz <katzj@redhat.com> - 2.5.0-0.20051210
601 - update to newer CVS
602
603 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
604 - rebuilt
605
606 * Wed Dec  7 2005 Jeremy Katz <katzj@redhat.com> - 2.5.0-0.20051207
607 - update to cvs snap for new group code and lots of other stuff
608
609 * Tue Dec  6 2005 Jeremy Katz <katzj@redhat.com> - 2.4.1-3
610 - ... and actually apply the patch
611
612 * Mon Dec  5 2005 Jeremy Katz <katzj@redhat.com> - 2.4.1-2
613 - add Panu's patch for cachecookie cleaning (#174715)
614 - change default cache time to 30 minutes to match new upstream
615
616 * Wed Nov 30 2005 Jeremy Katz <katzj@redhat.com> - 2.4.1-1
617 - update to 2.4.1
618 - add PLUGINS to the docs
619 - fix another installonlyn bug (#174001)
620
621 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-14
622 - really fix kernel-smp-devel
623
624 * Fri Nov 11 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-13
625 - handle installonlypkgs in provides too to handle, eg, 
626   kernel-smp-devel (#172981)
627
628 * Thu Nov 10 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-12
629 - fix problem with custom kernel names in installonlyn (#172855)
630 - make it more obvious how to add more tokeep with installonlyn
631
632 * Wed Nov 09 2005 Paul Nasrat <pnasrat@redhat.com> - 2.4.0-11
633 - Expose location base from metadata
634
635 * Tue Nov  8 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-10
636 - fix problem in installonlyn that caillon hit where removing kernels 
637   would trigger instead of only happening on update/install of kernels
638 - make plugin config files noreplace
639
640 * Mon Nov  7 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-9
641 - enable plugins by default
642 - add installyonlyn plugin so that we only keep two kernels around by default
643
644 * Mon Oct 24 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-8
645 - drop macro patch
646 - more fixes for returnByName* stuff -- need to leave best arch selection
647   to the caller
648
649 * Sun Oct 23 2005 Paul Nasrat <pnasrat@redhat.com> - 2.4.0-7
650 - Drop anaconda flag patch
651 - Fix ppc64pseries/iseries basearch substitution
652
653 * Thu Oct 06 2005 Paul Nasrat <pnasrat@redhat.com> - 2.4.0-6
654 - Backport transaction constants
655 - Allow setting anaconda flag
656
657 * Tue Oct  4 2005 Jeremy Katz <katzj@redhat.com>
658 - add dirs for plugins
659
660 * Tue Sep 27 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-5
661 - add yum-cli dir (#169334)
662
663 * Wed Sep 21 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-4
664 - make returnByName* be consistent in what it returns (#168712)
665
666 * Fri Sep 16 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-3
667 - add two patches for anaconda that have been committed upstream
668   * allow removal of packages from transaction
669   * support search by name with sqlite
670
671 * Thu Sep 01 2005 Paul Nasrat <pnasrat@redhat.com> - 2.4.0-2
672 - Initial version of macro support patch
673
674 * Tue Aug 16 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-1
675 - update to 2.4.0
676
677 * Fri Jul  8 2005 Jeremy Katz <katzj@redhat.com> - 2.3.4-1
678 - update to 2.3.4
679 - use %%{python_sitelib} in the file list
680
681 * Wed Jun 15 2005 Jeremy Katz <katzj@redhat.com> - 2.3.3-1
682 - update to 2.3.3
683
684 * Wed May 25 2005 Paul Nasrat <pnasrat@redhat.com> - 2.3.2-7
685 - Drop erase reversal patch 
686
687 * Tue May 24 2005 Paul Nasrat <pnasrat@redhat.com> - 2.3.2-6
688 - Erase/remove reversing for yum cli (#158577)
689
690 * Tue May 24 2005 Jeremy Katz <katzj@redhat.com> - 2.3.2-5
691 - allow multiple packages _providing_ kernel-devel (or any installonlypkgs) 
692   to be installed (#155988)
693
694 * Mon May 23 2005 Jeremy Katz <katzj@redhat.com> - 2.3.2-4
695 - fix traceback on out of disk space error
696
697 * Fri May 20 2005 Jeremy Katz <katzj@redhat.com> - 2.3.2-3
698 - add fixes from Seth for the shell to run depsolve and to clean up 
699   output somewhat (#158267)
700
701 * Thu May  5 2005 Jeremy Katz <katzj@redhat.com> - 2.3.2-2
702 - handle ppc64/sparc64 "correctly"
703
704 * Mon Apr  4 2005 Jeremy Katz <katzj@redhat.com> - 2.3.2-1
705 - update to 2.3.2, now requires python-elementtree for xml parsing
706
707 * Tue Mar 15 2005 Jeremy Katz <katzj@redhat.com> - 2.3.1-3
708 - add patch from gijs for sqlite changes
709
710 * Mon Mar 14 2005 Florian La Roche <laroche@redhat.com>
711 - python-sqlite3 -> python-sqlite
712
713 * Mon Mar  7 2005 Jeremy Katz <katzj@redhat.com> - 2.3.1-1
714 - update to 2.3.1
715 - urlgrabber is split out into its own package now
716 - require python-sqlite3
717
718 * Tue Feb 22 2005 Jeremy Katz <katzj@redhat.com> - 2.3.0-2
719 - fix the duplicate repos with the same id bug
720
721 * Mon Feb 21 2005 Jeremy Katz <katzj@redhat.com> - 2.3.0-1
722 - update to 2.3.0
723
724 * Tue Jan 25 2005 Jeremy Katz <katzj@redhat.com> - 2.1.13-1
725 - update to 2.1.13
726
727 * Sat Jan 22 2005 Jeremy Katz <katzj@redhat.com> - 2.1.12-2
728 - allow multiple kernel-devel packages to be installed
729
730 * Wed Jan 12 2005 Florian La Roche <laroche@redhat.com>
731 - add small patch to fix dep reporting
732
733 * Mon Nov 29 2004 Jeremy Katz <katzj@redhat.com> - 2.1.12-1
734 - update to 2.1.12
735 - add hack from jbj to workaround python 2.4 urllib breakage (#138535)
736
737 * Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 2.1.11-4
738 - rebuild for python 2.4
739
740 * Sun Oct 31 2004 Bill Nottingham <notting@redhat.com> - 2.1.11-3
741 - fix multilib update patch to allow installing noarch (#135396, continued)
742
743 * Fri Oct 29 2004 Jeremy Katz <katzj@redhat.com> - 2.1.11-2
744 - add patch to fix multilib updates on ia32e (#135396)
745
746 * Thu Oct 28 2004 Jeremy Katz <katzj@redhat.com> - 2.1.11-1
747 - update to 2.1.11
748   - fix config file error handling
749   - better handling of empty lines/comments in mirror lists
750   - improve some error messages
751
752 * Sun Oct 24 2004 Jeremy Katz <katzj@redhat.com> - 2.1.10-3.1
753 - make the cron job executable (#136764)
754
755 * Thu Oct 21 2004 Jeremy Katz <katzj@redhat.com> - 2.1.10-3
756 - actually remove the repositories
757
758 * Wed Oct 20 2004 Jeremy Katz <katzj@redhat.com> - 2.1.10-2
759 - remove repositories from being explicitly listed in yum.conf, 
760   .repo files will be included in the fedora-release package
761
762 * Tue Oct 19 2004 Jeremy Katz <katzj@redhat.com> - 2.1.10-1
763 - update to 2.1.10
764   * updated man pages
765   * make more resilient to broken groups file
766   * fix urlgrabber failure callback (#136178)
767
768 * Mon Oct 18 2004 Jeremy Katz <katzj@redhat.com> - 2.1.9-1
769 - 2.1.9 includes the path fix
770
771 * Mon Oct 18 2004 Jeremy Katz <katzj@redhat.com> - 2.1.8-2
772 - fix path in /usr/bin/yum
773 - turn on gpgchecking by default
774
775 * Mon Oct 18 2004 Bill Nottingham <notting@redhat.com> - 2.1.8-1
776 - 2.1.8, fixes #135735, #135998, #135775
777
778 * Wed Oct 13 2004 Jeremy Katz <katzj@redhat.com> - 2.1.7-2
779 - add yum-arch
780
781 * Wed Oct 13 2004 Jeremy Katz <katzj@redhat.com> - 2.1.7-1
782 - 2.1.7
783 - use mirror list by default
784
785 * Wed Oct  6 2004 Bill Nottingham <notting@redhat.com> - 2.1.6-1
786 - 2.1.6
787
788 * Mon Oct  4 2004 Jeremy Katz <katzj@redhat.com> - 2.1.5-1
789 - 2.1.5
790 - turn on obsoletes=1 by default in yum.conf
791
792 * Wed Sep 29 2004 Bill Nottingham <notting@redhat.com> - 2.1.4-1
793 - 2.1.4
794
795 * Fri Sep  3 2004 Bill Nottingham <notting@redhat.com> - 2.1.3-1
796 - 2.1.3
797
798 * Thu Sep  2 2004 Jeremy Katz <katzj@redhat.com> - 2.1.2-1
799 - 2.1.2
800
801 * Wed Sep  1 2004 Jeremy Katz <katzj@redhat.com> - 2.1.1-1
802 - 2.1.1
803
804 * Tue Aug 31 2004 Jeremy Katz <katzj@redhat.com> - 2.1.0-1
805 - update to 2.1.0
806
807 * Wed Jul 7 2004  Elliot Lee <sopwith@redhat.com> 2.0.7-3
808 - Back to rawhide
809
810 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
811 - rebuilt
812
813 * Tue May 11 2004 Elliot Lee <sopwith@redhat.com> 2.0.7-1.1
814 - Update config again
815
816 * Fri May  7 2004 Jeremy Katz <katzj@redhat.com> 2.0.7-1
817 - update to 2.0.7
818 - change config to point to final FC2 locations
819
820 * Fri Apr 16 2004 Jeremy Katz <katzj@redhat.com> - 2.0.7-0.20040416
821 - new snap 
822
823 * Sat Apr  3 2004 Jeremy Katz <katzj@redhat.com> 2.0.7-0.20040403
824 - new snap, should fix yum -e name.arch
825
826 * Wed Mar 17 2004 Jeremy Katz <katzj@redhat.com> 2.0.6-1
827 - update to 2.0.6
828
829 * Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> 2.0.5.20040310-1
830 - update to today's snap
831
832 * Wed Mar  3 2004 Jeremy Katz <katzj@redhat.com> 2.0.5.20040303-1
833 - today's snap
834
835 * Tue Mar  2 2004 Jeremy Katz <katzj@redhat.com> - 2.0.5.20040229-1
836 - update again per seth's request
837
838 * Thu Feb 26 2004 Florian La Roche <Florian.LaRoche@redhat.de>
839 - mv /etc/init.d -> /etc/rc.d/init.d
840
841 * Tue Feb 24 2004 Jeremy Katz <katzj@redhat.com> - 2.0.5.20040224-1
842 - newer
843
844 * Mon Feb 23 2004 Jeremy Katz <katzj@redhat.com> - 2.0.5.20040223-1
845 - update to current snapshot per skvidal's request
846 - add retries=20 to yum.conf
847
848 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
849 - rebuilt
850
851 * Fri Jan 23 2004 Bill Nottingham <notting@redhat.com> 2.0.4.20040103-1
852 - update to current snapshot
853 - fix config for FC2 test 1
854
855 * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 2.0.4-5
856 - build yum daily snapshot for amd64 fix.
857
858 * Wed Nov 12 2003 Bill Nottingham <notting@redhat.com> 2.0.4-4
859 - patch for excluding dirs in yum-arch from CVS
860
861 * Thu Nov  6 2003 Jeremy Katz <katzj@redhat.com> 2.0.4-3
862 - patch to work with python 2.3 from Seth
863
864 * Wed Oct 29 2003 Elliot Lee <sopwith@redhat.com> 2.0.4-2
865 - Stick in a new yum.conf for FC1.
866
867 * Mon Oct 20 2003 Florian La Roche <Florian.LaRoche@redhat.de>
868 - new upstream release 2.0.4
869
870 * Tue Sep 16 2003 Jeff Johnson <jbj@redhat.com> 2.0.3-1
871 - update to 2.0.3
872 - drop yum-init patch, merged into 2.0.3.
873 - change rpm version requirement to 4.1.1.
874
875 * Thu Jul 24 2003 Florian La Roche <Florian.LaRoche@redhat.de>
876 - change init script to more current RHL style
877
878 * Wed Jul 23 2003 Nalin Dahyabhai <nalin@redhat.com>
879 - require libxml2-python, because yum does
880
881 * Thu Jul 17 2003 Jeff Johnson <jbj@redhat.com> 2.0-1
882 - update to 2.0.
883
884 * Thu May 22 2003 Jeff Johnson <jbj@redhat.com> 1.98-0.20030522
885 - update to snapshot.
886
887 * Mon May 12 2003 Jeff Johnson <jbj@redhat.com> 1.98-0.20030512
888 - create.