e516b27d7a7205197e928011527bd3983c36ca09
[linux-2.6.git] / scripts / kernel-2.6-planetlab.spec
1 Summary: The Linux kernel (the core of the Linux operating system)
2
3 # What parts do we want to build?  We must build at least one kernel.
4 # These are the kernels that are built IF the architecture allows it.
5
6 %define buildup 1
7 %define buildsmp 0
8 %define builduml 0
9 %define buildsource 0
10 %define builddoc 0
11
12
13 # Versions of various parts
14
15 #
16 # Polite request for people who spin their own kernel rpms:
17 # please modify the "release" field in a way that identifies
18 # that the kernel isn't the stock distribution kernel, for example by
19 # adding some text to the end of the version number.
20 #
21 %define sublevel 10
22 %define kversion 2.6.%{sublevel}
23 %define rpmversion 2.6.%{sublevel}
24 %define rhbsys  %([ -r /etc/beehive-root ] && echo  || echo .`whoami`)
25 %define release 1.14_FC2.2.planetlab%{?date:.%{date}}
26 %define signmodules 0
27
28 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
29
30 # Override generic defaults with per-arch defaults 
31
32 %define image_install_path boot
33
34 #
35 # Three sets of minimum package version requirements in the form of Conflicts:
36 # to versions below the minimum
37 #
38
39 #
40 # First the general kernel 2.6 required versions as per
41 # Documentation/Changes
42 #
43 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
44
45
46 # Then a series of requirements that are distribution specific, either 
47 # because we add patches for something, or the older versions have 
48 # problems with the newer kernel or lack certain things that make 
49 # integration in the distro harder than needed.
50 #
51 %define package_conflicts  cipe < 1.4.5, tux < 2.1.0, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0
52
53 #
54 # Several packages had bugs in them that became obvious when the NPTL
55 # threading code got integrated. 
56 #
57 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
58
59 #
60 # Packages that need to be installed before the kernel is, because the %post
61 # scripts use them.
62 #
63 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
64
65 Vendor: PlanetLab
66 Packager: PlanetLab Central <support@planet-lab.org>
67 Distribution: PlanetLab 3.0
68 URL: http://cvs.planet-lab.org/cvs/linux-2.6
69
70 Name: kernel
71 Group: System Environment/Kernel
72 License: GPLv2
73 Version: %{rpmversion}
74 Release: %{release}
75 ExclusiveOS: Linux
76 Provides: kernel = %{version}
77 Provides: kernel-drm = 4.3.0
78 Prereq: %{kernel_prereq}
79 Conflicts: %{kernel_dot_org_conflicts}
80 Conflicts: %{package_conflicts}
81 Conflicts: %{nptl_conflicts}
82 # We can't let RPM do the dependencies automatic because it'll then pick up
83 # a correct but undesirable perl dependency from the module headers which
84 # isn't required for the kernel proper to function
85 AutoReqProv: no
86
87 #
88 # List the packages used during the kernel build
89 #
90 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
91 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg
92 #BuildPreReq: kernel-utils >= 1:2.4-12.1.142
93 BuildRequires: gcc >= 2.96-98, binutils >= 2.12, redhat-rpm-config
94 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
95 BuildArchitectures: i686
96
97
98
99 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
100
101 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
102
103 %description 
104 The kernel package contains the Linux kernel (vmlinuz), the core of any
105 Linux operating system.  The kernel handles the basic functions
106 of the operating system:  memory allocation, process allocation, device
107 input and output, etc.
108
109
110 %package sourcecode
111 Summary: The source code for the Linux kernel.
112 Group: Development/System
113 Prereq: fileutils
114 Requires: make >= 3.78
115 Requires: gcc >= 3.2
116 Requires: /usr/bin/strip
117 # for xconfig and gconfig
118 Requires: qt-devel, gtk2-devel readline-devel ncurses-devel
119 Provides: kernel-source
120 Obsoletes: kernel-source <= 2.6.6
121
122 %description sourcecode
123 The kernel-sourcecode package contains the source code files for the Linux
124 kernel. The source files can be used to build a custom kernel that is
125 smaller by virtue of only including drivers for your particular hardware, if
126 you are so inclined (and you know what you're doing). The customisation
127 guide in the documentation describes in detail how to do this. This package
128 is neither needed nor usable for building external kernel modules for
129 linking such modules into the default operating system kernels.
130
131 %package doc
132 Summary: Various documentation bits found in the kernel source.
133 Group: Documentation
134 %if !%{buildsource}
135 Obsoletes: kernel-source <= 2.6.6
136 Obsoletes: kernel-sourcecode <= 2.6.6
137 %endif
138
139 %description doc
140 This package contains documentation files from the kernel
141 source. Various bits of information about the Linux kernel and the
142 device drivers shipped with it are documented in these files. 
143
144 You'll want to install this package if you need a reference to the
145 options that can be passed to Linux kernel modules at load time.
146
147
148 %package smp
149 Summary: The Linux kernel compiled for SMP machines.
150
151 Group: System Environment/Kernel
152 Provides: kernel = %{version}
153 Provides: kernel-drm = 4.3.0
154 Prereq: %{kernel_prereq}
155 Conflicts: %{kernel_dot_org_conflicts}
156 Conflicts: %{package_conflicts}
157 Conflicts: %{nptl_conflicts}
158 # upto and including kernel 2.4.9 rpms, the 4Gb+ kernel was called kernel-enterprise
159 # now that the smp kernel offers this capability, obsolete the old kernel
160 Obsoletes: kernel-enterprise < 2.4.10
161 # We can't let RPM do the dependencies automatic because it'll then pick up
162 # a correct but undesirable perl dependency from the module headers which
163 # isn't required for the kernel proper to function
164 AutoReqProv: no
165
166 %description smp
167 This package includes a SMP version of the Linux kernel. It is
168 required only on machines with two or more CPUs as well as machines with
169 hyperthreading technology.
170
171 Install the kernel-smp package if your machine uses two or more CPUs.
172
173 %package uml
174 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
175
176 Group: System Environment/Kernel
177
178 %description uml
179 This package includes a user mode version of the Linux kernel.
180
181 %package vserver
182 Summary: A placeholder RPM that provides kernel and kernel-drm
183
184 Group: System Environment/Kernel
185 Provides: kernel = %{version}
186 Provides: kernel-drm = 4.3.0
187
188 %description vserver
189 VServers do not require and cannot use kernels, but some RPMs have
190 implicit or explicit dependencies on the "kernel" package
191 (e.g. tcpdump). This package installs no files but provides the
192 necessary dependencies to make rpm and yum happy.
193
194 %prep
195
196 %setup -n linux-%{kversion}
197
198 # make sure the kernel has the sublevel we know it has. This looks weird
199 # but for -pre and -rc versions we need it since we only want to use
200 # the higher version when the final kernel is released.
201 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
202 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
203
204 # get rid of unwanted files resulting from patch fuzz
205 find . -name "*.orig" -exec rm -fv {} \;
206 find . -name "*~" -exec rm -fv {} \;
207
208 ###
209 ### build
210 ###
211 %build
212
213 BuildKernel() {
214
215     # Pick the right config file for the kernel we're building
216     if [ -n "$1" ] ; then
217         Config=kernel-%{kversion}-%{_target_cpu}-$1-planetlab.config
218     else
219         Config=kernel-%{kversion}-%{_target_cpu}-planetlab.config
220     fi
221
222     KernelVer=%{version}-%{release}$1
223     echo BUILDING A KERNEL FOR $1 %{_target_cpu}...
224
225     # make sure EXTRAVERSION says what we want it to say
226     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}$1/" Makefile
227
228     # override ARCH in the case of UML
229     if [ "$1" = "uml" ] ; then
230         export ARCH=um
231     fi
232
233     # and now to start the build process
234
235     make -s mrproper
236     cp configs/$Config .config
237
238     make -s nonint_oldconfig > /dev/null
239     make -s include/linux/version.h 
240
241     make -s %{?_smp_mflags} bzImage 
242     make -s %{?_smp_mflags} modules || exit 1
243     make buildcheck
244     
245     # Start installing the results
246
247     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
248     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
249     install -m 644 System.map $RPM_BUILD_ROOT/usr/lib/debug/boot/System.map-$KernelVer
250     objdump -t vmlinux | grep ksymtab | cut -f2 | cut -d" " -f2 | cut -c11- | sort -u  > exported
251     echo "_stext" >> exported
252     echo "_end" >> exported
253     touch $RPM_BUILD_ROOT/boot/System.map-$KernelVer
254     for i in `cat exported` 
255     do 
256          grep " $i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer || :
257          grep "tab_$i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer || :
258          grep "__crc_$i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer ||:
259     done
260     rm -f exported
261 #    install -m 644 init/kerntypes.o $RPM_BUILD_ROOT/boot/Kerntypes-$KernelVer
262     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
263     rm -f System.map
264     cp arch/*/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
265
266     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
267     make -s INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
268  
269     # And save the headers/makefiles etc for building modules against
270     #
271     # This all looks scary, but the end result is supposed to be:
272     # * all arch relevant include/ files
273     # * all Makefile/Kconfig files
274     # * all script/ files 
275
276     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
277     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
278     # first copy everything
279     cp --parents `find  -type f -name Makefile -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
280     cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
281     # then drop all but the needed Makefiles/Kconfig files
282     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
283     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
284     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
285     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
286     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
287     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
288     cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
289     cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
290     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
291     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
292     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
293     cd include
294     cp -a acpi config linux math-emu media net pcmcia rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
295     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
296     # Make sure the Makefile and version.h have a matching timestamp so that
297     # external modules can be built
298     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
299     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
300     cd .. 
301
302     #
303     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
304     #
305     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
306     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
307
308     # mark modules executable so that strip-to-file can strip them
309     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f  | xargs chmod u+x
310
311     # detect missing or incorrect license tags
312     for i in `find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" ` ; do echo -n "$i " ; /sbin/modinfo -l $i >> modinfo ; done
313     cat modinfo | grep -v "^GPL" | grep -v "^Dual BSD/GPL" | grep -v "^Dual MPL/GPL" | grep -v "^GPL and additional rights" | grep -v "^GPL v2" && exit 1 
314     rm -f modinfo
315     # remove files that will be auto generated by depmod at rpm -i time
316     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
317
318 }
319
320 ###
321 # DO it...
322 ###
323
324 # prepare directories
325 rm -rf $RPM_BUILD_ROOT
326 mkdir -p $RPM_BUILD_ROOT/boot
327
328 %if %{buildup}
329 BuildKernel
330 %endif
331
332 %if %{buildsmp}
333 BuildKernel smp
334 %endif
335
336 %if %{builduml}
337 BuildKernel uml
338 %endif
339
340 ###
341 ### install
342 ###
343
344 %install
345
346 # architectures that don't get kernel-source (i586/i686/athlon) dont need
347 # much of an install because the build phase already copied the needed files
348
349 %if %{builddoc}
350 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
351
352 # sometimes non-world-readable files sneak into the kernel source tree
353 chmod -R a+r *
354 # copy the source over
355 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
356 %endif
357
358 %if %{buildsource}
359
360 mkdir -p $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
361 chmod -R a+r *
362
363 # clean up the source tree so that it is ready for users to build their own
364 # kernel
365 make -s mrproper
366 # copy the source over
367 tar cf - . | tar xf - -C $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
368
369 # set the EXTRAVERSION to <version>custom, so that people who follow a kernel building howto
370 # don't accidentally overwrite their currently working moduleset and hose
371 # their system
372 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}custom/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/Makefile
373
374 # some config options may be appropriate for an rpm kernel build but are less so for custom user builds,
375 # change those to values that are more appropriate as defeault for people who build their own kernel.
376 perl -p -i -e "s/^CONFIG_DEBUG_INFO.*/# CONFIG_DEBUG_INFO is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
377 perl -p -i -e "s/^.*CONFIG_DEBUG_PAGEALLOC.*/# CONFIG_DEBUG_PAGEALLOC is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
378 perl -p -i -e "s/^.*CONFIG_DEBUG_SLAB.*/# CONFIG_DEBUG_SLAB is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
379 perl -p -i -e "s/^.*CONFIG_DEBUG_SPINLOCK.*/# CONFIG_DEBUG_SPINLOCK is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
380 perl -p -i -e "s/^.*CONFIG_DEBUG_HIGHMEM.*/# CONFIG_DEBUG_HIGHMEM is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
381 perl -p -i -e "s/^.*CONFIG_MODULE_SIG.*/# CONFIG_MODULE_SIG is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
382
383 install -m 644 %{SOURCE10}  $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
384 %endif
385
386 ###
387 ### clean
388 ###
389
390 %clean
391 rm -rf $RPM_BUILD_ROOT
392
393 ###
394 ### scripts
395 ###
396
397 # load the loop module for upgrades...in case the old modules get removed we have
398 # loopback in the kernel so that mkinitrd will work.
399 %pre 
400 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
401 exit 0
402
403 %pre smp
404 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
405 exit 0
406
407 %post 
408 # trick mkinitrd in case the current environment does not have device mapper
409 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
410 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
411     if [ ! -f $rootdev ]; then
412         fake_root_lvm=1
413         mkdir -p $(dirname $rootdev)
414         touch $rootdev
415     fi
416 fi
417 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
418 if [ -n "$fake_root_lvm" ]; then
419     rm -f $rootdev
420 fi
421 if [ -x /usr/sbin/hardlink ] ; then
422 pushd /lib/modules/%{KVERREL}/build > /dev/null ; {
423         cd /lib/modules/%{KVERREL}/build
424         find . -type f | while read f; do hardlink -c /lib/modules/*/build/$f $f ; done
425 }
426 popd
427 fi
428
429 # make some useful links
430 pushd /boot > /dev/null ; {
431         ln -sf System.map-%{KVERREL} System.map
432 #       ln -sf Kerntypes-%{KVERREL} Kerntypes
433         ln -sf config-%{KVERREL} config
434         ln -sf initrd-%{KVERREL}.img initrd-boot
435         ln -sf vmlinuz-%{KVERREL} kernel-boot
436 }
437 popd
438
439 # ask for a reboot
440 mkdir -p /etc/planetlab
441 touch /etc/planetlab/update-reboot
442
443 %post smp
444 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}smp
445 if [ -x /usr/sbin/hardlink ] ; then
446 pushd /lib/modules/%{KVERREL}smp/build > /dev/null ; {
447         cd /lib/modules/%{KVERREL}smp/build
448         find . -type f | while read f; do hardlink -c /lib/modules/*/build/$f $f ; done
449 }
450 popd
451 fi
452
453
454 %preun 
455 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
456 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
457
458 %preun smp
459 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
460 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}smp
461
462
463 ###
464 ### file lists
465 ###
466
467 %if %{buildup}
468 %files 
469 %defattr(-,root,root)
470 /%{image_install_path}/vmlinuz-%{KVERREL}
471 #/boot/Kerntypes-%{KVERREL}
472 /boot/System.map-%{KVERREL}
473 /boot/config-%{KVERREL}
474 %dir /lib/modules/%{KVERREL}
475 /lib/modules/%{KVERREL}/kernel
476 %verify(not mtime) /lib/modules/%{KVERREL}/build
477
478 %endif
479
480 %if %{buildsmp}
481 %files smp
482 %defattr(-,root,root)
483 /%{image_install_path}/vmlinuz-%{KVERREL}smp
484 #/boot/Kerntypes-%{KVERREL}smp
485 /boot/System.map-%{KVERREL}smp
486 /boot/config-%{KVERREL}smp
487 %dir /lib/modules/%{KVERREL}smp
488 /lib/modules/%{KVERREL}smp/kernel
489 %verify(not mtime) /lib/modules/%{KVERREL}smp/build
490
491 %endif
492
493 %if %{builduml}
494 %files uml
495 %defattr(-,root,root)
496
497 %endif
498
499 # only some architecture builds need kernel-source and kernel-doc
500
501 %if %{buildsource}
502 %files sourcecode
503 %defattr(-,root,root)
504 /usr/src/linux-%{KVERREL}/
505 %endif
506
507
508 %if %{builddoc}
509 %files doc
510 %defattr(-,root,root)
511 /usr/share/doc/kernel-doc-%{kversion}/Documentation/*
512 %endif
513
514
515 %files vserver
516 %defattr(-,root,root)
517 # no files
518
519 %changelog
520 * Thu Feb 17 2005 Marc E. Fiuczynski <mef@cs.princeton.edu>
521 - merge to Fedora Core 2 2.6.10-1.14_FC2
522
523 * Tue Feb 8 2005 Marc E. Fiuczynski <mef@cs.princeton.edu>
524 - merge to Fedora Core 2 2.6.10-1.12_FC2
525
526 * Tue Jan 18 2005 Marc E. Fiuczynski <mef@cs.princeton.edu>
527 - merge to Fedora Core 2 2.6.9-1.11_FC2
528
529 * Thu Sep 16 2004 Mark Huang <mlhuang@cs.princeton.edu>
530 - merge to Fedora Core 2 2.6.8-1.521
531
532 * Tue Aug 31 2004 Arjan van de Ven <arjanv@redhat.com>
533 - fix execshield buglet with legacy binaries
534 - 2.6.9-rc1-bk7
535
536 * Mon Aug 30 2004 Arjan van de Ven <arjanv@redhat.com>
537 - 2.6.9-rc1-bk6
538
539 * Sat Aug 28 2004 Arjan van de Ven <arjanv@redhat.com>
540 - 2.6.9-rc1-bk4, now with i915 DRM driver
541
542 * Fri Aug 27 2004 Arjan van de Ven <arjanv@redhat.com>
543 - 2.6.9-rc1-bk2 
544
545 * Mon Aug 23 2004 Arjan van de Ven <arjanv@redhat.com>
546 - 2.6.8.1-bk2
547
548 * Sat Aug 21 2004 Arjan van de Ven <arjanv@redhat.com>
549 - attempt to fix early-udev bug
550
551 * Fri Aug 13 2004 Arjan van de Ven <arjanv@redhat.com>
552 - 2.6.8-rc4-bk3
553 - split execshield up some more
554
555 * Fri Aug 13 2004 Dave Jones <davej@redhat.com>
556 - Update SCSI whitelist again with some more card readers.
557
558 * Mon Aug 9 2004 Arjan van de Ven <arjanv@redhat.com>
559 - 2.6.8-rc3-bk3
560
561 * Thu Aug  5 2004 Mark Huang <mlhuang@cs.princeton.edu>
562 - adapt for Fedora Core 2 based PlanetLab 3.0 (remove Source and Patch
563   sections, most non-x86 sections, and GPG sections)
564
565 * Wed Aug 4 2004 Arjan van de Ven <arjanv@redhat.com>
566 - Add the flex-mmap bits for s390/s390x (Pete Zaitcev)
567 - Add flex-mmap for x86-64 32 bit emulation
568 - 2.6.8-rc3
569
570 * Mon Aug 2 2004 Arjan van de Ven <arjanv@redhat.com>
571 - Add Rik's token trashing control patch
572
573 * Sun Aug 1 2004 Arjan van de Ven <arjanv@redhat.com>
574 - 2.6.8-rc2-bk11
575
576 * Fri Jul 30 2004 Arjan van de Ven <arjanv@redhat.com>
577 - 2.6.8-rc2-bk8
578
579 * Wed Jul 28 2004 Arjan van de Ven <arjanv@redhat.com>
580 - 2.6.8-rc2-bk6
581 - make a start at splitting up the execshield patchkit
582
583 * Fri Jul 16 2004 Arjan van de Ven <arjanv@redhat.com>
584 - ppc32 embedded updates
585
586 * Thu Jul 15 2004 Arjan van de Ven <arjanv@redhat.com>
587 - make USB modules again and add Alan's real fix for the SMM-meets-USB bug
588 - 2.6.8-rc1-bk4
589
590 * Wed Jul 14 2004 Arjan van de Ven <arjanv@redhat.com>
591 - 2.6.8-rc1-bk3
592
593 * Tue Jul 13 2004 Arjan van de Ven <arjanv@redhat.com>
594 - add "enforcemodulesig" boot option to make the kernel load signed modules only
595
596 * Mon Jul 12 2004 Arjan van de Ven <arjanv@redhat.com>
597 - updated voluntary preempt
598 - 2.6.8-rc1
599
600 * Wed Jul 7 2004 Arjan van de Ven <arjanv@redhat.com>
601 - fix boot breakage that was hitting lots of people (Dave Jones)
602
603 * Tue Jul 6 2004 Arjan van de Ven <arjanv@redhat.com>
604 - add voluntary preemption patch from Ingo
605 - 2.6.7-bk19
606
607 * Tue Jun 29 2004 Arjan van de Ven <arjanv@redhat.com>
608 - make a start at gpg signed modules support
609
610 * Sat Jun 27 2004 Arjan van de Ven <arjanv@redhat.com>
611 - experiment with making the hardlink call in post more efficient
612 - 2.6.7-bk9
613
614 * Thu Jun 24 2004 Arjan van de Ven <arjanv@redhat.com>
615 - 2.6.7-bk7
616 - Add wli's patch to allocate memory bottom up not top down
617 - change some config options in the kernel-sourcecode package that are
618   good for rpm kernel builds but not for custom user builds to more appropriate 
619   default values.
620 - reenable kernel-sourcecode again for a few builds 
621
622 * Wed Jun 23 2004 Arjan van de Ven <arjanv@redhat.com>
623 - 2.6.7-bk5
624 - fix tux unresolved symbols (#126532)
625
626 * Mon Jun 21 2004 Arjan van de Ven <arjanv@redhat.com>
627 - make kernel-doc and kernel-sourcecode builds independent of eachother
628 - disable kernel-sourcecode builds entirely, we'll be replacing it with documentation
629   on how to use the src.rpm instead for building your own kernel.
630
631 * Sat Jun 19 2004 Arjan van de Ven <arjanv@redhat.com>
632 - 2.6.7-bk2
633
634 * Sun Jun 13 2004 Arjan van de Ven <arjanv@redhat.com>
635 - add patch from DaveM to fix the ppp-keeps-iface-busy bug
636
637 * Sat Jun 12 2004 Arjan van de Ven <arjanv@redhat.com>
638 - add fix from Andi Kleen/Linus for the fpu-DoS
639
640 * Thu Jun 10 2004 Arjan van de Ven <arjanv@redhat.com>
641 - disable mlock-uses-rlimit patch, it has a security hole and needs more thought
642 - revert airo driver to the FC2 one since the new one breaks
643
644 * Tue Jun 8 2004 Dave Jones <davej@redhat.com>
645 - Update to 2.6.7rc3
646
647 * Fri Jun 4 2004 Arjan van de Ven <arjanv@redhat.com>
648 - fix the mlock-uses-rlimit patch
649
650 * Wed Jun 2 2004 David Woodhouse <dwmw2@redhat.com>
651 - Add ppc64 (Mac G5)
652
653 * Wed Jun 2 2004 Arjan van de Ven <arjanv@redhat.com>
654 - add a forward port of the mlock-uses-rlimit patch
655 - add NX support for x86 (Intel, Ingo)
656
657 * Tue Jun 1 2004 Arjan van de Ven <arjanv@redhat.com>
658 - refresh ext3 reservation patch
659
660 * Sun May 30 2004 Arjan van de Ven <arjanv@redhat.com>
661 - 2.6.7-rc2
662 - set the ACPI OS name to "Microsoft Windows XP" for better compatibility
663
664 * Thu May 27 2004 Pete Zaitcev <zaitcev@redhat.com>
665 - Fix qeth and zfcp (s390 drivers): align qib by 256, embedded into qdio_irq.
666
667 * Thu May 27 2004 Dave Jones <davej@redhat.com>
668 - Fix the crashes on boot on Asus P4P800 boards. (#121819)
669
670 * Wed May 26 2004 Dave Jones <davej@redhat.com>
671 - Lots more updates to the SCSI whitelist for various
672   USB card readers. (#112778, among others..)
673
674 * Wed May 26 2004 Arjan van de Ven <arjanv@redhat.com>
675 - back out ehci suspend/resume patch, it breaks
676 - add fix for 3c59x-meets-kudzu bug from Alan
677
678 * Tue May 25 2004 Arjan van de Ven <arjanv@redhat.com>
679 - try improving suspend/resume by restoring more PCI state
680 - 2.6.7-rc1-bk1
681
682 * Mon May 24 2004 Dave Jones <davej@redhat.com>
683 - Add yet another multi-card reader to the whitelist (#85851)
684
685 * Sun May 23 2004 Dave Jones <davej@redhat.com>
686 - Add another multi-card reader to the whitelist (#124048)
687
688 * Wed May 19 2004 Arjan van de Ven <arjanv@redhat.com>
689 - put firewire race fix in (datacorruptor)
690
691 * Tue May 18 2004 Dave Jones <davej@redhat.com>
692 - Fix typo in ibmtr driver preventing compile (#123391)
693
694 * Mon May 17 2004 Arjan van de Ven <arjanv@redhat.com>
695 - update to 2.6.6-bk3
696 - made kernel-source and kernel-doc noarch.rpm's since they are not
697   architecture specific.
698
699 * Sat May 08 2004 Arjan van de Ven <arjanv@redhat.com>
700 - fix non-booting on Transmeta cpus (Peter Anvin)
701 - fix count leak in message queues
702
703 * Fri May 07 2004 Arjan van de Ven <arjanv@redhat.com>
704 - more ide cache flush work
705 - patch from scsi-bk to fix sd refcounting
706
707 * Thu May 06 2004 Arjan van de Ven <arjanv@redhat.com>
708 - some more ide cache flush fixes 
709
710 * Wed May 05 2004 Arjan van de Ven <arjanv@redhat.com>
711 - fix bug 122504
712 - convert b44 to ethtool ops (jgarzik)
713 - make IDE do a cache-flush on shutdown (me/Alan)
714
715 * Tue May 04 2004 Arjan van de Ven <arjanv@redhat.com>
716 - work around i810/i830 DRM issue
717
718 * Fri Apr 30 2004 Arjan van de Ven <arjanv@redhat.com>
719 - 2.6.6-rc3-bk1
720 - make amd64 boot again
721 - fix vm86-vs-4g4g interaction (Ingo)
722
723 * Thu Apr 22 2004 Arjan van de Ven <arjanv@redhat.com>
724 - 2.6.6-rc2
725  
726 * Tue Apr 20 2004 Arjan van de Ven <arjanv@redhat.com>
727 - add the ext3 online resize patch
728
729 * Mon Apr 19 2004 Arjan van de Ven <arjanv@redhat.com>
730 - 2.6.6-rc1-bk3
731 - add the objrmap vm from the -mm tree; it needs testing
732
733 * Thu Apr 15 2004 Arjan van de Ven <arjanv@redhat.com>
734 - 2.6.5-bk2
735 - disable DISCONTIGMEM on ia64 for performance
736 - fix sleep_on use in reiserfs (Chris Mason)
737
738 * Tue Apr 13 2004 Arjan van de Ven <arjanv@redhat.com>
739 - 2.6.5-mc4
740 - reenable sg driver for scsi tape changers and such
741 - the sk98lin driver oopses on module unload, preven that
742
743 * Mon Apr 12 2004 Arjan van de Ven <arjanv@redhat.com>
744 - fix "bad pmd" bug with patch from Ingo
745
746 * Fri Apr 09 2004 Arjan van de Ven <arjanv@redhat.com>
747 - 2.6.5-mc3
748 - finish up the -mc2 merge
749 - latest 4g/4g patch from Ingo
750 - latest execshield patch from Ingo
751 - fix a few framebuffer bugs
752
753 * Thu Apr 08 2004 Arjan van de Ven <arjanv@redhat.com>
754 - first attempt at a 2.6.5-mc2 merge
755
756 * Thu Apr 08 2004 Dave Jones <davej@redhat.com>
757 - Add in missing SiS AGP fix.
758
759 * Tue Apr 06 2004 Dave Jones <davej@redhat.com>
760 - More agpgart fixes.
761
762 * Fri Apr 02 2004 Arjan van de Ven <arjanv@redhat.com>
763 - fix another 4g/4g-vs-resume bug
764
765 * Tue Mar 30 2004 Arjan van de Ven <arjanv@redhat.com>
766 - 2.6.5-rc3
767 - fix PCI posting bug in i830 DRM
768
769 * Mon Mar 29 2004 Arjan van de Ven <arjanv@redhat.com>
770 - 2.6.5-rc2-bk8
771
772 * Mon Mar 29 2004 Dave Jones <davej@redhat.com>
773 - Include latest agpgart fixes.
774
775 * Thu Mar 25 2004 Arjan van de Ven <arjanv@redhat.com>
776 - more DRM fixes
777 - add the fsync patches from akpm
778
779 * Tue Mar 23 2004 Arjan van de Ven <arjanv@redhat.com>
780 - 2.6.5-rc2-bk3
781 - fix direct userspace memory access in i830 drm driver
782
783 * Mon Mar 22 2004 Arjan van de Ven <arjanv@redhat.com>
784 - 2.6.5-rc2-bk2
785 - some stackbloat reductions from Dave and me
786
787 * Sat Mar 20 2004 Arjan van de Ven <arjanv@redhat.com>
788 - 2.6.5-rc2
789
790 * Tue Mar 16 2004 Dave Jones <davej@redhat.com>
791 - 2.6.5-rc1
792
793 * Mon Mar 15 2004 Arjan van de Ven <arjanv@redhat.com>
794 - 2.6.4-bk3
795 - fix oops in toshiba_acpi (Barry K. Nathan)
796
797 * Sat Mar 13 2004 Arjan van de Ven <arjanv@redhat.com>
798 - 2.6.4-bk2 merge 
799
800 * Thu Mar 11 2004 Arjan van de Ven <arjanv@redhat.com>
801 - renable sonypi driver that was off accidentally
802 - 2.6.4-final 
803 - fix the oops on alsa module unloads
804
805 * Wed Mar 10 2004 Arjan van de Ven <arjanv@redhat.com>
806 - add ppc64/iseries, ppc32 (powermac/ibook) and ia64 architectures
807 - 2.6.4-rc3 
808
809 * Tue Mar 09 2004 Arjan van de Ven <arjanv@redhat.com>
810 - 2.6.4-rc2-bk5
811 - fix nfs-vs-selinux issue
812 - fix typo in URL as per #117849
813
814 * Mon Mar 08 2004 Arjan van de Ven <arjanv@redhat.com>
815 - fix race in lp.c (#117710)
816 - 2.6.4-rc2-bk3
817 - attempt to fix S3 suspend-to-ram with 4g/4g split
818
819 * Sat Mar 06 2004 Arjan van de Ven <arjanv@redhat.com>
820 - fix reiserfs
821 - set HZ to 1000 again for some tests
822
823 * Wed Feb 25 2004 Arjan van de Ven <arjanv@redhat.com>
824 - merge back a bunch of fedora fixes
825 - disable audit
826
827 * Tue Feb 24 2004 Arjan van de Ven <arjanv@redhat.com>
828 - audit bugfixes
829 - update tux to a working version
830 - 2.6.3-bk5 merge
831
832 * Fri Feb 20 2004 Arjan van de Ven <arjanv@redhat.com>
833 - re-add and enable the Auditing patch
834 - switch several cpufreq modules to built in since detecting in userspace
835   which to use is unpleasant
836 * Thu Jul 03 2003 Arjan van de Ven <arjanv@redhat.com>
837 - 2.6 start 
838