ea7408fe46b13fcc3a4dc442b14e5affa2c10991
[linux-2.6.git] / scripts / kernel-2.6-planetlab.spec
1 Summary: The Linux kernel (the core of the Linux operating system)
2
3 # What parts do we want to build?  We must build at least one kernel.
4 # These are the kernels that are built IF the architecture allows it.
5
6 %define buildup 1
7 %define buildsmp 0
8 %define builduml 0
9 %define buildsource 0
10 %define builddoc 0
11
12
13 # Versions of various parts
14
15 #
16 # Polite request for people who spin their own kernel rpms:
17 # please modify the "release" field in a way that identifies
18 # that the kernel isn't the stock distribution kernel, for example by
19 # adding some text to the end of the version number.
20 #
21 %define sublevel 7
22 %define kversion 2.6.%{sublevel}
23 %define rpmversion 2.6.%{sublevel}
24 %define rhbsys  %([ -r /etc/beehive-root ] && echo  || echo .`whoami`)
25 %define release 1.planetlab%{?date:.%{date}}
26 %define signmodules 0
27
28 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
29
30 # Override generic defaults with per-arch defaults 
31
32 %define image_install_path boot
33
34 #
35 # Three sets of minimum package version requirements in the form of Conflicts:
36 # to versions below the minimum
37 #
38
39 #
40 # First the general kernel 2.6 required versions as per
41 # Documentation/Changes
42 #
43 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
44
45
46 # Then a series of requirements that are distribution specific, either 
47 # because we add patches for something, or the older versions have 
48 # problems with the newer kernel or lack certain things that make 
49 # integration in the distro harder than needed.
50 #
51 %define package_conflicts  cipe < 1.4.5, tux < 2.1.0, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0
52
53 #
54 # Several packages had bugs in them that became obvious when the NPTL
55 # threading code got integrated. 
56 #
57 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
58
59 #
60 # Packages that need to be installed before the kernel is, because the %post
61 # scripts use them.
62 #
63 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
64
65 Name: kernel
66 Group: System Environment/Kernel
67 License: GPLv2
68 Version: %{rpmversion}
69 Release: %{release}
70 ExclusiveOS: Linux
71 Provides: kernel = %{version}
72 Provides: kernel-drm = 4.3.0
73 Prereq: %{kernel_prereq}
74 Conflicts: %{kernel_dot_org_conflicts}
75 Conflicts: %{package_conflicts}
76 Conflicts: %{nptl_conflicts}
77 # We can't let RPM do the dependencies automatic because it'll then pick up
78 # a correct but undesirable perl dependency from the module headers which
79 # isn't required for the kernel proper to function
80 AutoReqProv: no
81
82 #
83 # List the packages used during the kernel build
84 #
85 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
86 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, kernel-utils >= 2.4-12.1.139
87 # temporary req since modutils changed output format 
88 #BuildPreReq: modutils >= 2.4.26-14
89 BuildRequires: gcc >= 2.96-98, binutils >= 2.12, redhat-rpm-config
90 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
91 BuildArchitectures: i686
92
93
94
95 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
96
97 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
98
99 %description 
100 The kernel package contains the Linux kernel (vmlinuz), the core of any
101 Linux operating system.  The kernel handles the basic functions
102 of the operating system:  memory allocation, process allocation, device
103 input and output, etc.
104
105
106 %package sourcecode
107 Summary: The source code for the Linux kernel.
108 Group: Development/System
109 Prereq: fileutils
110 Requires: make >= 3.78
111 Requires: gcc >= 3.2
112 Requires: /usr/bin/strip
113 # for xconfig and gconfig
114 Requires: qt-devel, gtk2-devel readline-devel ncurses-devel
115 Provides: kernel-source
116 Obsoletes: kernel-source <= 2.6.6
117
118 %description sourcecode
119 The kernel-sourcecode package contains the source code files for the Linux
120 kernel. The source files can be used to build a custom kernel that is
121 smaller by virtue of only including drivers for your particular hardware, if
122 you are so inclined (and you know what you're doing). The customisation
123 guide in the documentation describes in detail how to do this. This package
124 is neither needed nor usable for building external kernel modules for
125 linking such modules into the default operating system kernels.
126
127 %package doc
128 Summary: Various documentation bits found in the kernel source.
129 Group: Documentation
130 %if !%{buildsource}
131 Obsoletes: kernel-source <= 2.6.6
132 Obsoletes: kernel-sourcecode <= 2.6.6
133 %endif
134
135 %description doc
136 This package contains documentation files from the kernel
137 source. Various bits of information about the Linux kernel and the
138 device drivers shipped with it are documented in these files. 
139
140 You'll want to install this package if you need a reference to the
141 options that can be passed to Linux kernel modules at load time.
142
143
144 %package smp
145 Summary: The Linux kernel compiled for SMP machines.
146
147 Group: System Environment/Kernel
148 Provides: kernel = %{version}
149 Provides: kernel-drm = 4.3.0
150 Prereq: %{kernel_prereq}
151 Conflicts: %{kernel_dot_org_conflicts}
152 Conflicts: %{package_conflicts}
153 Conflicts: %{nptl_conflicts}
154 # upto and including kernel 2.4.9 rpms, the 4Gb+ kernel was called kernel-enterprise
155 # now that the smp kernel offers this capability, obsolete the old kernel
156 Obsoletes: kernel-enterprise < 2.4.10
157 # We can't let RPM do the dependencies automatic because it'll then pick up
158 # a correct but undesirable perl dependency from the module headers which
159 # isn't required for the kernel proper to function
160 AutoReqProv: no
161
162 %description smp
163 This package includes a SMP version of the Linux kernel. It is
164 required only on machines with two or more CPUs as well as machines with
165 hyperthreading technology.
166
167 Install the kernel-smp package if your machine uses two or more CPUs.
168
169 %package uml
170 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
171
172 Group: System Environment/Kernel
173
174 %description uml
175 This package includes a user mode version of the Linux kernel.
176
177 %prep
178
179 %setup -n linux-%{kversion}
180
181 # make sure the kernel has the sublevel we know it has. This looks weird
182 # but for -pre and -rc versions we need it since we only want to use
183 # the higher version when the final kernel is released.
184 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
185 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
186
187 # get rid of unwanted files resulting from patch fuzz
188 find . -name "*.orig" -exec rm -fv {} \;
189 find . -name "*~" -exec rm -fv {} \;
190
191 ###
192 ### build
193 ###
194 %build
195
196 BuildKernel() {
197
198     # Pick the right config file for the kernel we're building
199     if [ -n "$1" ] ; then
200         Config=kernel-%{kversion}-%{_target_cpu}-$1-planetlab.config
201     else
202         Config=kernel-%{kversion}-%{_target_cpu}-planetlab.config
203     fi
204
205     KernelVer=%{version}-%{release}$1
206     echo BUILDING A KERNEL FOR $1 %{_target_cpu}...
207
208     # make sure EXTRAVERSION says what we want it to say
209     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}$1/" Makefile
210
211     # override ARCH in the case of UML
212     if [ "$1" = "uml" ] ; then
213         export ARCH=um
214     fi
215
216     # and now to start the build process
217
218     make -s mrproper
219     cp configs/$Config .config
220
221     make -s nonint_oldconfig > /dev/null
222     make -s include/linux/version.h 
223
224     make -s %{?_smp_mflags} bzImage 
225     make -s %{?_smp_mflags} modules || exit 1
226     make buildcheck
227     
228     # Start installing the results
229
230     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
231     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
232     install -m 644 System.map $RPM_BUILD_ROOT/usr/lib/debug/boot/System.map-$KernelVer
233     objdump -t vmlinux | grep ksymtab | cut -f2 | cut -d" " -f2 | cut -c11- | sort -u  > exported
234     echo "_stext" >> exported
235     echo "_end" >> exported
236     touch $RPM_BUILD_ROOT/boot/System.map-$KernelVer
237     for i in `cat exported` 
238     do 
239          grep " $i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer || :
240          grep "tab_$i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer || :
241          grep "__crc_$i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer ||:
242     done
243     rm -f exported
244     install -m 644 init/kerntypes.o $RPM_BUILD_ROOT/boot/Kerntypes-$KernelVer
245     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
246     rm -f System.map
247     cp arch/*/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
248
249     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
250     make -s INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
251  
252     # And save the headers/makefiles etc for building modules against
253     #
254     # This all looks scary, but the end result is supposed to be:
255     # * all arch relevant include/ files
256     # * all Makefile/Kconfig files
257     # * all script/ files 
258
259     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
260     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
261     # first copy everything
262     cp --parents `find  -type f -name Makefile -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
263     cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
264     # then drop all but the needed Makefiles/Kconfig files
265     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
266     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
267     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
268     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
269     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
270     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
271     cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
272     cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
273     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
274     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
275     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
276     cd include
277     cp -a acpi config linux math-emu media net pcmcia rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
278     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
279     # Make sure the Makefile and version.h have a matching timestamp so that
280     # external modules can be built
281     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
282     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
283     cd .. 
284
285     #
286     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
287     #
288     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
289     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
290
291     # mark modules executable so that strip-to-file can strip them
292     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f  | xargs chmod u+x
293
294     # detect missing or incorrect license tags
295     for i in `find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" ` ; do echo -n "$i " ; /sbin/modinfo -l $i >> modinfo ; done
296     cat modinfo | grep -v "^GPL" | grep -v "^Dual BSD/GPL" | grep -v "^Dual MPL/GPL" | grep -v "^GPL and additional rights" | grep -v "^GPL v2" && exit 1 
297     rm -f modinfo
298     # remove files that will be auto generated by depmod at rpm -i time
299     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
300
301 }
302
303 ###
304 # DO it...
305 ###
306
307 # prepare directories
308 rm -rf $RPM_BUILD_ROOT
309 mkdir -p $RPM_BUILD_ROOT/boot
310
311 %if %{buildup}
312 BuildKernel
313 %endif
314
315 %if %{buildsmp}
316 BuildKernel smp
317 %endif
318
319 %if %{builduml}
320 BuildKernel uml
321 %endif
322
323 ###
324 ### install
325 ###
326
327 %install
328
329 # architectures that don't get kernel-source (i586/i686/athlon) dont need
330 # much of an install because the build phase already copied the needed files
331
332 %if %{builddoc}
333 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
334
335 # sometimes non-world-readable files sneak into the kernel source tree
336 chmod -R a+r *
337 # copy the source over
338 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
339 %endif
340
341 %if %{buildsource}
342
343 mkdir -p $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
344 chmod -R a+r *
345
346 # clean up the source tree so that it is ready for users to build their own
347 # kernel
348 make -s mrproper
349 # copy the source over
350 tar cf - . | tar xf - -C $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
351
352 # set the EXTRAVERSION to <version>custom, so that people who follow a kernel building howto
353 # don't accidentally overwrite their currently working moduleset and hose
354 # their system
355 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}custom/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/Makefile
356
357 # some config options may be appropriate for an rpm kernel build but are less so for custom user builds,
358 # change those to values that are more appropriate as defeault for people who build their own kernel.
359 perl -p -i -e "s/^CONFIG_DEBUG_INFO.*/# CONFIG_DEBUG_INFO is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
360 perl -p -i -e "s/^.*CONFIG_DEBUG_PAGEALLOC.*/# CONFIG_DEBUG_PAGEALLOC is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
361 perl -p -i -e "s/^.*CONFIG_DEBUG_SLAB.*/# CONFIG_DEBUG_SLAB is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
362 perl -p -i -e "s/^.*CONFIG_DEBUG_SPINLOCK.*/# CONFIG_DEBUG_SPINLOCK is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
363 perl -p -i -e "s/^.*CONFIG_DEBUG_HIGHMEM.*/# CONFIG_DEBUG_HIGHMEM is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
364 perl -p -i -e "s/^.*CONFIG_MODULE_SIG.*/# CONFIG_MODULE_SIG is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
365
366 install -m 644 %{SOURCE10}  $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
367 %endif
368
369 ###
370 ### clean
371 ###
372
373 %clean
374 rm -rf $RPM_BUILD_ROOT
375
376 ###
377 ### scripts
378 ###
379
380 # load the loop module for upgrades...in case the old modules get removed we have
381 # loopback in the kernel so that mkinitrd will work.
382 %pre 
383 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
384 exit 0
385
386 %pre smp
387 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
388 exit 0
389
390 %post 
391 # trick mkinitrd in case the current environment does not have device mapper
392 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
393 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
394     if [ ! -f $rootdev ]; then
395         fake_root_lvm=1
396         mkdir -p $(dirname $rootdev)
397         touch $rootdev
398     fi
399 fi
400 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
401 if [ -n "$fake_root_lvm" ]; then
402     rm -f $rootdev
403 fi
404 if [ -x /usr/sbin/hardlink ] ; then
405 pushd /lib/modules/%{KVERREL}/build > /dev/null ; {
406         cd /lib/modules/%{KVERREL}/build
407         find . -type f | while read f; do hardlink -c /lib/modules/*/build/$f $f ; done
408 }
409 popd
410 fi
411
412 # make some useful links
413 pushd /boot > /dev/null ; {
414         ln -sf System.map-%{KVERREL} System.map
415         ln -sf Kerntypes-%{KVERREL} Kerntypes
416         ln -sf config-%{KVERREL} config
417         ln -sf initrd-%{KVERREL}.img initrd-boot
418         ln -sf vmlinuz-%{KVERREL} kernel-boot
419 }
420 popd
421
422 # ask for a reboot
423 mkdir -p /etc/planetlab
424 touch /etc/planetlab/update-reboot
425
426 %post smp
427 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}smp
428 if [ -x /usr/sbin/hardlink ] ; then
429 pushd /lib/modules/%{KVERREL}smp/build > /dev/null ; {
430         cd /lib/modules/%{KVERREL}smp/build
431         find . -type f | while read f; do hardlink -c /lib/modules/*/build/$f $f ; done
432 }
433 popd
434 fi
435
436
437 %preun 
438 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
439 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
440
441 %preun smp
442 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
443 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}smp
444
445
446 ###
447 ### file lists
448 ###
449
450 %if %{buildup}
451 %files 
452 %defattr(-,root,root)
453 /%{image_install_path}/vmlinuz-%{KVERREL}
454 /boot/Kerntypes-%{KVERREL}
455 /boot/System.map-%{KVERREL}
456 /boot/config-%{KVERREL}
457 %dir /lib/modules/%{KVERREL}
458 /lib/modules/%{KVERREL}/kernel
459 %verify(not mtime) /lib/modules/%{KVERREL}/build
460
461 %endif
462
463 %if %{buildsmp}
464 %files smp
465 %defattr(-,root,root)
466 /%{image_install_path}/vmlinuz-%{KVERREL}smp
467 /boot/Kerntypes-%{KVERREL}smp
468 /boot/System.map-%{KVERREL}smp
469 /boot/config-%{KVERREL}smp
470 %dir /lib/modules/%{KVERREL}smp
471 /lib/modules/%{KVERREL}smp/kernel
472 %verify(not mtime) /lib/modules/%{KVERREL}smp/build
473
474 %endif
475
476 %if %{builduml}
477 %files uml
478 %defattr(-,root,root)
479
480 %endif
481
482 # only some architecture builds need kernel-source and kernel-doc
483
484 %if %{buildsource}
485 %files sourcecode
486 %defattr(-,root,root)
487 /usr/src/linux-%{KVERREL}/
488 %endif
489
490
491 %if %{builddoc}
492 %files doc
493 %defattr(-,root,root)
494 /usr/share/doc/kernel-doc-%{kversion}/Documentation/*
495 %endif
496
497 %changelog
498 * Thu Aug  5 2004 Mark Huang <mlhuang@cs.princeton.edu>
499 - adapt for Fedora Core 2 based PlanetLab 3.0 (remove Source and Patch
500   sections, most non-x86 sections, and GPG sections)
501
502 * Fri Jul 16 2004 Arjan van de Ven <arjanv@redhat.com>
503 - ppc32 embedded updates
504
505 * Thu Jul 15 2004 Arjan van de Ven <arjanv@redhat.com>
506 - make USB modules again and add Alan's real fix for the SMM-meets-USB bug
507 - 2.6.8-rc1-bk4
508
509 * Wed Jul 14 2004 Arjan van de Ven <arjanv@redhat.com>
510 - 2.6.8-rc1-bk3
511
512 * Tue Jul 13 2004 Arjan van de Ven <arjanv@redhat.com>
513 - add "enforcemodulesig" boot option to make the kernel load signed modules only
514
515 * Mon Jul 12 2004 Arjan van de Ven <arjanv@redhat.com>
516 - updated voluntary preempt
517 - 2.6.8-rc1
518
519 * Wed Jul 7 2004 Arjan van de Ven <arjanv@redhat.com>
520 - fix boot breakage that was hitting lots of people (Dave Jones)
521
522 * Tue Jul 6 2004 Arjan van de Ven <arjanv@redhat.com>
523 - add voluntary preemption patch from Ingo
524 - 2.6.7-bk19
525
526 * Tue Jun 29 2004 Arjan van de Ven <arjanv@redhat.com>
527 - make a start at gpg signed modules support
528
529 * Sat Jun 27 2004 Arjan van de Ven <arjanv@redhat.com>
530 - experiment with making the hardlink call in post more efficient
531 - 2.6.7-bk9
532
533 * Thu Jun 24 2004 Arjan van de Ven <arjanv@redhat.com>
534 - 2.6.7-bk7
535 - Add wli's patch to allocate memory bottom up not top down
536 - change some config options in the kernel-sourcecode package that are
537   good for rpm kernel builds but not for custom user builds to more appropriate 
538   default values.
539 - reenable kernel-sourcecode again for a few builds 
540
541 * Wed Jun 23 2004 Arjan van de Ven <arjanv@redhat.com>
542 - 2.6.7-bk5
543 - fix tux unresolved symbols (#126532)
544
545 * Mon Jun 21 2004 Arjan van de Ven <arjanv@redhat.com>
546 - make kernel-doc and kernel-sourcecode builds independent of eachother
547 - disable kernel-sourcecode builds entirely, we'll be replacing it with documentation
548   on how to use the src.rpm instead for building your own kernel.
549
550 * Sat Jun 19 2004 Arjan van de Ven <arjanv@redhat.com>
551 - 2.6.7-bk2
552
553 * Sun Jun 13 2004 Arjan van de Ven <arjanv@redhat.com>
554 - add patch from DaveM to fix the ppp-keeps-iface-busy bug
555
556 * Sat Jun 12 2004 Arjan van de Ven <arjanv@redhat.com>
557 - add fix from Andi Kleen/Linus for the fpu-DoS
558
559 * Thu Jun 10 2004 Arjan van de Ven <arjanv@redhat.com>
560 - disable mlock-uses-rlimit patch, it has a security hole and needs more thought
561 - revert airo driver to the FC2 one since the new one breaks
562
563 * Tue Jun 8 2004 Dave Jones <davej@redhat.com>
564 - Update to 2.6.7rc3
565
566 * Fri Jun 4 2004 Arjan van de Ven <arjanv@redhat.com>
567 - fix the mlock-uses-rlimit patch
568
569 * Wed Jun 2 2004 David Woodhouse <dwmw2@redhat.com>
570 - Add ppc64 (Mac G5)
571
572 * Wed Jun 2 2004 Arjan van de Ven <arjanv@redhat.com>
573 - add a forward port of the mlock-uses-rlimit patch
574 - add NX support for x86 (Intel, Ingo)
575
576 * Tue Jun 1 2004 Arjan van de Ven <arjanv@redhat.com>
577 - refresh ext3 reservation patch
578
579 * Sun May 30 2004 Arjan van de Ven <arjanv@redhat.com>
580 - 2.6.7-rc2
581 - set the ACPI OS name to "Microsoft Windows XP" for better compatibility
582
583 * Thu May 27 2004 Pete Zaitcev <zaitcev@redhat.com>
584 - Fix qeth and zfcp (s390 drivers): align qib by 256, embedded into qdio_irq.
585
586 * Thu May 27 2004 Dave Jones <davej@redhat.com>
587 - Fix the crashes on boot on Asus P4P800 boards. (#121819)
588
589 * Wed May 26 2004 Dave Jones <davej@redhat.com>
590 - Lots more updates to the SCSI whitelist for various
591   USB card readers. (#112778, among others..)
592
593 * Wed May 26 2004 Arjan van de Ven <arjanv@redhat.com>
594 - back out ehci suspend/resume patch, it breaks
595 - add fix for 3c59x-meets-kudzu bug from Alan
596
597 * Tue May 25 2004 Arjan van de Ven <arjanv@redhat.com>
598 - try improving suspend/resume by restoring more PCI state
599 - 2.6.7-rc1-bk1
600
601 * Mon May 24 2004 Dave Jones <davej@redhat.com>
602 - Add yet another multi-card reader to the whitelist (#85851)
603
604 * Sun May 23 2004 Dave Jones <davej@redhat.com>
605 - Add another multi-card reader to the whitelist (#124048)
606
607 * Wed May 19 2004 Arjan van de Ven <arjanv@redhat.com>
608 - put firewire race fix in (datacorruptor)
609
610 * Tue May 18 2004 Dave Jones <davej@redhat.com>
611 - Fix typo in ibmtr driver preventing compile (#123391)
612
613 * Mon May 17 2004 Arjan van de Ven <arjanv@redhat.com>
614 - update to 2.6.6-bk3
615 - made kernel-source and kernel-doc noarch.rpm's since they are not
616   architecture specific.
617
618 * Sat May 08 2004 Arjan van de Ven <arjanv@redhat.com>
619 - fix non-booting on Transmeta cpus (Peter Anvin)
620 - fix count leak in message queues
621
622 * Fri May 07 2004 Arjan van de Ven <arjanv@redhat.com>
623 - more ide cache flush work
624 - patch from scsi-bk to fix sd refcounting
625
626 * Thu May 06 2004 Arjan van de Ven <arjanv@redhat.com>
627 - some more ide cache flush fixes 
628
629 * Wed May 05 2004 Arjan van de Ven <arjanv@redhat.com>
630 - fix bug 122504
631 - convert b44 to ethtool ops (jgarzik)
632 - make IDE do a cache-flush on shutdown (me/Alan)
633
634 * Tue May 04 2004 Arjan van de Ven <arjanv@redhat.com>
635 - work around i810/i830 DRM issue
636
637 * Fri Apr 30 2004 Arjan van de Ven <arjanv@redhat.com>
638 - 2.6.6-rc3-bk1
639 - make amd64 boot again
640 - fix vm86-vs-4g4g interaction (Ingo)
641
642 * Thu Apr 22 2004 Arjan van de Ven <arjanv@redhat.com>
643 - 2.6.6-rc2
644  
645 * Tue Apr 20 2004 Arjan van de Ven <arjanv@redhat.com>
646 - add the ext3 online resize patch
647
648 * Mon Apr 19 2004 Arjan van de Ven <arjanv@redhat.com>
649 - 2.6.6-rc1-bk3
650 - add the objrmap vm from the -mm tree; it needs testing
651
652 * Thu Apr 15 2004 Arjan van de Ven <arjanv@redhat.com>
653 - 2.6.5-bk2
654 - disable DISCONTIGMEM on ia64 for performance
655 - fix sleep_on use in reiserfs (Chris Mason)
656
657 * Tue Apr 13 2004 Arjan van de Ven <arjanv@redhat.com>
658 - 2.6.5-mc4
659 - reenable sg driver for scsi tape changers and such
660 - the sk98lin driver oopses on module unload, preven that
661
662 * Mon Apr 12 2004 Arjan van de Ven <arjanv@redhat.com>
663 - fix "bad pmd" bug with patch from Ingo
664
665 * Fri Apr 09 2004 Arjan van de Ven <arjanv@redhat.com>
666 - 2.6.5-mc3
667 - finish up the -mc2 merge
668 - latest 4g/4g patch from Ingo
669 - latest execshield patch from Ingo
670 - fix a few framebuffer bugs
671
672 * Thu Apr 08 2004 Arjan van de Ven <arjanv@redhat.com>
673 - first attempt at a 2.6.5-mc2 merge
674
675 * Thu Apr 08 2004 Dave Jones <davej@redhat.com>
676 - Add in missing SiS AGP fix.
677
678 * Tue Apr 06 2004 Dave Jones <davej@redhat.com>
679 - More agpgart fixes.
680
681 * Fri Apr 02 2004 Arjan van de Ven <arjanv@redhat.com>
682 - fix another 4g/4g-vs-resume bug
683
684 * Tue Mar 30 2004 Arjan van de Ven <arjanv@redhat.com>
685 - 2.6.5-rc3
686 - fix PCI posting bug in i830 DRM
687
688 * Mon Mar 29 2004 Arjan van de Ven <arjanv@redhat.com>
689 - 2.6.5-rc2-bk8
690
691 * Mon Mar 29 2004 Dave Jones <davej@redhat.com>
692 - Include latest agpgart fixes.
693
694 * Thu Mar 25 2004 Arjan van de Ven <arjanv@redhat.com>
695 - more DRM fixes
696 - add the fsync patches from akpm
697
698 * Tue Mar 23 2004 Arjan van de Ven <arjanv@redhat.com>
699 - 2.6.5-rc2-bk3
700 - fix direct userspace memory access in i830 drm driver
701
702 * Mon Mar 22 2004 Arjan van de Ven <arjanv@redhat.com>
703 - 2.6.5-rc2-bk2
704 - some stackbloat reductions from Dave and me
705
706 * Sat Mar 20 2004 Arjan van de Ven <arjanv@redhat.com>
707 - 2.6.5-rc2
708
709 * Tue Mar 16 2004 Dave Jones <davej@redhat.com>
710 - 2.6.5-rc1
711
712 * Mon Mar 15 2004 Arjan van de Ven <arjanv@redhat.com>
713 - 2.6.4-bk3
714 - fix oops in toshiba_acpi (Barry K. Nathan)
715
716 * Sat Mar 13 2004 Arjan van de Ven <arjanv@redhat.com>
717 - 2.6.4-bk2 merge 
718
719 * Thu Mar 11 2004 Arjan van de Ven <arjanv@redhat.com>
720 - renable sonypi driver that was off accidentally
721 - 2.6.4-final 
722 - fix the oops on alsa module unloads
723
724 * Wed Mar 10 2004 Arjan van de Ven <arjanv@redhat.com>
725 - add ppc64/iseries, ppc32 (powermac/ibook) and ia64 architectures
726 - 2.6.4-rc3 
727
728 * Tue Mar 09 2004 Arjan van de Ven <arjanv@redhat.com>
729 - 2.6.4-rc2-bk5
730 - fix nfs-vs-selinux issue
731 - fix typo in URL as per #117849
732
733 * Mon Mar 08 2004 Arjan van de Ven <arjanv@redhat.com>
734 - fix race in lp.c (#117710)
735 - 2.6.4-rc2-bk3
736 - attempt to fix S3 suspend-to-ram with 4g/4g split
737
738 * Sat Mar 06 2004 Arjan van de Ven <arjanv@redhat.com>
739 - fix reiserfs
740 - set HZ to 1000 again for some tests
741
742 * Wed Feb 25 2004 Arjan van de Ven <arjanv@redhat.com>
743 - merge back a bunch of fedora fixes
744 - disable audit
745
746 * Tue Feb 24 2004 Arjan van de Ven <arjanv@redhat.com>
747 - audit bugfixes
748 - update tux to a working version
749 - 2.6.3-bk5 merge
750
751 * Fri Feb 20 2004 Arjan van de Ven <arjanv@redhat.com>
752 - re-add and enable the Auditing patch
753 - switch several cpufreq modules to built in since detecting in userspace
754   which to use is unpleasant
755 * Thu Jul 03 2003 Arjan van de Ven <arjanv@redhat.com>
756 - 2.6 start 
757