5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
12 Source0: %{name}-%{version}.tar.bz2
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
21 Summary: the SFA python libraries
22 Group: Applications/System
25 Requires: python >= 2.5
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
30 # xmlbuilder depends on lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
49 Summary: the SFA wrapper around MyPLC NodeManager
50 Group: Applications/System
52 Requires: pyOpenSSL >= 0.6
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
66 Requires: pyOpenSSL >= 0.7
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
74 Summary: unit tests suite for SFA
75 Group: Applications/System
79 This package provides the python libraries for the PlanetLab implementation of SFA
82 This package implements the SFA interface which serves as a layer
83 between the existing PlanetLab NodeManager interfaces and the SFA API.
86 This package implements the SFA interface which serves as a layer
87 between the existing PlanetLab interfaces and the SFA API.
90 This package provides the client side of the SFA API, in particular
91 sfi.py, together with other utilities.
93 %description sfatables
94 sfatables is a tool for defining access and admission control policies
95 in an SFA network, in much the same way as iptables is for ip
96 networks. This is the command line interface to manage sfatables
99 Provides some binary unit tests in /usr/share/sfa/tests
105 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
108 rm -rf $RPM_BUILD_ROOT
109 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
112 rm -rf $RPM_BUILD_ROOT
115 # sfa and sfatables depend each other.
116 %{_bindir}/sfa-server.py*
119 %{_bindir}/keyconvert.py*
120 /var/www/html/wsdl/*.wsdl
124 %{_bindir}/sfa_component_setup.py*
128 %defattr(-,root,root)
129 %config /etc/sfa/default_config.xml
130 %config (noreplace) /etc/sfa/aggregates.xml
131 %config (noreplace) /etc/sfa/registries.xml
134 /etc/sfa/credential.xsd
138 /etc/sfa/protogeni-rspec-common.xsd
139 %{_bindir}/sfa-config-tty
140 %{_bindir}/sfa-import-plc.py*
141 %{_bindir}/sfa-clean-peer-records.py*
142 %{_bindir}/sfa-nuke-plc.py*
143 %{_bindir}/gen-sfa-cm-config.py*
144 %{_bindir}/sfa-ca.py*
147 %config (noreplace) /etc/sfa/sfi_config
149 %{_bindir}/getNodes.py*
150 %{_bindir}/getRecord.py*
151 %{_bindir}/setRecord.py*
152 %{_bindir}/sfadump.py*
158 %{_datadir}/sfa/tests
160 ### sfa-plc installs the 'sfa' service
165 if [ "$1" = 0 ] ; then
166 /sbin/service sfa stop || :
167 /sbin/chkconfig --del sfa || :
171 [ "$1" -ge "1" ] && service sfa restart
173 ### sfa-cm installs the 'sfa-cm' service
175 chkconfig --add sfa-cm
178 if [ "$1" = 0 ] ; then
179 /sbin/service sfa-cm stop || :
180 /sbin/chkconfig --del sfa-cm || :
184 [ "$1" -ge "1" ] && service sfa-cm restart
188 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
189 - fix registry credential regeneration and handle expiration
190 - support for setting slice tags (min_role=user)
191 - client can display its own version: sfi.py version --local
192 - GetVersion to provide urn in addition to hrn
193 - more code uses plxrn vs previous helper functions
194 - import replaces '+' in email addresses with '_'
196 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
197 - fix GetVersion code_tag and add code_url
199 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
200 - extend GetVersion towards minimum federation introspection, and expose local tag
202 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
203 - fixed some legacy issues (list vs List)
204 - deprecated sfa.util.namespace for xrn and plxrn
205 - unit tests ship as the sfa-tests rpm
207 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
208 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
209 - NOTE: get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
210 - hrn-urn translations tweaked
211 - fixed 'service sfa status'
212 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
213 - started to repair sfadump - although not usable yet
214 - trust objects now have dump_string method that dump() actually prints
215 - unit tests under review
216 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
217 - binaries now support -v or -vv to increase loglevel
218 - trashed obsolete sfa.util.client
220 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
221 - various bugfixes and cleanup, improved/harmonized logging
223 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
224 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
225 to avoid returning a PLCAPI exception that might confuse users.
226 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.
229 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
230 - (Architecture) Credential format changed to match ProtoGENI xml format
231 - (Architecture) All interfaces export a new set of methods that are compatible
232 with the ProtoGeni Aggregate spec. These new methods are considered a
233 replacement for the pervious methods exported by the interfaces. All
234 previous methods are still exported and work as normal, but they are
235 considered deprecated and will not be supported in future releases.
236 - (Architecture) SFI has been updated to use the new interface methods.
237 - (Architecture) Changed keyconvet implementation from c to python.
238 - (Architecture) Slice Manager now attempts looks for a delegated credential
239 provided by the client before using its own server credential.
240 - (Archiceture) Slice Interface no longers stores cache of resources on disk.
241 This cache now exists only in memory and is cleared when service is restarted
242 or cache lifetime is exceeded.
243 - (Performance) SliceManager sends request to Aggregates in parallel instead
245 - (Bug fix) SFA tickets now support the new rspec format.
246 - (Bug fix) SFI only uses cahced credential if they aren't expired.
247 - (Bug fix) Cerdential delegation modified to work with new credential format.
248 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
249 Aggregate instead of relaying through the Slice Manager.
250 - (Enhancement) Simplified caching. Accociated a global cache instance with
251 the api handler on every new server request, making it easier to access the
252 cache and use in more general ways.
255 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
256 - fix registry credential regeneration and handle expiration
257 - support for setting slice tags (min_role=user)
258 - client can display its own version: sfi.py version --local
259 - GetVersion to provide urn in addition to hrn
260 - more code uses plxrn vs previous helper functions
261 - import replaces '+' in email addresses with '_'
263 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
264 - fix GetVersion code_tag and add code_url
266 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
267 - extend GetVersion towards minimum federation introspection, and expose local tag
269 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
270 - fixed some legacy issues (list vs List)
271 - deprecated sfa.util.namespace for xrn and plxrn
272 - unit tests ship as the sfa-tests rpm
274 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
275 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
276 - NOTE: get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
277 - hrn-urn translations tweaked
278 - fixed 'service sfa status'
279 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
280 - started to repair sfadump - although not usable yet
281 - trust objects now have dump_string method that dump() actually prints
282 - unit tests under review
283 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
284 - binaries now support -v or -vv to increase loglevel
285 - trashed obsolete sfa.util.client
287 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
288 - various bugfixes and cleanup, improved/harmonized logging
290 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
291 - SfaServer now uses a pool of threads to handle requests concurrently
292 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
293 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
294 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
295 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir
296 - Component manager does not install gid files if slice already has them
297 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
298 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
299 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
301 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
302 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support. Other features are:
303 - - sfa-config-tty now has the same features like plc-config-tty
304 - - Contains code to support both urn and hrn
305 - - Cleaned up request_hash related stuff
306 - - SM, AM and Registry code is organized under respective managers
307 - - Site and Slice synchronization across federated aggregates
308 - - Script to generate sfa_component_config
310 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
311 - sfa-config-tty now has the same features like plc-config-tty
312 - Contains code to support both urn and hrn
313 - Cleaned up request_hash related stuff
314 - SM, AM and Registry code is organized under respective managers
315 - Slice synchronization across federated aggregates
316 - some bugs are fixed
318 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
319 - checkpoint with fewer mentions of geni
321 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
323 - this is believed to pass the tests; among other things:
324 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
326 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
329 - - Preliminary version of hash based authentication
330 - - Initial code for Component Manager
331 - - Authority structure is moved to /var/lib/sfa/
334 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
335 - Create_slice and get_resources methods are connected to sfatables.
336 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
338 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
339 - Bug fix on update and remove_peer_object methods
340 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
342 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
343 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
345 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
346 - compatibility with RefreshPeer
347 - incremental mechanism for importing PLC records into SFA tables
348 - unified single database (still inside the underlying PLC db postgresql server)
349 - includes/improves call traceability and logging features
352 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
353 - added libxslt-python dependency
355 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
356 - unified single SFA database in the PLC-DB
357 - upcalls from PLCAPI to SFA methods
358 - SFA call traceability and logging features
360 - includes first/rough version of sfatables for policy implementation
362 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
363 - snapshot after the GEC5 demo
364 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
366 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
367 - snapshot july 15 - has gone through superficial manual testing
368 - hopefully a good basis for gec5 demo
369 - multi-dir sfi client tested as well
371 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
372 - rename geniwrapper.spec into sfa.spec
374 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
375 - clean up in xmlrpc/soap, --protocol option to chose between both
376 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
377 - hopefully more helpful context in case of crashes when importing
378 - bugfixes for using only /etc/sfa for site-dep files
379 - bugfixes in wsdl generation
381 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
382 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
383 - config variables in sfa_config now start with SFA_ and not GENI_
384 - config.py can be loaded even with no config present
386 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
387 - first step for cleanup and reorganization
388 - mass-renaming from geni to sfa (some are still needed)
389 - sfa/trust implements the security architecture
391 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
392 - snapshot for reproducible builds
394 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
395 - snapshot for the convenience of alpha users
397 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
398 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
400 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
401 - ongoing work - snapshot for 4.3-rc9
403 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
406 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
407 - bugfixes - still a work in progress
409 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
413 %define module_current_branch 0.2