63996d1553d4b7be0c4e0567864557c8a695c4f0
[sliver-openvswitch.git] / xenserver / vswitch-xen.spec
1 # Spec file for vswitch and related programs.
2
3 # Copyright (C) 2009 Nicira Networks, Inc.
4 #
5 # Copying and distribution of this file, with or without modification,
6 # are permitted in any medium without royalty provided the copyright
7 # notice and this notice are preserved.  This file is offered as-is,
8 # without warranty of any kind.
9
10 # When building, the rpmbuild command line should define
11 # vswitch_version, xen_version, and build_number using -D arguments.
12 # for example:
13 #
14 #    rpmbuild -D "vswitch_version 0.8.9~1+build123" -D "xen_version 2.6.18-128.1.1.el5.xs5.1.0.483.1000xen" -D "build_number --with-build-number=123" -bb /usr/src/redhat/SPECS/vswitch-xen.spec
15 #
16 %define version %{vswitch_version}-%{xen_version}
17
18 Name: vswitch
19 Summary: Virtual switch
20 Group: System Environment/Daemons
21 URL: http://www.openvswitch.org/
22 Version: %{vswitch_version}
23
24 # The entire source code is ASL 2.0 except datapath/ which is GPLv2
25 License: ASL 2.0 and GPLv2
26 Release: 1
27 Source: openvswitch-%{vswitch_version}.tar.gz
28 Buildroot: /tmp/vswitch-xen-rpm
29 Requires: kernel-xen = %(echo '%{xen_version}' | sed 's/xen$//')
30 # The following Conflicts prevents the "vswitch" package generated by
31 # this spec file from installing at the same time as the "openvswitch"
32 # package shipped with XenServer 5.5.900.  In fact, the packages
33 # contain some files with identical names anyhow, so they will not
34 # coexist, but adding an explicit Conflicts makes this conflict more
35 # obvious.
36 Conflicts: openvswitch
37
38 %description
39 The vswitch provides standard network bridging functions augmented with
40 support for the OpenFlow protocol for remote per-flow control of
41 traffic.
42
43 %prep
44 %setup -q -n openvswitch-%{vswitch_version}
45
46 %build
47 ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=%{_localstatedir} --with-l26=/lib/modules/%{xen_version}/build --enable-ssl %{build_number}
48 make %{_smp_mflags}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 make install DESTDIR=$RPM_BUILD_ROOT
53 install -d -m 755 $RPM_BUILD_ROOT/etc
54 install -d -m 755 $RPM_BUILD_ROOT/etc/init.d
55 install -m 755 xenserver/etc_init.d_vswitch \
56          $RPM_BUILD_ROOT/etc/init.d/vswitch
57 install -m 755 xenserver/etc_init.d_vswitch-xapi-update \
58          $RPM_BUILD_ROOT/etc/init.d/vswitch-xapi-update
59 install -d -m 755 $RPM_BUILD_ROOT/etc/sysconfig
60 install -d -m 755 $RPM_BUILD_ROOT/etc/logrotate.d
61 install -m 755 xenserver/etc_logrotate.d_vswitch \
62          $RPM_BUILD_ROOT/etc/logrotate.d/vswitch
63 install -d -m 755 $RPM_BUILD_ROOT/etc/profile.d
64 install -m 755 xenserver/etc_profile.d_vswitch.sh \
65          $RPM_BUILD_ROOT/etc/profile.d/vswitch.sh
66 install -d -m 755 $RPM_BUILD_ROOT/etc/xapi.d/plugins
67 install -m 755 xenserver/etc_xapi.d_plugins_vswitch-cfg-update \
68          $RPM_BUILD_ROOT/etc/xapi.d/plugins/vswitch-cfg-update
69 install -d -m 755 $RPM_BUILD_ROOT/usr/share/vswitch/scripts
70 install -m 755 xenserver/opt_xensource_libexec_interface-reconfigure \
71              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/interface-reconfigure
72 install -m 755 xenserver/etc_xensource_scripts_vif \
73              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/vif
74 install -m 755 xenserver/usr_sbin_xen-bugtool \
75              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/xen-bugtool
76 install -m 755 xenserver/usr_sbin_brctl \
77              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/brctl
78 install -m 755 xenserver/usr_share_vswitch_scripts_sysconfig.template \
79          $RPM_BUILD_ROOT/usr/share/vswitch/scripts/sysconfig.template
80 install -m 644 xenserver/etc_udev_xen-backend.rules \
81         $RPM_BUILD_ROOT/usr/share/vswitch/scripts/xen-backend.rules
82 install -m 644 \
83         xenserver/usr_lib_xsconsole_plugins-base_XSFeatureVSwitch.py \
84                $RPM_BUILD_ROOT/usr/share/vswitch/scripts/XSFeatureVSwitch.py
85
86 install -d -m 755 $RPM_BUILD_ROOT/lib/modules/%{xen_version}/kernel/net/vswitch
87 find datapath/linux-2.6 -name *.ko -exec install -m 755  \{\} $RPM_BUILD_ROOT/lib/modules/%{xen_version}/kernel/net/vswitch \;
88
89 # Get rid of stuff we don't want to make RPM happy.
90 rm \
91     $RPM_BUILD_ROOT/usr/bin/ovs-controller \
92     $RPM_BUILD_ROOT/usr/bin/ovs-discover \
93     $RPM_BUILD_ROOT/usr/bin/ovs-kill \
94     $RPM_BUILD_ROOT/usr/bin/ovs-openflowd \
95     $RPM_BUILD_ROOT/usr/bin/ovs-pki \
96     $RPM_BUILD_ROOT/usr/bin/ovs-wdt \
97     $RPM_BUILD_ROOT/usr/sbin/ovs-monitor \
98     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-controller.8 \
99     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-discover.8 \
100     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-kill.8 \
101     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-openflowd.8 \
102     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-pki.8
103 rm -f $RPM_BUILD_ROOT/lib/modules/%{xen_version}/kernel/net/vswitch/veth_mod.ko
104 rm -r \
105     $RPM_BUILD_ROOT/usr/share/openvswitch/commands
106
107 install -d -m 755 $RPM_BUILD_ROOT/var/lib/openvswitch
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 if [ ! -f /etc/xensource-inventory ]; then
114     printf "XenSource inventory not present in /etc/xensource-inventory"
115     exit 1
116 fi
117
118 if [ "$1" = "1" ]; then
119     if md5sum -c --status <<EOF
120 ca141d60061dcfdade73e75abc6529b5  /usr/sbin/brctl
121 b8e9835862ef1a9cec2a3f477d26c989  /etc/xensource/scripts/vif
122 51970ad613a3996d5997e18e44db47da  /opt/xensource/libexec/interface-reconfigure
123 5654c8c36699fcc8744ca9cd5b855414  /usr/sbin/xen-bugtool
124 883820a78723ee21340f31099b18f18e  /etc/udev/xen-backend.rules
125 EOF
126     then
127         printf "\nVerified host scripts from XenServer 5.5.0.\n\n"
128     elif md5sum -c --status <<EOF
129 ca141d60061dcfdade73e75abc6529b5  /usr/sbin/brctl
130 b8e9835862ef1a9cec2a3f477d26c989  /etc/xensource/scripts/vif
131 ce451d3c985fd1db6497a363f0d9dedb  /opt/xensource/libexec/interface-reconfigure
132 2b53f500431fcba5276c896e9e4281b9  /usr/sbin/xen-bugtool
133 883820a78723ee21340f31099b18f18e  /etc/udev/xen-backend.rules
134 EOF
135     then
136         printf "\nVerified host scripts from XenServer 5.5.900.\n\n"
137     else
138 cat <<EOF
139
140 The original XenServer scripts replaced by this package are not those
141 of any supported version of XenServer.  This could lead to unexpected
142 behavior of your server.  Unless you are sure you know what you are
143 doing, it is highly recommended that you remove this package
144 immediately after the install completes, which will restore the
145 XenServer scripts that you were previously using.
146
147 EOF
148     fi
149 fi
150
151 if test ! -e /var/lib/openvswitch/dbcache; then
152     if test "$1" = 1; then
153         printf "Creating xapi database cache...  "
154     else
155         printf "warning: Open vSwitch is being re-installed or upgraded,\n"
156         printf "         but the xapi database cache is missing.\n"
157         printf "Re-creating xapi database cache...  "
158     fi
159
160     if /usr/share/vswitch/scripts/interface-reconfigure rewrite; then
161         printf "done.\n"
162     else
163         printf "FAILED\n"
164         printf "Open vSwitch can only be installed on a XenServer that\n"
165         printf "has connectivity to xapi on the pool master.  Please\n"
166         printf "fix connectivity to the pool master, then try again.\n"
167         exit 1
168     fi
169 fi
170
171 # Ensure that modprobe will find our modules.
172 depmod %{xen_version}
173
174 if grep -F net.ipv4.conf.all.arp_filter /etc/sysctl.conf >/dev/null 2>&1; then :; else
175     cat >>/etc/sysctl.conf <<EOF
176 # This works around an issue in xhad, which binds to a particular
177 # Ethernet device, which in turn causes ICMP port unreachable messages
178 # if packets are received are on the wrong interface, which in turn
179 # can happen if we send out ARP replies on every interface (as Linux
180 # does by default) instead of just on the interface that has the IP
181 # address being ARPed for, which this sysctl setting in turn works
182 # around.
183 #
184 # Bug #1378.
185 net.ipv4.conf.all.arp_filter = 1
186 EOF
187 fi
188
189 # Ensure ovs-vswitchd.conf exists
190 touch /etc/ovs-vswitchd.conf
191
192 # Create default or update existing /etc/sysconfig/vswitch.
193 SYSCONFIG=/etc/sysconfig/vswitch
194 TEMPLATE=/usr/share/vswitch/scripts/sysconfig.template
195 if [ ! -e $SYSCONFIG ]; then
196     cp $TEMPLATE $SYSCONFIG
197 else
198     for var in $(awk -F'[ :]' '/^# [_A-Z0-9]+:/{print $2}' $TEMPLATE)
199     do
200         if ! grep $var $SYSCONFIG >/dev/null 2>&1; then
201             echo >> $SYSCONFIG
202             sed -n "/$var:/,/$var=/p" $TEMPLATE >> $SYSCONFIG
203         fi
204     done
205 fi
206
207 # Replace XenServer files by our versions.
208 mkdir -p /usr/lib/vswitch/xs-original \
209     || printf "Could not create script backup directory.\n"
210 for f in \
211     /opt/xensource/libexec/interface-reconfigure \
212     /etc/xensource/scripts/vif \
213     /usr/sbin/xen-bugtool \
214     /usr/sbin/brctl \
215     /etc/udev/xen-backend.rules
216 do
217     s=$(basename "$f")
218     t=$(readlink "$f")
219     if [ "$t" != "/usr/share/vswitch/scripts/$s" ]; then
220         mv "$f" /usr/lib/vswitch/xs-original/ \
221             || printf "Could not save original XenServer $s script\n"
222         ln -s "/usr/share/vswitch/scripts/$s" "$f" \
223             || printf "Could not link to vSwitch $s script\n"
224     fi
225 done
226
227 # Install xsconsole plugin
228 plugin=$(readlink /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py)
229 if [ "$plugin" != "/usr/share/vswitch/scripts/XSFeatureVSwitch.py" ]; then
230     rm -f /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py
231     ln -s /usr/share/vswitch/scripts/XSFeatureVSwitch.py /usr/lib/xsconsole/plugins-base/ || printf "Could not link to vSswitch xsconsole plugin.\n"
232 fi
233
234 # Ensure all required services are set to run
235 for s in vswitch vswitch-xapi-update; do
236     if chkconfig --list $s >/dev/null 2>&1; then
237         chkconfig --del $s || printf "Could not remove $s init script."
238     fi
239     chkconfig --add $s || printf "Could not add $s init script."
240     chkconfig $s on || printf "Could not enable $s init script."
241 done
242
243 if [ "$1" = "1" ]; then    # $1 = 2 for upgrade
244     printf "\nYou MUST reboot the server NOW to complete the change to the\n"
245     printf "the vSwitch.  Attempts to modify networking on the server\n"
246     printf "or any hosted VM will fail until after the reboot and could\n"
247     printf "leave the server in an state requiring manual recovery.\n\n"
248 else
249     printf "\nTo use the new vSwitch, you should reboot the server\n"
250     printf "now.  Failure to do so may result in incorrect operation.\n\n"
251 fi
252
253 %preun
254 if [ "$1" = "0" ]; then     # $1 = 1 for upgrade
255     for s in vswitch vswitch-xapi-update; do
256         chkconfig --del $s || printf "Could not remove $s init script."
257     done
258 fi
259
260
261 %postun
262 if [ "$1" = "0" ]; then     # $1 = 1 for upgrade
263
264     rm -f /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py \
265         /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.pyc \
266         /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.pyo \
267         || printf "Could not remove vSwitch xsconsole plugin.\n"
268
269     # Restore original XenServer scripts
270     for f in \
271         /opt/xensource/libexec/interface-reconfigure \
272         /etc/xensource/scripts/vif \
273         /usr/sbin/xen-bugtool \
274         /usr/sbin/brctl \
275         /etc/udev/xen-backend.rules
276     do
277         s=$(basename "$f")
278         if [ ! -f "/usr/lib/vswitch/xs-original/$s" ]; then
279             printf "Original XenServer $s script not present in /usr/lib/vswitch/xs-original\n"
280             printf "Could not restore original XenServer script.\n"
281         else
282             (rm -f "$f" \
283                 && mv "/usr/lib/vswitch/xs-original/$s" "$f") \
284                 || printf "Could not restore original XenServer $s script.\n"
285         fi
286     done
287
288     # Remove all configuration files
289     rm -f /etc/ovs-vswitchd.conf
290     rm -f /etc/sysconfig/vswitch
291     rm -f /etc/ovs-vswitchd.cacert
292     rm -f /var/lib/openvswitch/dbcache
293
294     printf "\nYou MUST reboot the server now to complete the change to\n"
295     printf "standard Xen networking.  Attempts to modify networking on the\n"
296     printf "server or any hosted VM will fail until after the reboot and\n"
297     printf "could leave the server in a state requiring manual recovery.\n\n"
298 fi
299
300
301 %files
302 %defattr(-,root,root)
303 /etc/init.d/vswitch
304 /etc/init.d/vswitch-xapi-update
305 /etc/xapi.d/plugins/vswitch-cfg-update
306 /etc/logrotate.d/vswitch
307 /etc/profile.d/vswitch.sh
308 /lib/modules/%{xen_version}/kernel/net/vswitch/openvswitch_mod.ko
309 /lib/modules/%{xen_version}/kernel/net/vswitch/brcompat_mod.ko
310 /usr/share/vswitch/scripts/interface-reconfigure
311 /usr/share/vswitch/scripts/vif
312 /usr/share/vswitch/scripts/xen-bugtool
313 /usr/share/vswitch/scripts/XSFeatureVSwitch.py
314 /usr/share/vswitch/scripts/brctl
315 /usr/share/vswitch/scripts/sysconfig.template
316 /usr/share/vswitch/scripts/xen-backend.rules
317 # Following two files are generated automatically by rpm.  We don't
318 # really need them and they won't be used on the XenServer, but there
319 # isn't an obvious place to get rid of them since they are generated
320 # after the install script runs.  Since they are small, we just
321 # include them.
322 /usr/share/vswitch/scripts/XSFeatureVSwitch.pyc
323 /usr/share/vswitch/scripts/XSFeatureVSwitch.pyo
324 /usr/sbin/ovs-brcompatd
325 /usr/sbin/ovs-vswitchd
326 /usr/bin/ovs-appctl
327 /usr/bin/ovs-cfg-mod
328 /usr/bin/ovs-dpctl
329 /usr/bin/ovs-ofctl
330 /usr/bin/ovs-vsctl
331 /usr/share/man/man5/ovs-vswitchd.conf.5.gz
332 /usr/share/man/man8/ovs-appctl.8.gz
333 /usr/share/man/man8/ovs-brcompatd.8.gz
334 /usr/share/man/man8/ovs-cfg-mod.8.gz
335 /usr/share/man/man8/ovs-dpctl.8.gz
336 /usr/share/man/man8/ovs-ofctl.8.gz
337 /usr/share/man/man8/ovs-vsctl.8.gz
338 /usr/share/man/man8/ovs-vswitchd.8.gz
339 /var/lib/openvswitch