sync with upstream
[util-vserver.git] / util-vserver.spec
index 687035e..1b6305a 100644 (file)
@@ -1,8 +1,14 @@
-# $Id: util-vserver.spec.in 2283 2006-09-10 17:07:57Z hollow $
+# $Id: util-vserver.spec.in 2807 2008-10-30 01:59:52Z dhozac $
+
+%if "%{?_without_python:1}" != "1"
+%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
+%endif
 
 ## This package understands the following switches:
 ## --without dietlibc        ...   disable usage of dietlibc
 ## --with xalan              ...   require/use the xalan xslt processor
 
 ## This package understands the following switches:
 ## --without dietlibc        ...   disable usage of dietlibc
 ## --with xalan              ...   require/use the xalan xslt processor
+## --without doc             ...   disable doc generation
+## --with legacy             ...   enable the legacy APIs
 
 %global confdir                %_sysconfdir/vservers
 %global confdefaultdir %confdir/.defaults
 
 %global confdir                %_sysconfdir/vservers
 %global confdefaultdir %confdir/.defaults
 
 %global _localstatedir %_var
 
 
 %global _localstatedir %_var
 
+%global fullver                0.30.216-pre2883
+%global modulever 0.30.216
+%global ver            %( echo %fullver | sed 's/-.*//' )
+%global subver         %( s=`echo %fullver | grep -- - | sed 's/.*-/./'`; echo ${s:-.1} )
+
+# for module-tools
+%global module_version_varname modulever
+%global taglevel 3
 
 %{!?release_func:%global release_func() %1%{?dist}}
 
 Summary:       Linux virtual server utilities
 Name:          util-vserver
 
 %{!?release_func:%global release_func() %1%{?dist}}
 
 Summary:       Linux virtual server utilities
 Name:          util-vserver
-Version:       0.30.212
-Release:       %release_func 0
+Version:       %ver
+Release:       %taglevel
 License:       GPL
 Group:         System Environment/Base
 URL:           http://savannah.nongnu.org/projects/util-vserver/
 License:       GPL
 Group:         System Environment/Base
 URL:           http://savannah.nongnu.org/projects/util-vserver/
-Source0:       http://www.13thfloor.at/~ensc/util-vserver/files/alpha/%name-%version.tar.bz2
-#Source1:      http://www.13thfloor.at/~ensc/util-vserver/files/alpha/%name-%version.tar.bz2.asc
+Source0:       http://ftp.linux-vserver.org/pub/utils/util-vserver/%name-%fullver.tar.bz2
+Source1:       fstab
+Patch1:                f12.patch
+Patch2:                f13.patch
+Patch3:         rev2883to2896.patch
 BuildRoot:     %_tmppath/%name-%version-%release-root
 Requires:      init(%name)
 Requires:      %name-core = %version-%release
 BuildRoot:     %_tmppath/%name-%version-%release-root
 Requires:      init(%name)
 Requires:      %name-core = %version-%release
@@ -30,10 +47,14 @@ Requires:   %name-lib  = %version-%release
 Requires:      diffutils mktemp sed
 Provides:      vserver = %version-%release
 Obsoletes:     vserver < %version
 Requires:      diffutils mktemp sed
 Provides:      vserver = %version-%release
 Obsoletes:     vserver < %version
-BuildRequires: mount vconfig gawk iproute iptables
+BuildRequires: mount vconfig gawk /sbin/ip iptables
 BuildRequires: gcc-c++ wget which diffutils
 BuildRequires: gcc-c++ wget which diffutils
-BuildRequires: e2fsprogs-devel beecrypt-devel
-BuildRequires: doxygen tetex-latex
+BuildRequires: e2fsprogs-devel e2fsprogs
+%{!?_without_beecrypt:BuildRequires: beecrypt-devel}
+%{?_without_beecrypt:BuildRequires: nss-devel}
+BuildRequires: e2fsprogs
+%{!?_without_doc:BuildRequires:        doxygen tetex-latex}
+%{!?_without_python:BuildRequires: python python-devel ctags}
 Requires(post):                %name-core
 Requires(pre):         %pkglibdir
 Requires(postun):      %pkglibdir
 Requires(post):                %name-core
 Requires(pre):         %pkglibdir
 Requires(postun):      %pkglibdir
@@ -52,7 +73,7 @@ Requires:             util-linux
 %package build
 Summary:               Tools which can be used to build vservers
 Group:                 Applications/System
 %package build
 Summary:               Tools which can be used to build vservers
 Group:                 Applications/System
-Requires:              rpm wget binutils tar e2fsprogs
+Requires:              rpm wget binutils tar
 Requires:              %name = %version-%release
 Requires(pre):         %confdir
 Requires(postun):      %confdir
 Requires:              %name = %version-%release
 Requires(pre):         %confdir
 Requires(postun):      %confdir
@@ -85,6 +106,11 @@ Group:                      Development/Libraries
 Requires:              pkgconfig
 Requires:              %name-lib = %version-%release
 
 Requires:              pkgconfig
 Requires:              %name-lib = %version-%release
 
+%package python
+Summary:               Python bindings to develop vserver-based applications
+Group:                 Development/Libraries
+Requires:              %name-lib = %version-%release
+
 
 %description
 util-vserver provides the components and a framework to setup virtual
 
 %description
 util-vserver provides the components and a framework to setup virtual
@@ -158,17 +184,33 @@ can't interact with services in the main server.
 This package contains header files and libraries which are needed to
 develop VServer related applications.
 
 This package contains header files and libraries which are needed to
 develop VServer related applications.
 
+%description python
+util-vserver provides the components and a framework to setup virtual
+servers.  A virtual server runs inside a linux server. It is nevertheless
+highly independent. As such, you can run various services with normal
+configuration. The various vservers can't interact with each other and
+can't interact with services in the main server.
+
+This package contains the files needed to interface with the
+Linux-VServer API from Python.
 
 
-%prep
-%setup -q
 
 
+%prep
+%setup -q -n %name-%fullver
+%patch1 -p0
+%patch2 -p1
+%patch2 -p0
+autoreconf -fi
 
 %build
 %configure --with-initrddir=%_initrddir --enable-release \
 
 %build
 %configure --with-initrddir=%_initrddir --enable-release \
-           %{?_without_dietlibc:--disable-dietlibc}
+           %{?_without_dietlibc:--disable-dietlibc} \
+           %{?_with_legacy:--enable-apis=NOLEGACY} \
+           --with-initscripts=sysv \
+           %{?_without_python:--without-python}
 
 %__make %{?_smp_mflags} all
 
 %__make %{?_smp_mflags} all
-%__make %{?_smp_mflags} doc
+%{!?_without_doc:%__make %{?_smp_mflags} doc}
 
 
 %install
 
 
 %install
@@ -181,8 +223,9 @@ MANIFEST_CONFIG='%config' \
 MANIFEST_CONFIG_NOREPLACE='%config(noreplace)' \
 contrib/make-manifest %name $RPM_BUILD_ROOT contrib/manifest.dat
 
 MANIFEST_CONFIG_NOREPLACE='%config(noreplace)' \
 contrib/make-manifest %name $RPM_BUILD_ROOT contrib/manifest.dat
 
+install -c -m 755 %{SOURCE1} %{buildroot}/%pkglibdir/defaults/fstab
 
 
-%check || :
+%check
 %__make check
 
 
 %__make check
 
 
@@ -212,14 +255,15 @@ test "$1" != 0 || rm -rf %_localstatedir/cache/vservers/* 2>/dev/null || :
 %post sysv
 %chkconfig --add vservers-default
 %chkconfig --add vprocunhide
 %post sysv
 %chkconfig --add vservers-default
 %chkconfig --add vprocunhide
-
-
+%chkconfig --add util-vserver
+%chkconfig util-vserver on
 
 %preun sysv
 test "$1" != 0 || %_initrddir/vprocunhide stop &>/dev/null || :
 
 test "$1" != 0 || %chkconfig --del vprocunhide
 test "$1" != 0 || %chkconfig --del vservers-default
 
 %preun sysv
 test "$1" != 0 || %_initrddir/vprocunhide stop &>/dev/null || :
 
 test "$1" != 0 || %chkconfig --del vprocunhide
 test "$1" != 0 || %chkconfig --del vservers-default
+test "$1" != 0 || %chkconfig --del util-vserver
 
 
 %postun sysv
 
 
 %postun sysv
@@ -244,6 +288,11 @@ copy fedora /etc/pki/rpm-gpg/RPM-GPG-*
 copy centos /usr/share/doc/centos-*/RPM-GPG-KEY-*
 
 
 copy centos /usr/share/doc/centos-*/RPM-GPG-KEY-*
 
 
+%pre build
+x="%_libdir/util-vserver/distributions/etch"
+test -d "$x" && mv "$x" "$x.rpmsave" || :
+
+
 %post build
 test -d /vservers/.hash || mkdir -m0700 /vservers/.hash
 
 %post build
 test -d /vservers/.hash || mkdir -m0700 /vservers/.hash
 
@@ -339,11 +388,32 @@ test "$1" = 0  || %_initrddir/rebootmgr   condrestart >/dev/null || :
 
 %files devel -f %name-devel.list
 %defattr(-,root,root,-)
 
 %files devel -f %name-devel.list
 %defattr(-,root,root,-)
-%doc lib/apidoc/latex/refman.pdf
-%doc lib/apidoc/html
+%{!?_without_doc:%doc lib/apidoc/latex/refman.pdf}
+%{!?_without_doc:%doc lib/apidoc/html}
+
+
+%files python
+%defattr(-,root,root,-)
+%{!?_without_python:%{python_sitearch}/*}
 
 
 %changelog
 
 
 %changelog
+* Tue Jun 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-0.30.216-3
+- Do not restart util-vserver service on upgrades
+
+* Tue Jun 01 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-0.30.216-2
+- remove tmpfs mounted /tmp from fstab template
+
+* Tue May 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-0.30.216-1
+
+* Mon Jun 25 2007 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.30.214-0
+- updated URLs
+- get rid of e2fsprogs requirement
+
+* Fri Dec 29 2006 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.30.213-0
+- add --with legacy and --without doc switches
+- add util-vserver initscript
+
 * Sun Jan 22 2006 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.30.210-0
 - do not require 'xalan' anymore by default
 - removed 'Requires: apt'; apt-rpm is not maintained upstream anymore
 * Sun Jan 22 2006 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.30.210-0
 - do not require 'xalan' anymore by default
 - removed 'Requires: apt'; apt-rpm is not maintained upstream anymore