use cached values more consistently.
[monitor.git] / Monitor.spec
index 3c2a2d6..9ddfcb1 100644 (file)
@@ -6,7 +6,7 @@
 
 %define name monitor
 %define version 2.0
-%define taglevel 8
+%define taglevel 9
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -79,7 +79,12 @@ as Zabbix DB.
 %package pcucontrol
 summary: pcu controls for monitor and plcapi
 group: applications/system
-requires: python
+Requires: python
+Requires: OpenIPMI-tools
+Requires: openssh-clients
+Requires: perl-libwww-perl
+Requires: perl-IO-Socket-SSL 
+Requires: curl
 
 %description pcucontrol
 both monitor and the plcapi use a set of common commands to reboot machines
@@ -216,6 +221,11 @@ chkconfig --add monitor-runlevelagent
 chkconfig monitor-runlevelagent on
 
 %changelog
+* Fri Apr 03 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-9
+- added new models to db.
+- major updates throughout.
+- better unification. needs an install test.
+
 * Wed Apr 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-8
 - removed old pkl database references.
 - added blacklist to db model