manually fix taglevel
[nodemanager.git] / NodeManager.spec
index 5764ab1..08aaab3 100644 (file)
@@ -7,7 +7,7 @@
 
 %define name NodeManager
 %define version 2.0
-%define taglevel 5
+%define taglevel 18
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -28,25 +28,21 @@ URL: %(echo %{url} | cut -d ' ' -f 2)
 # not possible because of forward_api_calls
 #BuildArch: noarch
 
-# Old Node Manager
-Obsoletes: sidewinder, sidewinder-common
+# old name
+#Obsoletes: sidewinder, sidewinder-common
 
+# Uses function decorators
+Requires: python >= 2.4
+# connecting PLC
+Requires: python-pycurl
+# Signed tickets
+Requires: gnupg
 # vuseradd, vuserdel
 Requires: vserver-%{slicefamily}
+# our interface to the vserver patch
 Requires: util-vserver >= 0.30.208-17
-
 # vserver.py
 Requires: util-vserver-python > 0.3-16
-
-# Signed tickets
-Requires: gnupg
-
-# Contact API server
-Requires: curl
-
-# Uses function decorators
-Requires: python >= 2.4
-
 # sioc/plnet
 Requires: pyplnet >= 4.3
 
@@ -69,13 +65,42 @@ local operations on slices.
 rm -rf $RPM_BUILD_ROOT
 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
 
+# install the sliver initscript (that triggers the slice initscript if any)
+mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
+rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
+chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
+
 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
 
-install -D -m 644 logrotate/nm $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
+install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
 
+install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
+
+##########
 %post
+# tmp - handle file renamings; old names are from 2.0-8
+renamings="
+/var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
+/root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
+/var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
+/var/log/nm@/var/log/nodemanager
+/var/log/nm.daemon@/var/log/nodemanager.daemon
+/var/run/nm.pid@/var/run/nodemanager.pid
+/tmp/sliver_mgr.api@/tmp/nodemanager.api
+/etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
+"
+for renaming in $renamings; do
+  old=$(echo $renaming | cut -d@ -f1)
+  new=$(echo $renaming | cut -d@ -f2)
+  newdir=$(dirname $new)
+  if [ -e "$old" -a ! -e "$new" ] ; then
+      mkdir -p $newdir
+      mv -f $old $new
+  fi
+done
+#
 chkconfig --add conf_files
 chkconfig conf_files on
 chkconfig --add nm
@@ -87,7 +112,7 @@ if [ "$PL_BOOTCD" != "1" ] ; then
        service fuse-pl restart
 fi
 
-
+##########
 %preun
 # 0 = erase, 1 = upgrade
 if [ $1 -eq 0 ] ; then
@@ -107,9 +132,71 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/NodeManager/
 %{_bindir}/forward_api_calls
 %{_initrddir}/
-%{_sysconfdir}/logrotate.d/nm
+%{_sysconfdir}/logrotate.d/nodemanager
+/var/lib/
 
 %changelog
+* Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
+- revert curlwrapper to former forking-curl version
+- fixes in the omf plugin for ssh key location and node hrn
+- set umask 0022 in tools.daemon
+
+* Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
+- configure omf-resctl for keys
+
+* Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
+- fix key generation
+
+* Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
+- name changes and fix typos
+
+* Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
+- remove config and options parameters from start function
+
+* Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
+- working version of reservable nodes
+- sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
+- dismantled the -s|--startup option (no convincing need for that)
+- simpler and more robust init.d/nm
+- initscript content management through replace_file_with_string
+- sliverauth uses replace_file_with_string
+- curlwrapper has a debug mode
+
+* Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
+- pretty-printing/normalized python code - hopefully neutral
+
+* Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
+- (1) unconditionnally install and chkconfig-like a generic 'vinit' service
+- that triggers /etc/init.d/vinit.slice if present and executable
+- (2) install the slice-provided initscript (as per the initscript tag) as
+- /etc/init.d/vinit.slice
+- (3) as a result the initscript are now triggered by rc as part of the
+- standard vserver .. start, properly attached to the vserver,
+- and properly killed upon vserver .. stop
+- (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
+
+* Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
+- fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
+- basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
+- plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
+- cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
+- cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
+- cleanup: nodemanger now is a class; however plugins are still dumb modules
+- cleanup: does not depend on obsolete Set
+
+* Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
+- tagging before RC
+
+* Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
+- Fix typos in plugins/drl.py and doc/NMAPI.xml.in
+- Added some precautions to the slice id-saving code
+- Added log message to code that records the slice id
+
+* Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
+- This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
+- of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
+- to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
+
 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
 - fix log_call in plugins/drl.py