more renamings
[nodemanager.git] / NodeManager.spec
index d8246f9..444706e 100644 (file)
@@ -7,7 +7,7 @@
 
 %define name NodeManager
 %define version 2.0
-%define taglevel 0
+%define taglevel 8
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -28,25 +28,21 @@ URL: %(echo %{url} | cut -d ' ' -f 2)
 # not possible because of forward_api_calls
 #BuildArch: noarch
 
-# Old Node Manager
-Obsoletes: sidewinder, sidewinder-common
+# old name
+#Obsoletes: sidewinder, sidewinder-common
 
+# Uses function decorators
+Requires: python >= 2.4
+# connecting PLC
+Requires: python-pycurl
+# Signed tickets
+Requires: gnupg
 # vuseradd, vuserdel
 Requires: vserver-%{slicefamily}
+# our interface to the vserver patch
 Requires: util-vserver >= 0.30.208-17
-
 # vserver.py
 Requires: util-vserver-python > 0.3-16
-
-# Signed tickets
-Requires: gnupg
-
-# Contact API server
-Requires: curl
-
-# Uses function decorators
-Requires: python >= 2.4
-
 # sioc/plnet
 Requires: pyplnet >= 4.3
 
@@ -73,9 +69,33 @@ mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
 
-install -D -m 644 logrotate/nm $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
+install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
 
+install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
+
+##########
 %post
+# tmp - handle file renamings; old names are from 2.0-8
+renamings="
+/var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.dat
+/root/sliver_mgr_db.pickle@/var/lib/nodemanager/nodemanager.pickle
+/var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
+/var/log/nm@/var/log/nodemanager
+/var/log/nm.daemon@/var/log/nodemanager.daemon
+/var/run/nm.pid@/var/run/nodemanager.pid
+/tmp/sliver_mgr.api@/tmp/nodemanager.api
+/etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
+"
+for renaming in $renamings; do
+  old=$(echo $renaming | cut -d@ -f1)
+  new=$(echo $renaming | cut -d@ -f2)
+  newdir=$(dirname $new)
+  if [ -e "$old" -a ! -e "$new" ] ; then
+      mkdir -p $newdir
+      mv -f $old $new
+  fi
+done
+#
 chkconfig --add conf_files
 chkconfig conf_files on
 chkconfig --add nm
@@ -87,7 +107,7 @@ if [ "$PL_BOOTCD" != "1" ] ; then
        service fuse-pl restart
 fi
 
-
+##########
 %preun
 # 0 = erase, 1 = upgrade
 if [ $1 -eq 0 ] ; then
@@ -107,9 +127,54 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/NodeManager/
 %{_bindir}/forward_api_calls
 %{_initrddir}/
-%{_sysconfdir}/logrotate.d/nm
+%{_sysconfdir}/logrotate.d/nodemanager
+/var/lib/
 
 %changelog
+* Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
+- tagging before RC
+
+* Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
+- Fix typos in plugins/drl.py and doc/NMAPI.xml.in
+- Added some precautions to the slice id-saving code
+- Added log message to code that records the slice id
+
+* Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
+- This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
+- of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
+- to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
+
+* Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
+- fix log_call in plugins/drl.py
+
+* Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
+- protect against nodes in migrated PLC's not having the hrn tag yet
+
+* Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
+- new omf-resctl and drl plugins
+- specialaccount optimized to overwrite authorized keys only upon changes
+- codemux plugin has support for a new 'ip' setting
+- mainloop to display ordered modules&plugins at all times
+
+* Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
+- modules and plugins have a priority
+- specialaccounts appears soon in the priority chain
+- logger.log_call logs process output, and has a timeout
+- vuser{add,del} run through bash -x
+- nm initscript has support for 'service nm restartverbose'
+- logs reviewed for consistency
+- use hashlib module instead of sha when available
+
+* Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
+- first working version of 5.0:
+- pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
+- nodefamily is 3-fold with pldistro-fcdistro-arch
+- relies on GetSlivers to expose 'GetSliceFamily' for slivers
+- (in addition to the 'vref' tag that's still exposed too)
+- logging reviewed for more convenience
+- support for 'service nm restartdebug'
+- make sync knows how to publish uncommitted code on a test node
+
 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
 - emergency tag - make the setting of hmac by the sliverauth plugin more robust