Tagging module NodeManager - NodeManager-1.7-26
[nodemanager.git] / NodeManager.spec
index 7979d2e..49b74b7 100644 (file)
@@ -7,7 +7,7 @@
 
 %define name NodeManager
 %define version 1.7
-%define taglevel 10
+%define taglevel 26
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -62,6 +62,7 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
 
 install -D -m 755 conf_files.init $RPM_BUILD_ROOT/%{_initrddir}/conf_files
+install -D -m 755 fuse-pl.init $RPM_BUILD_ROOT/%{_initrddir}/fuse-pl
 install -D -m 755 nm.init $RPM_BUILD_ROOT/%{_initrddir}/nm
 install -D -m 644 nm.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
 
@@ -70,14 +71,19 @@ chkconfig --add conf_files
 chkconfig conf_files on
 chkconfig --add nm
 chkconfig nm on
+chkconfig --add fuse-pl
+chkconfig fuse-pl on
 if [ "$PL_BOOTCD" != "1" ] ; then
        service nm restart
+       service fuse-pl restart
 fi
 
 
 %preun
 # 0 = erase, 1 = upgrade
 if [ $1 -eq 0 ] ; then
+    chkconfig fuse-pl off
+    chkconfig --del fuse-pl
     chkconfig nm off
     chkconfig --del nm
     chkconfig conf_files off
@@ -95,9 +101,76 @@ rm -rf $RPM_BUILD_ROOT
 %{_bindir}/forward_api_calls
 %{_initrddir}/nm
 %{_initrddir}/conf_files
+%{_initrddir}/fuse-pl
 %{_sysconfdir}/logrotate.d/nm
 
 %changelog
+* Sun Aug 17 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-26
+- FUSE support.
+
+* Wed Aug 13 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-25
+- Removed thread created for each sliver (!!!).
+- Slivers now spawned out of main thread.
+- This closes the Delegation bug and closes the recent rash of NM instabilities due to queue overflows. [ticket: 384]
+
+* Fri Aug 01 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-24
+- * Update bandwidth related attributes on every NM sync.  Bwlimit will check if values have changed.
+- * Vsys supports local_ scripts and NM will disregard them.
+
+* Mon Jul 28 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-23
+- After removing the fork() to the slice's uid when writing .ssh/authorized_keys, .ssh had the wrong owner/group.  Fixed.
+
+* Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-22
+- Small change.  Change uid to slice owner of authorized_keys.
+
+* Wed Jul 23 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-21
+- Slices with initscripts kept restarting.  Fixed.
+- Also removed unnecessary fork just to write .ssh/authorized keys for every slice.
+
+* Tue Jul 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-20
+- * Check slice is_running() every cycle.  If not, assume damaged and restart.
+
+* Mon Jul 07 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-19
+- chrooting is not thread-safe.
+
+* Fri Jun 27 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-18
+- Log disk init AFTER acquiring disk semaphore.
+
+* Wed Jun 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-17
+- unconditionnally passes node_id and slicefamily to conf_file scripts
+- correctly set personality a sliver creation time (not yet used by util-vserver-pl though)
+
+* Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-16
+- 
+- enables a vsys slice attribute to end with 'a', 'c', or 'l' characters without
+- NM going bonkers.
+- 
+
+* Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-15
+- 
+- enable restart if vsys.conf changes also.
+- 
+
+* Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-14
+- 
+- the _restart flag for vsys was getting lost when looking across multiple
+- vservers.  adding the 'or' should preserve any 'True' returns from
+- createVsysDir()
+- 
+
+* Tue Jun 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-13
+- 
+- Time out curl when no response for 90 seconds.
+- 
+
+* Fri Jun 13 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-12
+- Patch designed to work around the vsys-fail-to-restart problem with
+- non-existent directories, and the vuseradd-fail-to-work on directories that
+- do exist.  
+- 
+- This patch will work in conjunction with the new vsys patch.
+- 
+
 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-10
 - fixed doc build by locating locally installed DTDs at build-time