passes slicefamily unconditionnaly, as for node_id
[nodemanager.git] / NodeManager.spec
index c5f2f40..7bc2e5a 100644 (file)
@@ -1,19 +1,36 @@
+#
+# $Id$
+#
+%define url $URL$
+
+%define slicefamily %{pldistro}-%{distroname}-%{_arch}
+
+%define name NodeManager
+%define version 1.7
+%define taglevel 16
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+
 Summary: PlanetLab Node Manager
-Name: NodeManager
-Version: 1.1
-Release: 1%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+Name: %{name}
+Version: %{version}
+Release: %{release}
 License: PlanetLab
 Group: System Environment/Daemons
-URL: http://cvs.planet-lab.org/cvs/NodeManager
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
+Vendor: PlanetLab
+Packager: PlanetLab Central <support@planet-lab.org>
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
+
 # Old Node Manager
 Obsoletes: sidewinder, sidewinder-common
 
 # vuseradd, vuserdel
-Requires: vserver-reference
-Requires: util-vserver
+Requires: vserver-%{slicefamily}
+Requires: util-vserver >= 0.30.208-17
 
 # vserver.py
 Requires: util-vserver-python
@@ -53,6 +70,10 @@ chkconfig --add conf_files
 chkconfig conf_files on
 chkconfig --add nm
 chkconfig nm on
+if [ "$PL_BOOTCD" != "1" ] ; then
+       service nm restart
+fi
+
 
 %preun
 # 0 = erase, 1 = upgrade
@@ -77,5 +98,78 @@ rm -rf $RPM_BUILD_ROOT
 %{_sysconfdir}/logrotate.d/nm
 
 %changelog
+* Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-16
+- 
+- enables a vsys slice attribute to end with 'a', 'c', or 'l' characters without
+- NM going bonkers.
+- 
+
+* Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-15
+- 
+- enable restart if vsys.conf changes also.
+- 
+
+* Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-14
+- 
+- the _restart flag for vsys was getting lost when looking across multiple
+- vservers.  adding the 'or' should preserve any 'True' returns from
+- createVsysDir()
+- 
+
+* Tue Jun 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-13
+- 
+- Time out curl when no response for 90 seconds.
+- 
+
+* Fri Jun 13 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-12
+- Patch designed to work around the vsys-fail-to-restart problem with
+- non-existent directories, and the vuseradd-fail-to-work on directories that
+- do exist.  
+- 
+- This patch will work in conjunction with the new vsys patch.
+- 
+
+* Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-10
+- fixed doc build by locating locally installed DTDs at build-time
+
+* Fri May 09 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-9
+- * Reverted vserver start to forking before VServer.start to avoid defunct procs.* House keeping in various places.
+
+* Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-8
+- merge changes for myplc-docs from trunk
+
+* Wed Apr 16 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-7
+- 
+- Set vcVHI_CONTEXT as slice_id for fprobe-ulog to mark packets with.
+- 
+
+* Wed Apr 09 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-5 NodeManager-1.7-6
+- 
+- * Codemux will use PLC_API_HOST when PLC_PLANETFLOW_HOST isn't defined.
+- 
+
+* Fri Apr 04 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-4 NodeManager-1.7-5
+- * vdu limitting when NM restarts and slices are re-init'ed
+- * CoDemux config parser update.  Now tolerates spaces.
+
+* Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
+- Codemux supports multiple hosts mapping to single slice
+- Fixed bug in delegation support where tickets delivered weren't
+  being passed to sm.deliver_ticket().
+* Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
+- Codemux now configured via slice attribute (host,port)
+- Support for multiple vserver reference images (including different archs)
+- Mom BW emails are sent to list defined by MyPLC's config
+- Sirius BW loans honored correctly.  Fixed.
+- BW totals preserved for dynamic slices so as not to game the system.
+* Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
+- Configures vsys via vsys slice attribute {name: vsys, value: script}
+- CPU reservations are now calculated via percentages instead of shares
+- BW totals preserved for dynamic slices
+- Closes bug where node cap sets off bw slice alarms for all slices.
+
+* Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
+- Switched to SVN.
+
 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
 - Initial build.