initscripts are now triggered through rc via a generic /etc/init.d/vinit
[nodemanager.git] / NodeManager.spec
index d58342c..be9e623 100644 (file)
@@ -7,7 +7,7 @@
 
 %define name NodeManager
 %define version 2.0
-%define taglevel 8
+%define taglevel 9
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -28,22 +28,21 @@ URL: %(echo %{url} | cut -d ' ' -f 2)
 # not possible because of forward_api_calls
 #BuildArch: noarch
 
-# Old Node Manager
-Obsoletes: sidewinder, sidewinder-common
+# old name
+#Obsoletes: sidewinder, sidewinder-common
 
+# Uses function decorators
+Requires: python >= 2.4
+# connecting PLC
+Requires: python-pycurl
+# Signed tickets
+Requires: gnupg
 # vuseradd, vuserdel
 Requires: vserver-%{slicefamily}
+# our interface to the vserver patch
 Requires: util-vserver >= 0.30.208-17
-
 # vserver.py
 Requires: util-vserver-python > 0.3-16
-
-# Signed tickets
-Requires: gnupg
-
-# Uses function decorators
-Requires: python >= 2.4
-
 # sioc/plnet
 Requires: pyplnet >= 4.3
 
@@ -66,6 +65,11 @@ local operations on slices.
 rm -rf $RPM_BUILD_ROOT
 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
 
+# install the sliver initscript (that triggers the slice initscript if any)
+mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
+rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
+chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
+
 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
@@ -78,8 +82,8 @@ install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate
 %post
 # tmp - handle file renamings; old names are from 2.0-8
 renamings="
-/var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.dat
-/root/sliver_mgr_db.pickle@/var/lib/nodemanager/nodemanager.pickle
+/var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
+/root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
 /var/log/nm@/var/log/nodemanager
 /var/log/nm.daemon@/var/log/nodemanager.daemon
@@ -132,6 +136,15 @@ rm -rf $RPM_BUILD_ROOT
 /var/lib/
 
 %changelog
+* Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
+- fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
+- basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
+- plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
+- cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
+- cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
+- cleanup: nodemanger now is a class; however plugins are still dumb modules
+- cleanup: does not depend on obsolete Set
+
 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
 - tagging before RC