- raise an xmlrpclib.Fault on any exception while parsing/delivering ticket
[nodemanager.git] / NodeManager.spec
index e025afa..c5f2f40 100644 (file)
@@ -44,9 +44,25 @@ local operations on slices.
 rm -rf $RPM_BUILD_ROOT
 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
 
+install -D -m 755 conf_files.init $RPM_BUILD_ROOT/%{_initrddir}/conf_files
 install -D -m 755 nm.init $RPM_BUILD_ROOT/%{_initrddir}/nm
 install -D -m 644 nm.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
 
+%post
+chkconfig --add conf_files
+chkconfig conf_files on
+chkconfig --add nm
+chkconfig nm on
+
+%preun
+# 0 = erase, 1 = upgrade
+if [ $1 -eq 0 ] ; then
+    chkconfig nm off
+    chkconfig --del nm
+    chkconfig conf_files off
+    chkconfig --del conf_files
+fi
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -57,6 +73,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/NodeManager/*
 %{_bindir}/forward_api_calls
 %{_initrddir}/nm
+%{_initrddir}/conf_files
 %{_sysconfdir}/logrotate.d/nm
 
 %changelog