Change default CPU share from 32 to 1
[nodemanager.git] / NodeManager.spec
index cbf5278..eb074f0 100644 (file)
@@ -1,19 +1,34 @@
+#
+# $Id$
+#
+%define url $URL$
+
+%define name NodeManager
+%define version 1.7
+%define taglevel 1
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+
 Summary: PlanetLab Node Manager
-Name: NodeManager
-Version: 1.1
-Release: 4%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+Name: %{name}
+Version: %{version}
+Release: %{release}
 License: PlanetLab
 Group: System Environment/Daemons
-URL: http://cvs.planet-lab.org/cvs/NodeManager
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
+Vendor: PlanetLab
+Packager: PlanetLab Central <support@planet-lab.org>
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
+
 # Old Node Manager
 Obsoletes: sidewinder, sidewinder-common
 
 # vuseradd, vuserdel
 Requires: vserver-reference
-Requires: util-vserver
+Requires: util-vserver >= 0.30.208-17
 
 # vserver.py
 Requires: util-vserver-python
@@ -53,6 +68,10 @@ chkconfig --add conf_files
 chkconfig conf_files on
 chkconfig --add nm
 chkconfig nm on
+if [ "$PL_BOOTCD" != "1" ] ; then
+       service nm restart
+fi
+
 
 %preun
 # 0 = erase, 1 = upgrade
@@ -77,5 +96,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_sysconfdir}/logrotate.d/nm
 
 %changelog
+* Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
+- Switched to SVN.
+
 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
 - Initial build.