Use mtools to build USB images, no more loop-mounts here, woohoo!
[bootcd.git] / bootcd.spec
index 309e3ef..05279bb 100644 (file)
@@ -1,11 +1,11 @@
 %define name bootcd
-%define version 3.3
+%define version 3.4
 %define release 2%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 3.3
-URL: http://cvs.planet-lab.org/cvs/bootcd_v3
+Distribution: PlanetLab 4.0
+URL: http://cvs.planet-lab.org/cvs/bootcd
 
 Summary: Boot CD
 Name: bootcd
@@ -16,7 +16,7 @@ Group: System Environment/Base
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
-Requires: dosfstools, mkisofs, gzip
+Requires: dosfstools, mkisofs, gzip, mtools
 
 AutoReqProv: no
 %define debug_package %{nil}
@@ -37,10 +37,10 @@ Central servers.
 %setup -q
 
 %build
-pushd bootcd_v3
+pushd BootCD
 
 # Build the reference image
-./prep.sh
+./prep.sh %{pldistro}
 
 # Build the default configuration (PlanetLab)
 ./build.sh
@@ -53,20 +53,21 @@ popd
 %install
 rm -rf $RPM_BUILD_ROOT
 
-pushd bootcd_v3
+pushd  BootCD
 
 # Install the reference image and build scripts
 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
-find \
+tar cpf - \
     build/isofs/bootcd.img \
     build/isofs/isolinux.bin \
     build/isofs/kernel \
     build/passwd \
     build/version.txt \
+       bootcustom.sh \
     configurations \
     syslinux/unix/syslinux | \
-    cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/
+    tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
 
 # Install the default images in the download/ directory
 install -d -m 755 $RPM_BUILD_ROOT/var/www/html/download
@@ -81,12 +82,12 @@ rm -rf $RPM_BUILD_ROOT
 # If run under sudo
 if [ -n "$SUDO_USER" ] ; then
     # Allow user to delete the build directory
-    chown -R $SUDO_USER .
+    chown -h -R $SUDO_USER .
     # Some temporary cdroot files like /var/empty/sshd and
     # /usr/bin/sudo get created with non-readable permissions.
     find . -not -perm +0600 -exec chmod u+rw {} \;
     # Allow user to delete the built RPM(s)
-    chown -R $SUDO_USER %{_rpmdir}/%{_arch}
+    chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
 fi
 
 %post planetlab