Use mtools to build USB images, no more loop-mounts here, woohoo!
[bootcd.git] / bootcd.spec
index 3a87e3f..05279bb 100644 (file)
@@ -16,7 +16,7 @@ Group: System Environment/Base
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
-Requires: dosfstools, mkisofs, gzip
+Requires: dosfstools, mkisofs, gzip, mtools
 
 AutoReqProv: no
 %define debug_package %{nil}
@@ -37,10 +37,10 @@ Central servers.
 %setup -q
 
 %build
-pushd bootcd
+pushd BootCD
 
 # Build the reference image
-./prep.sh -a $(uname -i) -r $([ -f "/etc/fedora-release" ] && awk ' { print $4 } ' /etc/fedora-release || echo 4)
+./prep.sh %{pldistro}
 
 # Build the default configuration (PlanetLab)
 ./build.sh
@@ -53,7 +53,7 @@ popd
 %install
 rm -rf $RPM_BUILD_ROOT
 
-pushd bootcd
+pushd  BootCD
 
 # Install the reference image and build scripts
 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}