Use mtools to build USB images, no more loop-mounts here, woohoo!
[bootcd.git] / bootcd.spec
index a5adc8c..05279bb 100644 (file)
@@ -1,10 +1,10 @@
 %define name bootcd
-%define version 3.3
+%define version 3.4
 %define release 2%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 3.3
+Distribution: PlanetLab 4.0
 URL: http://cvs.planet-lab.org/cvs/bootcd
 
 Summary: Boot CD
@@ -16,7 +16,7 @@ Group: System Environment/Base
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
-Requires: dosfstools, mkisofs, gzip
+Requires: dosfstools, mkisofs, gzip, mtools
 
 AutoReqProv: no
 %define debug_package %{nil}
@@ -37,10 +37,10 @@ Central servers.
 %setup -q
 
 %build
-pushd bootcd
+pushd BootCD
 
 # Build the reference image
-./prep.sh -r $([ -f "/etc/fedora-release" ] && awk ' { print $4 } ' /etc/fedora-release || echo 4)
+./prep.sh %{pldistro}
 
 # Build the default configuration (PlanetLab)
 ./build.sh
@@ -53,7 +53,7 @@ popd
 %install
 rm -rf $RPM_BUILD_ROOT
 
-pushd bootcd
+pushd  BootCD
 
 # Install the reference image and build scripts
 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}