install systemd files in bootcd
[bootcd.git] / bootcd.spec
index dc5734d..23c1550 100644 (file)
@@ -3,7 +3,7 @@
 
 %define name bootcd-%{nodefamily}
 %define version 5.0
-%define taglevel 9
+%define taglevel 11
 
 # pldistro already in the rpm name
 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -32,6 +32,11 @@ BuildArch: noarch
 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
 # yumdownloader is needed in bootcd-kernel
 Requires: yum-utils
+# mkdiskimage is used for USB-partitioned mode
+# but it now comes in a separate rpm
+%if "%{distro}" == "Fedora" && "%{distrorelease}" >= 14
+Requires: syslinux-perl
+%endif
 
 Requires: pyplnet
 
@@ -95,6 +100,12 @@ tar cpf - \
 for script in bootcd bootcd-kernel; do 
     install -D -m 755 plc.d/$script $RPM_BUILD_ROOT/etc/plc.d/$script
 done
+
+#systemd files
+mkdir -p /lib/systemd/system
+mkdir -p /etc/systemd/system
+cp -pr systemd/* /lib/systemd/system
+ln -sf /lib/systemd/system/pl_boot.target /etc/systemd/system/default.target
 popd
     
 %clean
@@ -107,8 +118,17 @@ rm -rf $RPM_BUILD_ROOT
 %files -n bootcd-initscripts
 %defattr(-,root,root,-)
 /etc/plc.d
+/lib/systemd/system
+/etc/systemd/system
 
 %changelog
+* Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-11
+- add requires: to syslinux-perl on fedora14
+
+* Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-10
+- blacklisted mdules
+- requires yum-utils for yumdownloader in bootcd-kernel
+
 * Mon Feb 21 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-5.0-9
 - Handle /dev/rtc name change for newer kernels