check consistency of specfiles:
[bootcd.git] / bootcd.spec
index 2fe18ef..3004c7e 100644 (file)
@@ -3,18 +3,22 @@
 #
 %define url $URL$
 
-%define name bootcd
-%define version 3.4
+%define nodefamily %{pldistro}-%{_arch}
+
+%define name bootcd-%{nodefamily}
+%define version 4.2
 %define taglevel 2
 
-%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+# pldistro already in the rpm name
+#%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define release %{taglevel}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
 URL: %(echo %{url} | cut -d ' ' -f 2)
 
-Summary: Boot CD
+Summary: Boot CD material for %{nodefamily}
 Name: %{name}
 Version: %{version}
 Release: %{release}
@@ -22,6 +26,8 @@ License: BSD
 Group: System Environment/Base
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+# other archs must be able to install this
+BuildArch: noarch
 
 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
 
@@ -39,7 +45,7 @@ environment.
 pushd BootCD
 
 # Build the reference image
-./prep.sh %{pldistro}
+./prep.sh %{pldistro} %{nodefamily}
 
 popd
 
@@ -56,7 +62,7 @@ tar cpf - \
     build/isofs/kernel \
     build/passwd \
     build/version.txt \
-       bootcustom.sh \
+    build/nodefamily \
     configurations | \
     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
 
@@ -80,10 +86,38 @@ fi
 %defattr(-,root,root,-)
 %{_datadir}/%{name}
 
+%post
+[ -f /etc/planetlab/nodefamily ] || { mkdir -p /etc/planetlab ; echo %{nodefamily} > /etc/planetlab/nodefamily ; }
+
 %changelog
+* Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-2
+- change location of nodefamily in /etc/planetlab/
+
+* Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
+- new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
+- now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7) 
+- nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
+
+* Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
+- kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
+- build.sh cleaned up in the process
+- actual location of selected node config file displayed
+- import pypci rather than pypciscan
+
+* Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
+- build.sh support for -s <console_spec> (recommended vs using type)
+- build.sh cleanup - usage clearer wrt types - removed old code
+- fixed modprobe with args in pl_hwinit
+
+* Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
+- load floppy with modprobe flags
+- support for creating a usb partition
+- removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
+
 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
 - added biginitrd usb image
 
 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
 - Initial build.
 
+%define module_current_branch 3.4