this mostly undoes changeset http://svn.planet-lab.org/changeset/6958
[bootcd.git] / bootcd.spec
index 47ad2e2..78d2cbb 100644 (file)
@@ -1,10 +1,10 @@
 %define name bootcd
-%define version 3.3
+%define version 3.4
 %define release 2%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 3.3
+Distribution: PlanetLab 4.0
 URL: http://cvs.planet-lab.org/cvs/bootcd
 
 Summary: Boot CD
@@ -37,10 +37,10 @@ Central servers.
 %setup -q
 
 %build
-pushd bootcd
+pushd BootCD
 
 # Build the reference image
-./prep.sh -r $([ -f "/etc/fedora-release" ] && awk ' { print $4 } ' /etc/fedora-release || echo 4)
+./prep.sh %{pldistro}
 
 # Build the default configuration (PlanetLab)
 ./build.sh
@@ -53,7 +53,7 @@ popd
 %install
 rm -rf $RPM_BUILD_ROOT
 
-pushd bootcd
+pushd  BootCD
 
 # Install the reference image and build scripts
 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
@@ -64,6 +64,7 @@ tar cpf - \
     build/isofs/kernel \
     build/passwd \
     build/version.txt \
+       bootcustom.sh \
     configurations \
     syslinux/unix/syslinux | \
     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -