Remove line that doesnt parse on f16. Should be ok because lxc is f14+
[bootcd.git] / bootcd.spec
index 23c1550..92d956c 100644 (file)
@@ -34,9 +34,7 @@ Requires: dosfstools, mkisofs, gzip, mtools, syslinux
 Requires: yum-utils
 # mkdiskimage is used for USB-partitioned mode
 # but it now comes in a separate rpm
-%if "%{distro}" == "Fedora" && "%{distrorelease}" >= 14
 Requires: syslinux-perl
-%endif
 
 Requires: pyplnet
 
@@ -106,6 +104,8 @@ mkdir -p /lib/systemd/system
 mkdir -p /etc/systemd/system
 cp -pr systemd/* /lib/systemd/system
 ln -sf /lib/systemd/system/pl_boot.target /etc/systemd/system/default.target
+ln -sf /lib/systemd/system/pl_boot.service /lib/systemd/system/pl_boot.target.wants/pl_boot.service
+ln -sf /lib/systemd/system/pl_sysinit.service /lib/systemd/system/pl_sysinit.target.wants/pl_sysinit.service
 popd
     
 %clean