use name /etc/planetlab/nodefamily, same as within myplc
[bootcd.git] / bootcd.spec
index d1c11a1..a5f24dc 100644 (file)
@@ -3,9 +3,11 @@
 #
 %define url $URL$
 
-%define name bootcd
+%define nodefamily %{pldistro}-%{_arch}
+
+%define name bootcd-%{nodefamily}
 %define version 4.2
-%define taglevel 0
+%define taglevel 1
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -14,7 +16,7 @@ Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
 URL: %(echo %{url} | cut -d ' ' -f 2)
 
-Summary: Boot CD
+Summary: Boot CD material for %{nodefamily}
 Name: %{name}
 Version: %{version}
 Release: %{release}
@@ -22,6 +24,8 @@ License: BSD
 Group: System Environment/Base
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+# other archs must be able to install this
+BuildArch: noarch
 
 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
 
@@ -39,7 +43,7 @@ environment.
 pushd BootCD
 
 # Build the reference image
-./prep.sh %{pldistro}
+./prep.sh %{pldistro} %{nodefamily}
 
 popd
 
@@ -56,7 +60,7 @@ tar cpf - \
     build/isofs/kernel \
     build/passwd \
     build/version.txt \
-       bootcustom.sh \
+    build/nodefamily \
     configurations | \
     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
 
@@ -80,7 +84,15 @@ fi
 %defattr(-,root,root,-)
 %{_datadir}/%{name}
 
+%post
+[ -f /etc/planetlab/nodefamily ] || { mkdir -p /etc/planetlab ; echo %{nodefamily} > /etc/planetlab/nodefamily ; }
+
 %changelog
+* Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
+- new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
+- now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7) 
+- nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
+
 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
 - kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
 - build.sh cleaned up in the process