use name /etc/planetlab/nodefamily, same as within myplc
[bootcd.git] / bootcd.spec
index fce1af2..a5f24dc 100644 (file)
@@ -1,20 +1,31 @@
-%define name bootcd
-%define version 3.4
-%define release 2%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+#
+# $Id$
+#
+%define url $URL$
+
+%define nodefamily %{pldistro}-%{_arch}
+
+%define name bootcd-%{nodefamily}
+%define version 4.2
+%define taglevel 1
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 4.0
-URL: http://cvs.planet-lab.org/cvs/bootcd
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
 
-Summary: Boot CD
-Name: bootcd
+Summary: Boot CD material for %{nodefamily}
+Name: %{name}
 Version: %{version}
 Release: %{release}
 License: BSD
 Group: System Environment/Base
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+# other archs must be able to install this
+BuildArch: noarch
 
 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
 
@@ -25,14 +36,6 @@ AutoReqProv: no
 The Boot CD securely boots PlanetLab nodes into an immutable
 environment.
 
-%package planetlab
-Summary: PlanetLab Boot CD
-Group: System Environment/Base
-
-%description planetlab
-The default PlanetLab Boot CD, customized to boot from PlanetLab
-Central servers.
-
 %prep
 %setup -q
 
@@ -40,13 +43,7 @@ Central servers.
 pushd BootCD
 
 # Build the reference image
-./prep.sh %{pldistro}
-
-# Build the default configuration (PlanetLab)
-./build.sh
-
-md5sum PlanetLab-BootCD-%{version}.{iso,usb} \
-    >PlanetLab-BootCD-%{version}.md5
+./prep.sh %{pldistro} %{nodefamily}
 
 popd
 
@@ -60,20 +57,13 @@ install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
 tar cpf - \
     build/isofs/bootcd.img \
-    build/isofs/isolinux.bin \
     build/isofs/kernel \
     build/passwd \
     build/version.txt \
-       bootcustom.sh \
-    configurations \
-    syslinux/unix/syslinux | \
+    build/nodefamily \
+    configurations | \
     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
 
-# Install the default images in the download/ directory
-install -d -m 755 $RPM_BUILD_ROOT/var/www/html/download
-install -m 644 PlanetLab-BootCD-%{version}.* \
-    $RPM_BUILD_ROOT/var/www/html/download/
-
 popd
     
 %clean
@@ -90,25 +80,39 @@ if [ -n "$SUDO_USER" ] ; then
     chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
 fi
 
-%post planetlab
-cat <<EOF
-Remember to GPG sign
-/var/www/html/download/PlanetLab-BootCD-%{version}.{iso,usb} with
-the PlanetLab private key.
-EOF
-
 %files
 %defattr(-,root,root,-)
 %{_datadir}/%{name}
 
-%files planetlab
-%defattr(-,root,root,-)
-/var/www/html/download
+%post
+[ -f /etc/planetlab/nodefamily ] || { mkdir -p /etc/planetlab ; echo %{nodefamily} > /etc/planetlab/nodefamily ; }
 
 %changelog
+* Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
+- new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
+- now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7) 
+- nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
+
+* Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
+- kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
+- build.sh cleaned up in the process
+- actual location of selected node config file displayed
+- import pypci rather than pypciscan
+
+* Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
+- build.sh support for -s <console_spec> (recommended vs using type)
+- build.sh cleanup - usage clearer wrt types - removed old code
+- fixed modprobe with args in pl_hwinit
+
+* Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
+- load floppy with modprobe flags
+- support for creating a usb partition
+- removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
+
 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
 - added biginitrd usb image
 
 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
 - Initial build.
 
+%define module_current_branch 3.4