- reviewed usage, for more relevance (lists all actually supported types)
[bootcd.git] / bootcd.spec
index 577f6ba..b353af1 100644 (file)
@@ -1,16 +1,21 @@
+#
+# $Id$
+#
+%define url $URL$
+
 %define name bootcd
-%define version 3.2
-%define release 1.planetlab%{?date:.%{date}}
-# XXX Get this from /etc/planetlab
-%define configuration default
+%define version 3.4
+%define taglevel 3
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 3.2
-URL: http://cvs.planet-lab.org/cvs/bootcd_v3
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
 
-Summary: The PlanetLab Boot CD
-Name: bootcd
+Summary: Boot CD
+Name: %{name}
 Version: %{version}
 Release: %{release}
 License: BSD
@@ -18,63 +23,72 @@ Group: System Environment/Base
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
+Requires: dosfstools, mkisofs, gzip, mtools, syslinux
+
 AutoReqProv: no
 %define debug_package %{nil}
 
 %description
-The PlanetLab Boot CD securely boots PlanetLab nodes into an immutable
+The Boot CD securely boots PlanetLab nodes into an immutable
 environment.
 
 %prep
 %setup -q
 
 %build
-./build.sh build %{configuration}
+pushd BootCD
+
+# Build the reference image
+./prep.sh %{pldistro}
+
+popd
 
 %install
-install -d $RPM_BUILD_ROOT/var/www/html/download
-pushd build/%{configuration}
-bzip2 -c PlanetLab-BootCD-%{version}.iso > \
-    $RPM_BUILD_ROOT/var/www/html/download/PlanetLab-BootCD-%{version}.iso.bz2
-bzip2 -c PlanetLab-BootCD-%{version}.usb > \
-    $RPM_BUILD_ROOT/var/www/html/download/PlanetLab-BootCD-%{version}.usb.bz2
-md5sum PlanetLab-BootCD-%{version}.{iso,usb} >> \
-    $RPM_BUILD_ROOT/var/www/html/download/PlanetLab-BootCD-%{version}.md5
-cd $RPM_BUILD_ROOT/var/www/html/download/
-md5sum PlanetLab-BootCD-%{version}.{iso,usb}.bz2 >> \
-    PlanetLab-BootCD-%{version}.md5
+rm -rf $RPM_BUILD_ROOT
+
+pushd  BootCD
+
+# Install the reference image and build scripts
+install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
+install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
+tar cpf - \
+    build/isofs/bootcd.img \
+    build/isofs/kernel \
+    build/passwd \
+    build/version.txt \
+       bootcustom.sh \
+    configurations | \
+    tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
+
 popd
     
-# If run under sudo, allow user to delete the build directory
-if [ -n "$SUDO_USER" ] ; then
-    chown -R $SUDO_USER .
-    # Some temporary cdroot files like /var/empty/sshd and
-    # /usr/bin/sudo get created with non-readable permissions.
-    find . -not -perm +0600 -exec chmod u+rw {} \;
-fi
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-# If run under sudo, allow user to delete the built RPM
+# If run under sudo
 if [ -n "$SUDO_USER" ] ; then
-    chown $SUDO_USER %{_rpmdir}/%{_arch}/%{name}-%{version}-%{release}.%{_arch}.rpm
+    # Allow user to delete the build directory
+    chown -h -R $SUDO_USER .
+    # Some temporary cdroot files like /var/empty/sshd and
+    # /usr/bin/sudo get created with non-readable permissions.
+    find . -not -perm +0600 -exec chmod u+rw {} \;
+    # Allow user to delete the built RPM(s)
+    chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
 fi
 
-%post
-cat <<EOF
-Remember to GPG sign
-/var/www/html/download/PlanetLab-BootCD-%{version}.{iso,usb}.bz2 with
-the PlanetLab private key.
-EOF
-
 %files
 %defattr(-,root,root,-)
-/var/www/html/download/PlanetLab-BootCD-%{version}.iso.bz2
-/var/www/html/download/PlanetLab-BootCD-%{version}.usb.bz2
-/var/www/html/download/PlanetLab-BootCD-%{version}.md5
+%{_datadir}/%{name}
 
 %changelog
+* Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
+- load floppy with modprobe flags
+- support for creating a usb partition
+- removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
+
+* Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
+- added biginitrd usb image
+
 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
 - Initial build.