- reviewed usage, for more relevance (lists all actually supported types)
[bootcd.git] / bootcd.spec
index db28e6c..b353af1 100644 (file)
@@ -1,14 +1,21 @@
+#
+# $Id$
+#
+%define url $URL$
+
 %define name bootcd
 %define version 3.4
-%define release 2%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define taglevel 3
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 4.0
-URL: http://cvs.planet-lab.org/cvs/bootcd
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
 
 Summary: Boot CD
-Name: bootcd
+Name: %{name}
 Version: %{version}
 Release: %{release}
 License: BSD
@@ -16,7 +23,7 @@ Group: System Environment/Base
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
-Requires: dosfstools, mkisofs, gzip
+Requires: dosfstools, mkisofs, gzip, mtools, syslinux
 
 AutoReqProv: no
 %define debug_package %{nil}
@@ -25,55 +32,34 @@ AutoReqProv: no
 The Boot CD securely boots PlanetLab nodes into an immutable
 environment.
 
-%package planetlab
-Summary: PlanetLab Boot CD
-Group: System Environment/Base
-
-%description planetlab
-The default PlanetLab Boot CD, customized to boot from PlanetLab
-Central servers.
-
 %prep
 %setup -q
 
 %build
-pushd bootcd
+pushd BootCD
 
 # Build the reference image
-./prep.sh -a $(uname -i) -r $([ -f "/etc/fedora-release" ] && awk ' { if ($3=="Core") print $4; else print $3 } ' /etc/fedora-release || echo 4)
-
-# Build the default configuration (PlanetLab)
-./build.sh
-
-md5sum PlanetLab-BootCD-%{version}.{iso,usb} \
-    >PlanetLab-BootCD-%{version}.md5
+./prep.sh %{pldistro}
 
 popd
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-pushd bootcd
+pushd  BootCD
 
 # Install the reference image and build scripts
 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
 tar cpf - \
     build/isofs/bootcd.img \
-    build/isofs/isolinux.bin \
     build/isofs/kernel \
     build/passwd \
     build/version.txt \
        bootcustom.sh \
-    configurations \
-    syslinux/unix/syslinux | \
+    configurations | \
     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
 
-# Install the default images in the download/ directory
-install -d -m 755 $RPM_BUILD_ROOT/var/www/html/download
-install -m 644 PlanetLab-BootCD-%{version}.* \
-    $RPM_BUILD_ROOT/var/www/html/download/
-
 popd
     
 %clean
@@ -90,22 +76,16 @@ if [ -n "$SUDO_USER" ] ; then
     chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
 fi
 
-%post planetlab
-cat <<EOF
-Remember to GPG sign
-/var/www/html/download/PlanetLab-BootCD-%{version}.{iso,usb} with
-the PlanetLab private key.
-EOF
-
 %files
 %defattr(-,root,root,-)
 %{_datadir}/%{name}
 
-%files planetlab
-%defattr(-,root,root,-)
-/var/www/html/download
-
 %changelog
+* Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
+- load floppy with modprobe flags
+- support for creating a usb partition
+- removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
+
 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
 - added biginitrd usb image