added kupdate.sh
[bootcd.git] / bootcd.spec
index a5f24dc..bfbc125 100644 (file)
@@ -7,9 +7,11 @@
 
 %define name bootcd-%{nodefamily}
 %define version 4.2
-%define taglevel 1
+%define taglevel 9
 
-%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+# pldistro already in the rpm name
+#%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define release %{taglevel}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
@@ -29,6 +31,8 @@ BuildArch: noarch
 
 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
 
+Requires: pyplnet
+
 AutoReqProv: no
 %define debug_package %{nil}
 
@@ -55,6 +59,7 @@ pushd  BootCD
 # Install the reference image and build scripts
 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
+install -m 755 kupdate.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
 tar cpf - \
     build/isofs/bootcd.img \
     build/isofs/kernel \
@@ -88,6 +93,35 @@ fi
 [ -f /etc/planetlab/nodefamily ] || { mkdir -p /etc/planetlab ; echo %{nodefamily} > /etc/planetlab/nodefamily ; }
 
 %changelog
+* Tue Dec 30 2008 Marc E. Fiuczynski <daniel@hozac.com> - BootCD-4.2-9
+- Added kupdate.sh
+
+* Sat Dec 13 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-8
+- Use pyplnet.
+- Add a site_admin account to the BootCD.
+- Add some explanations for common errors.
+
+* Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-7
+- Allow multiple -k options to the build.sh script.
+- Probe devices in PCI bus order.
+
+* Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-6
+- add support for fedora9 images - compliant with upstart
+- formerly monolythic dir 'conf_files/' split into 'etc/' and 'initscripts/'
+
+* Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-5
+- cosmetic - pl_boot to display timestamps
+
+* Mon Aug 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-4
+- adds -k as an argument to build.sh to pass additional kernel parameters to the
+- bootcd and kexec kernel.
+
+* Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-3
+- rpm release tag does not need pldistro as it is already part of the rpm name
+
+* Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-2
+- change location of nodefamily in /etc/planetlab/
+
 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
 - new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
 - now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7)