previous commit requires lots of changes in other modules so introduce a quick hack...
[bootcd.git] / bootcd.spec
index e645746..e07379f 100644 (file)
@@ -1,13 +1,9 @@
 #
-# $Id$
-#
-%define url $URL$
-
 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
 
 %define name bootcd-%{nodefamily}
 %define version 5.0
-%define taglevel 3
+%define taglevel 6
 
 # pldistro already in the rpm name
 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -20,7 +16,7 @@
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
-URL: %(echo %{url} | cut -d ' ' -f 2)
+URL: %{SCMURL}
 
 Summary: Boot CD material for %{nodefamily}
 Name: %{name}
@@ -67,7 +63,9 @@ Conflicts: MyPLC <= 4.3
 %setup -q
 
 %build
-pushd BootCD
+[ -d bootcd ] || ln -s BootCD bootcd
+
+pushd bootcd
 
 # Build the reference image
 ./prep.sh %{pldistro} %{nodefamily}
@@ -77,7 +75,7 @@ popd
 %install
 rm -rf $RPM_BUILD_ROOT
 
-pushd  BootCD
+pushd bootcd
 
 # Install the reference image and build scripts
 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
@@ -109,6 +107,15 @@ rm -rf $RPM_BUILD_ROOT
 /etc/plc.d
 
 %changelog
+* Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-6
+- use /usr/lib/syslinux/mkdiskimage or installed mkdiskimage
+
+* Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-5
+- remove remainging reference to planet-lab.org
+
+* Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-4
+- module name changes
+
 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-3
 - nicer initscript now uses 'action' from /etc/init.d/functions