iterate
[bootmanager.git] / bootmanager.spec
index 8dc4eb5..0ef34e5 100644 (file)
@@ -3,9 +3,7 @@
 #
 %define url $URL$
 
-%define nodefamily %{pldistro}-%{_arch}
-
-%define name bootmanager-%{nodefamily}
+%define name bootmanager
 %define version 4.3
 %define taglevel 16
 
@@ -31,10 +29,11 @@ Requires: PLCAPI >= 4.3
 # the python code packaged in these are shipped on the node as well
 Requires: pypcilib pyplnet monitor-runlevelagent
 
-# plc.d/bootmanager is moving
-Conflicts: myplc <= 4.3.37
-# nodeconfig/boot/index.php is moving
-Conflicts: nodeconfig <= 4.3.7
+### avoid having yum complain about updates, as stuff is moving around
+# plc.d/bootmanager
+Conflicts: myplc <= 4.3-37
+# nodeconfig/boot/*
+Conflicts: nodeconfig <= 4.3-7
 
 AutoReqProv: no
 %define debug_package %{nil}
@@ -58,22 +57,18 @@ find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular
 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
 
 # formerly in the nodeconfig module
-install -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
+install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
+install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
 
 # formerly in the MyPLC module
-install -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/pld.c/bootmanager
-
-#touch bootmanager.sh
-#install -D -m 755 bootmanager.sh $RPM_BUILD_ROOT/var/www/html/boot/bootmanager.sh
-
-# This is only required for 2.x bootcds.
-install -D -m 644 support-files/uudecode.gz $RPM_BUILD_ROOT/var/www/html/boot/uudecode.gz
+install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-# signing of botmanager.sh occurs as part of plc.d/bootmanager
+# signing of botmanager.sh occurs as part of /etc/plc.d/bootmanager
+# which in turn invokes build.sh
 
 # NOTE: do not run this agent when installed on a myplc.
 # xxx - a bit hacky maybe
@@ -84,9 +79,7 @@ chkconfig --del monitor-runlevelagent
 %defattr(-,root,root,-)
 %{_datadir}/%{name}
 /var/www/html/boot/index.php
-/etc/pld.c/bootmanager
-/var/www/html/boot/uudecode.gz
-#%ghost /var/www/html/boot/bootmanager.sh
+/etc/plc.d/bootmanager
 
 %changelog
 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16