fixed and moved the server-side yum scripts, from nodeconfig/yum to BootstrapFS/nodec...
[bootmanager.git] / bootmanager.spec
index 65575f8..460b86d 100644 (file)
@@ -4,8 +4,8 @@
 %define url $URL$
 
 %define name bootmanager
-%define version 4.3
-%define taglevel 16
+%define version 5.0
+%define taglevel 0
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -25,15 +25,18 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildArch: noarch
 
 Requires: tar, gnupg, sharutils, bzip2, pypcilib
-Requires: PLCAPI >= 4.3
+# need the apache user at install-time
+Requires: httpd 
+
+Requires: PLCAPI >= 5.0
 # the python code packaged in these are shipped on the node as well
 Requires: pypcilib pyplnet monitor-runlevelagent
 
 ### avoid having yum complain about updates, as stuff is moving around
 # plc.d/bootmanager
-Conflicts: myplc <= 4.3-37
+Conflicts: myplc <= 4.3
 # nodeconfig/boot/*
-Conflicts: nodeconfig <= 4.3-7
+Conflicts: nodeconfig <= 4.3
 
 AutoReqProv: no
 %define debug_package %{nil}
@@ -59,6 +62,7 @@ install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
 # formerly in the nodeconfig module
 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
+install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
 
 # formerly in the MyPLC module
 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
@@ -67,8 +71,10 @@ install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
 rm -rf $RPM_BUILD_ROOT
 
 %post
-# signing of botmanager.sh occurs as part of /etc/plc.d/bootmanager
-# which in turn invokes build.sh
+# initialize the boot manager upload area
+mkdir -p /var/log/bm
+chown apache:apache /var/log/bm
+chmod 700 /var/log/bm
 
 # NOTE: do not run this agent when installed on a myplc.
 # xxx - a bit hacky maybe
@@ -80,6 +86,7 @@ chkconfig --del monitor-runlevelagent
 %{_datadir}/%{name}
 /var/www/html/boot/index.php
 /var/www/html/boot/upload-bmlog.php
+/var/www/html/boot/getnodeid.php
 /etc/plc.d/bootmanager
 
 %changelog
@@ -189,4 +196,4 @@ chkconfig --del monitor-runlevelagent
 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
 - Initial build.
 
-%define module_current_branch 3.2
+%define module_current_branch 4.3