Fix indentation.
[bootmanager.git] / bootmanager.spec
index 9098895..7e93992 100644 (file)
@@ -3,7 +3,7 @@
 #
 %define name bootmanager
 %define version 3.2
-%define subversion 1
+%define subversion 2
 
 %define release %{subversion}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -34,25 +34,19 @@ nodes.
 %setup -q
 
 %build
-pushd BootManager
-./build.sh
-popd
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-pushd BootManager
-
 # Install source so that it can be rebuilt
 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/
 
+touch bootmanager.sh
 install -D -m 755 bootmanager.sh $RPM_BUILD_ROOT/var/www/html/boot/bootmanager.sh
 
 # This is only required for 2.x bootcds.
 install -D -m 644 support-files/uudecode.gz $RPM_BUILD_ROOT/var/www/html/boot/uudecode.gz
 
-popd
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -76,7 +70,8 @@ EOF
 %files
 %defattr(-,root,root,-)
 %{_datadir}/%{name}
-/var/www/html/boot/*
+%ghost /var/www/html/boot/bootmanager.sh
+/var/www/html/boot/uudecode.gz
 
 %changelog
 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> -