Cross module commit for 'diag' and 'disabled' node states.
[bootmanager.git] / bootmanager.spec
index 07c7de5..7e93992 100644 (file)
@@ -2,14 +2,14 @@
 # $Id: bootmanager.spec 856 2007-09-21 13:54:58Z thierry $
 #
 %define name bootmanager
-%define version 3.1
-%define subversion 16
+%define version 3.2
+%define subversion 2
 
 %define release %{subversion}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 4.1
+Distribution: PlanetLab 4.2
 URL: http://cvs.planet-lab.org/cvs/bootmanager
 
 Summary: The PlanetLab Boot Manager
@@ -21,7 +21,7 @@ Group: System Environment/Base
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
-Requires: tar, gnupg, sharutils, bzip2
+Requires: tar, gnupg, sharutils, bzip2, pypcilib
 
 AutoReqProv: no
 %define debug_package %{nil}
@@ -34,25 +34,19 @@ nodes.
 %setup -q
 
 %build
-pushd BootManager
-./build.sh
-popd
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-pushd BootManager
-
 # Install source so that it can be rebuilt
 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/
 
+touch bootmanager.sh
 install -D -m 755 bootmanager.sh $RPM_BUILD_ROOT/var/www/html/boot/bootmanager.sh
 
 # This is only required for 2.x bootcds.
 install -D -m 644 support-files/uudecode.gz $RPM_BUILD_ROOT/var/www/html/boot/uudecode.gz
 
-popd
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -76,7 +70,8 @@ EOF
 %files
 %defattr(-,root,root,-)
 %{_datadir}/%{name}
-/var/www/html/boot/*
+%ghost /var/www/html/boot/bootmanager.sh
+/var/www/html/boot/uudecode.gz
 
 %changelog
 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> -