run fsck prior to mount. should address hanging-mount failures on
[bootmanager.git] / bootmanager.spec
index 77a4e00..ab88c96 100644 (file)
@@ -5,7 +5,7 @@
 
 %define name bootmanager
 %define version 3.2
-%define taglevel 10
+%define taglevel 15
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -36,7 +36,7 @@ nodes.
 %setup -q
 
 %build
-gcc -shared -fPIC -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
+gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -77,6 +77,26 @@ EOF
 /var/www/html/boot/uudecode.gz
 
 %changelog
+* Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-3.2-15
+- Added in Daniel's support to only create a small /vserver and leave
+- remaining disks alone so that their partitions can be used as raw
+- disk extents by slices
+
+* Mon Dec 15 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-3.2-14
+- Use pyplnet.
+- Order devices by PCI slot number.
+- Module debugging code.
+
+* Fri Sep 26 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-3.2-13
+- include latest module tweaks in current production bootmanager.
+
+* Tue Jul 08 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-3.2-12
+- correctly convert port number to int before creating HTTPSConnection() object,
+- plus other changes to file to accomodate this.
+
+* Wed Jul 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-3.2-11
+- More hacks.
+
 * Tue Jul 01 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-3.2-10
 - Make the hack work.