run fsck prior to mount. should address hanging-mount failures on
[bootmanager.git] / bootmanager.spec
index 825761e..ab88c96 100644 (file)
@@ -5,7 +5,7 @@
 
 %define name bootmanager
 %define version 3.2
-%define taglevel 4
+%define taglevel 15
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -36,6 +36,7 @@ nodes.
 %setup -q
 
 %build
+gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -76,6 +77,53 @@ EOF
 /var/www/html/boot/uudecode.gz
 
 %changelog
+* Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-3.2-15
+- Added in Daniel's support to only create a small /vserver and leave
+- remaining disks alone so that their partitions can be used as raw
+- disk extents by slices
+
+* Mon Dec 15 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-3.2-14
+- Use pyplnet.
+- Order devices by PCI slot number.
+- Module debugging code.
+
+* Fri Sep 26 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-3.2-13
+- include latest module tweaks in current production bootmanager.
+
+* Tue Jul 08 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-3.2-12
+- correctly convert port number to int before creating HTTPSConnection() object,
+- plus other changes to file to accomodate this.
+
+* Wed Jul 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-3.2-11
+- More hacks.
+
+* Tue Jul 01 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-3.2-10
+- Make the hack work.
+
+* Tue Jul 01 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-3.2-9
+- Ugly hack stuff.
+
+* Fri Jun 27 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - BootManager-3.2-8
+- move the UpdateNodeConfiguration step after the NodeUpdate step in ChainBoot
+
+* Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
+- dont unload cpqphp
+
+* Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
+- changes in the state automaton logic 
+- root+swap = 7G
+- usb-key threshhold increased to 17 G
+- bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
+
+* Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
+- renamed step InstallBootstrapRPM into InstallBootstrapFS
+- reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
+- import pypcimap rather than pypciscan
+- initial downlaoding of plc_config made more robust
+- root and /vservers file systems mounted ext3
+- calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
+- also seems to be using session-based authentication rather than former hmac-based one
+
 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
 - usage of wireless attributes fixed and tested
 - breakpoints cleaned up (no change for production)