Setting tag bootmanager-5.0-11
[bootmanager.git] / bootmanager.spec
index 58efc5d..b1bb876 100644 (file)
@@ -4,8 +4,8 @@
 %define url $URL$
 
 %define name bootmanager
-%define version 4.3
-%define taglevel 16
+%define version 5.0
+%define taglevel 11
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -25,15 +25,18 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildArch: noarch
 
 Requires: tar, gnupg, sharutils, bzip2, pypcilib
-Requires: PLCAPI >= 4.3
+# need the apache user at install-time
+Requires: httpd 
+
+Requires: PLCAPI >= 5.0
 # the python code packaged in these are shipped on the node as well
 Requires: pypcilib pyplnet monitor-runlevelagent
 
 ### avoid having yum complain about updates, as stuff is moving around
 # plc.d/bootmanager
-Conflicts: myplc <= 4.3-37
+Conflicts: myplc <= 4.3
 # nodeconfig/boot/*
-Conflicts: nodeconfig <= 4.3-7
+Conflicts: nodeconfig <= 4.3
 
 AutoReqProv: no
 %define debug_package %{nil}
@@ -68,8 +71,10 @@ install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
 rm -rf $RPM_BUILD_ROOT
 
 %post
-# signing of botmanager.sh occurs as part of /etc/plc.d/bootmanager
-# which in turn invokes build.sh
+# initialize the boot manager upload area
+mkdir -p /var/log/bm
+chown apache:apache /var/log/bm
+chmod 700 /var/log/bm
 
 # NOTE: do not run this agent when installed on a myplc.
 # xxx - a bit hacky maybe
@@ -85,6 +90,46 @@ chkconfig --del monitor-runlevelagent
 /etc/plc.d/bootmanager
 
 %changelog
+* Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
+- replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
+
+* Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
+- Fix typo
+
+* Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
+- fix typo
+
+* Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
+- disable time/count based filesystem checks
+
+* Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
+- Fix new disk additions to LVM array
+
+* Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
+- bugfix for centos5/python2.4 missing hashlib
+
+* Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
+- check sha1sum of downloaded bootstrapfs
+- try recovering filesystem errors
+
+* Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
+- nicer initscript now uses 'action' from /etc/init.d/functions
+- bugfix for nodes with extensions
+
+* Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
+- create /etc/planetlab if missing
+- uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
+
+* Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
+- caglar's change to run MkInitrd right before kexec
+- plus clean up old code
+
+* Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
+- first working version of 5.0:
+- pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
+- uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
+- installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
+
 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
 - support for fedora 12
 
@@ -191,4 +236,4 @@ chkconfig --del monitor-runlevelagent
 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
 - Initial build.
 
-%define module_current_branch 3.2
+%define module_current_branch 4.3